Jump to content

TFTP Cisco 7941


Worm78
 Share

Recommended Posts

I'm working with a csico 7941 on a multi domain windows 3.4 server

 

Currently the system is all snom phones and i'm trying to add a few cisco phones.

 

I have TFTP working on another test PC (not a pbx system) and I have upgraded the firmware to SIP and tested some xml config files. All seems to be working.

 

Problem is once moved to the PBX tftp isn't working. I believe all the correct files are in place.

 

Wondering if this is caused by no gateway on the lan nic? If so can I add the pbx internal IP as its gateway with no other issues?

 

On the positive side if I add the mac address to an extension the system is generating a cfg file in the proper domain folder.

 

next question is once I have TFTP working should I fear all my old Snom phones that were manually setup failing? I just upgraded to 3.4 and have not used PNP at all in the past.

 

 

Thanks,

Brian

 

 

Here is the log after reboot.

 

 

[1] 2009/07/21 21:11:49: Starting up version 3.4.0.3201

[7] 2009/07/21 21:11:49: Found time zones HST AKDT AKST PDT PST MDT MST CDT CST2 EDT EST ADT AST NDT NST BST CET GMT+2 GMT+3 GMT+4 GMT+5 GMT+6 GMT+7 GMT+8 GMT+9 CST CAT IST AUS1 AUS2 AUS3 AUS4 AUS5 AUS6 GMT

[1] 2009/07/21 21:11:49: Working Directory is C:\Program Files\pbxnsip\PBX

[7] 2009/07/21 21:11:49: UDP: Opening socket on 0.0.0.0

[5] 2009/07/21 21:11:49: Starting threads

[7] 2009/07/21 21:11:49: UDP: Opening socket on 0.0.0.0

[7] 2009/07/21 21:11:49: TCP: Opening socket on 0.0.0.0:80

[7] 2009/07/21 21:11:49: TCP: Opening socket on 0.0.0.0:443

[7] 2009/07/21 21:11:49: UDP: Opening socket on 0.0.0.0:161

[7] 2009/07/21 21:11:49: UDP: Opening socket on 0.0.0.0:69

[7] 2009/07/21 21:11:49: UDP: Opening socket on 0.0.0.0:5060

[7] 2009/07/21 21:11:49: TCP: Opening socket on 0.0.0.0:5060

[7] 2009/07/21 21:11:49: TCP: Opening socket on 0.0.0.0:5061

Link to comment
Share on other sites

Please turn the TFTP logging on the PBX (also set the log level to 8) then reboot the CISCO phone. We should see some logs. PBX matches MAC address of the CISCO phone with an internal list of MAC addresses range. It could be that your CISCO mac address is not in the range too. Could you plesae post the first 6 digits of the MAC address?

 

I'm working with a csico 7941 on a multi domain windows 3.4 server

 

Currently the system is all snom phones and i'm trying to add a few cisco phones.

 

I have TFTP working on another test PC (not a pbx system) and I have upgraded the firmware to SIP and tested some xml config files. All seems to be working.

 

Problem is once moved to the PBX tftp isn't working. I believe all the correct files are in place.

 

Wondering if this is caused by no gateway on the lan nic? If so can I add the pbx internal IP as its gateway with no other issues?

 

On the positive side if I add the mac address to an extension the system is generating a cfg file in the proper domain folder.

 

next question is once I have TFTP working should I fear all my old Snom phones that were manually setup failing? I just upgraded to 3.4 and have not used PNP at all in the past.

 

 

Thanks,

Brian

Link to comment
Share on other sites

Mac starts with 0019E7

 

I have the log set to 8 and have tftp only checked and get nothing. This has always been the case. I don't think tftp is working. What did you think of the log file showing 0.0.0.0 for the tftp IP?

 

 

 

 

 

 

 

 

 

Please turn the TFTP logging on the PBX (also set the log level to 8) then reboot the CISCO phone. We should see some logs. PBX matches MAC address of the CISCO phone with an internal list of MAC addresses range. It could be that your CISCO mac address is not in the range too. Could you plesae post the first 6 digits of the MAC address?
Link to comment
Share on other sites

Mac starts with 0019E7

 

I have the log set to 8 and have tftp only checked and get nothing. This has always been the case. I don't think tftp is working. What did you think of the log file showing 0.0.0.0 for the tftp IP?

 

 

That mac range is supported. So it is not unknown mac address issue.

 

You can run the wireshark to see whether the phone is able to contact the PBX. If the phone is contacting the PBX (i.e., no network issues), then put the mac address of the phone under any of the extensions. Also, keep the CISCO firmware files on the tftp directory. Once these steps are complete, you can factory reset the phone and it should come up configured. Checkout this page for some help on factory reset.

https://www.pbxnsipsupport.com/index.php?_m...kbarticleid=399

Link to comment
Share on other sites

Any comment on the 0.0.0.0 address? Is that normal and can it work with this being listed? I have had the mac address under a user and it creates a folder in generated labeled with the correct ext and domain. Fails to pull files from the tftp location.

 

FYI System is on its own network with dual nics. A small rounter has its lan side plugged in to handle dhcp only. Lan (internal) side of pbx has no gateway. If anything is entered in the field my trunks go down. Wan is currently plugged directly to public switch.

 

 

That mac range is supported. So it is not unknown mac address issue.

 

You can run the wireshark to see whether the phone is able to contact the PBX. If the phone is contacting the PBX (i.e., no network issues), then put the mac address of the phone under any of the extensions. Also, keep the CISCO firmware files on the tftp directory. Once these steps are complete, you can factory reset the phone and it should come up configured. Checkout this page for some help on factory reset.

https://www.pbxnsipsupport.com/index.php?_m...kbarticleid=399

Link to comment
Share on other sites

Any comment on the 0.0.0.0 address? Is that normal and can it work with this being listed? I have had the mac address under a user and it creates a folder in generated labeled with the correct ext and domain. Fails to pull files from the tftp location.

 

FYI System is on its own network with dual nics. A small rounter has its lan side plugged in to handle dhcp only. Lan (internal) side of pbx has no gateway. If anything is entered in the field my trunks go down. Wan is currently plugged directly to public switch.

 

0.0.0.0 address is normal.

 

Under the TFTP folder you should have only the firmware files. Based on the generated folder's content, it looks like the phone is contacting the PBX and PBX is generating provisioning file for the phone. The question is - is the generated file is reaching the phone? Wireshark should show the details.

Link to comment
Share on other sites

I grabbed a new phone from the box and it seems to be pulling tftp firmware updates. Waiting to see if the phone config files come over.

 

 

Phone booted SIP, but not registering. Phone says registering over and over. Here is log.

 

Wireshark shows the phone tring to access the server IP for a bit with a SIP 404 error. In web gui there is nothing under registration popping up and the log doesn't show any registering other then what is below.

 

 

 

 

 

 

 

[6] 2009/07/22 17:41:58: TFTP: File CTLSEP0019E75AA7C0.tlv not found

[6] 2009/07/22 17:41:59: TFTP: Request SEP0019E75AA7C0.cnf.xml

[7] 2009/07/22 17:41:59: UDP: Opening socket on 0.0.0.0

[7] 2009/07/22 17:41:59: Open TFTP port 1589

[8] 2009/07/22 17:41:59: TFTP: Transfer finished successfully

[6] 2009/07/22 17:42:08: TFTP: File /mk-sip.jar not found

[7] 2009/07/22 17:42:13: UDP: Opening socket on 0.0.0.0

[7] 2009/07/22 17:42:13: Open TFTP port 1590

[6] 2009/07/22 17:42:13: TFTP: Request dialplan.xml

[8] 2009/07/22 17:42:13: TFTP: Transfer finished successfully

Link to comment
Share on other sites

Is this a single domain or a multi-domain system? Based in the TFTP log, it looks like the communication between the PBX and the phone is fine.

Open SEP0019E75AA7C0.cnf.xml and see anything suspicious about the user name, password or the domain. I am assuming that this file is created under <working dir>/generated/<domain>/<extension> and not under <working dir>/tftp.

 

 

 

I grabbed a new phone from the box and it seems to be pulling tftp firmware updates. Waiting to see if the phone config files come over.

 

 

Phone booted SIP, but not registering. Phone says registering over and over. Here is log.

 

Wireshark shows the phone tring to access the server IP for a bit with a SIP 404 error. In web gui there is nothing under registration popping up and the log doesn't show any registering other then what is below.

 

 

 

 

 

 

 

[6] 2009/07/22 17:41:58: TFTP: File CTLSEP0019E75AA7C0.tlv not found

[6] 2009/07/22 17:41:59: TFTP: Request SEP0019E75AA7C0.cnf.xml

[7] 2009/07/22 17:41:59: UDP: Opening socket on 0.0.0.0

[7] 2009/07/22 17:41:59: Open TFTP port 1589

[8] 2009/07/22 17:41:59: TFTP: Transfer finished successfully

[6] 2009/07/22 17:42:08: TFTP: File /mk-sip.jar not found

[7] 2009/07/22 17:42:13: UDP: Opening socket on 0.0.0.0

[7] 2009/07/22 17:42:13: Open TFTP port 1590

[6] 2009/07/22 17:42:13: TFTP: Request dialplan.xml

[8] 2009/07/22 17:42:13: TFTP: Transfer finished successfully

Link to comment
Share on other sites

Multi domain and the file is being created under <working dir>/generated/<domain>/<extension>

 

The file created is named sep_cnf.xml no mac in the middle.

 

I tired to change the file name to SEPmacaddress.cnf.xml I rebooted the phone and it will create a new file named sep_cnf.xml in the same folder.

 

 

Name and password look correct in file.

 

 

 

May be having the same issue as this guy. No confirmed resolution posted. I have tried his suggestion on the generated fileb ut it is changed back. I also copied this file, edited his suggested changes, named it correctly and added it to the tftp folder. No luck

 

If I do try the manual method does anyone know where domain or registrar info is in regards to the xml file, my snom phones call it a registrar intheri xml but this is not an option in cisco files.

 

 

http://forum.pbxnsip.com/index.php?showtopic=367

 

 

Here is the phone trying to register.

 

[7] 2009/07/23 09:21:15: SIP Rx udp:192.168.1.27:49155:

REGISTER sip:192.168.1.254 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.27:5060;branch=z9hG4bK5e6b91a6

From: <sip:311@192.168.1.254>;tag=0019e75aa7c00002852f4b58-34de90ae

To: <sip:311@192.168.1.254>

Call-ID: 0019e75a-a7c00002-8c130b80-e2438516@192.168.1.27

Max-Forwards: 70

Date: Tue, 05 May 2009 20:34:26 GMT

CSeq: 101 REGISTER

User-Agent: Cisco-CP7941G/8.5.2

Contact: <sip:311@192.168.1.27:5060;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-0019e75aa7c0>";+u.sip!model.ccm.cisco.com="115"

Supported: (null),X-cisco-xsi-7.0.1

Content-Length: 0

Reason: SIP;cause=200;text="cisco-alarm:25 Name=SEP0019E75AA7C0 Load=SIP41.8-5-2S Last=initialized"

Expires: 3600

 

 

[7] 2009/07/23 09:21:15: SIP Tx udp:192.168.1.27:5060:

SIP/2.0 404 Not Found

Via: SIP/2.0/UDP 192.168.1.27:5060;branch=z9hG4bK5e6b91a6

From: <sip:311@192.168.1.254>;tag=0019e75aa7c00002852f4b58-34de90ae

To: <sip:311@192.168.1.254>;tag=5e54e0bea2

Call-ID: 0019e75a-a7c00002-8c130b80-e2438516@192.168.1.27

CSeq: 101 REGISTER

Content-Length: 0

 

 

[7] 2009/07/23 09:21:17: Open TFTP port 2018

[6] 2009/07/23 09:21:17: TFTP: Request dialplan.xml

 

 

 

 

 

XML file pasted below:

 

<device xsi:type="axl:XIPPhone" ctiid="1566023366">

<deviceProtocol>SIP</deviceProtocol>

<sshUserId>admin</sshUserId>

<sshPassword>admin</sshPassword>

<devicePool>

<dateTimeSetting>

<dateTemplate>D-M-YA</dateTemplate>

<timeZone>Eastern Standard/Daylight Time</timeZone>

<ntps>

<ntp>

<name>pool.ntp.org</name>

<ntpMode>Unicast</ntpMode>

</ntp>

</ntps>

</dateTimeSetting>

<callManagerGroup>

<members>

<member priority="0">

<callManager>

<ports>

<ethernetPhonePort>2000</ethernetPhonePort>

<sipPort>5060</sipPort>

<securedSipPort></securedSipPort>

</ports>

<processNodeName>192.168.1.254</processNodeName>

</callManager>

</member>

</members>

</callManagerGroup>

</devicePool>

<sipProfile>

<sipProxies>

<backupProxy></backupProxy>

<backupProxyPort>5060</backupProxyPort>

<emergencyProxy></emergencyProxy>

<emergencyProxyPort>5060</emergencyProxyPort>

<outboundProxy></outboundProxy>

<outboundProxyPort>5060</outboundProxyPort>

<registerWithProxy>true</registerWithProxy>

</sipProxies>

<sipCallFeatures>

<cnfJoinEnabled>true</cnfJoinEnabled>

<callForwardURI>x-cisco-serviceuri-cfwdall</callForwardURI>

<callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>

<callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>

<callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>

<meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>

<abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>

<rfc2543Hold>false</rfc2543Hold>

<callHoldRingback>2</callHoldRingback>

<localCfwdEnable>true</localCfwdEnable>

<semiAttendedTransfer>true</semiAttendedTransfer>

<anonymousCallBlock>2</anonymousCallBlock>

<callerIdBlocking>2</callerIdBlocking>

<dndControl>0</dndControl>

<remoteCcEnable>true</remoteCcEnable>

</sipCallFeatures>

<sipStack>

<sipInviteRetx>6</sipInviteRetx>

<sipRetx>10</sipRetx>

<timerInviteExpires>180</timerInviteExpires>

<timerRegisterExpires>3600</timerRegisterExpires>

<timerRegisterDelta>5</timerRegisterDelta>

<timerKeepAliveExpires>120</timerKeepAliveExpires>

<timerSubscribeExpires>120</timerSubscribeExpires>

<timerSubscribeDelta>5</timerSubscribeDelta>

<timerT1>500</timerT1>

<timerT2>4000</timerT2>

<maxRedirects>70</maxRedirects>

<remotePartyID>false</remotePartyID>

<userInfo>None</userInfo>

</sipStack>

<autoAnswerTimer>0</autoAnswerTimer>

<autoAnswerAltBehavior>false</autoAnswerAltBehavior>

<autoAnswerOverride>true</autoAnswerOverride>

<transferOnhookEnabled>false</transferOnhookEnabled>

<enableVad>false</enableVad>

<preferredCodec>g711</preferredCodec>

<dtmfAvtPayload>101</dtmfAvtPayload>

<dtmfDbLevel>3</dtmfDbLevel>

<dtmfOutofBand>avt</dtmfOutofBand>

<alwaysUsePrimeLine>false</alwaysUsePrimeLine>

<alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>

<kpml>3</kpml>

<natEnabled>false</natEnabled>

<natAddress></natAddress>

<phoneLabel>311</phoneLabel>

<stutterMsgWaiting>1</stutterMsgWaiting>

<callStats>false</callStats>

<silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>

<disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>

<startMediaPort>16384</startMediaPort>

<stopMediaPort>32766</stopMediaPort>

<sipLines>

<line button="1">

<featureID>9</featureID>

<featureLabel>311</featureLabel>

<proxy>192.168.1.254</proxy>

<port>5060</port>

<name>311</name>

<displayName>Cordless Phone</displayName>

<autoAnswer>

<autoAnswerEnabled>2</autoAnswerEnabled>

</autoAnswer>

<callWaiting>3</callWaiting>

<authName>311</authName>

<authPassword>123456789123</authPassword>

<sharedLine>false</sharedLine>

<messageWaitingLampPolicy>1</messageWaitingLampPolicy>

<messagesNumber>311</messagesNumber>

<ringSettingIdle>4</ringSettingIdle>

<ringSettingActive>5</ringSettingActive>

<contact>311</contact>

<forwardCallInfoDisplay>

<callerName>true</callerName>

<callerNumber>false</callerNumber>

<redirectedNumber>false</redirectedNumber>

<dialedNumber>true</dialedNumber>

</forwardCallInfoDisplay>

</line>

</sipLines>

<voipControlPort>5060</voipControlPort>

<dscpForAudio>184</dscpForAudio>

<ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>

<dialTemplate>dialplan.xml</dialTemplate>

</sipProfile>

<commonProfile>

<phonePassword>pbxnsip</phonePassword>

<backgroundImageAccess>true</backgroundImageAccess>

<callLogBlfEnabled>2</callLogBlfEnabled>

</commonProfile>

<loadInformation>SIP41.8-5-2S</loadInformation>

<vendorConfig>

<disableSpeaker>false</disableSpeaker>

<disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>

<pcPort>1</pcPort>

<settingsAccess>1</settingsAccess>

<garp>0</garp>

<voiceVlanAccess>0</voiceVlanAccess>

<videoCapability>0</videoCapability>

<autoSelectLineEnable>0</autoSelectLineEnable>

<webAccess>1</webAccess>

<spanToPCPort>1</spanToPCPort>

<loggingDisplay>1</loggingDisplay>

<loadServer></loadServer>

</vendorConfig>

<versionStamp></versionStamp>

<networkLocale></networkLocale>

<networkLocaleInfo>

<name>United_States</name>

<version>5.0(2)</version>

</networkLocaleInfo>

<deviceSecurityMode>1</deviceSecurityMode>

<authenticationURL></authenticationURL>

<directoryURL></directoryURL>

<idleURL></idleURL>

<informationURL></informationURL>

<messagesURL></messagesURL>

<proxyServerURL></proxyServerURL>

<servicesURL></servicesURL>

<dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>

<dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>

<dscpForCm2Dvce>96</dscpForCm2Dvce>

<transportLayerProtocol>4</transportLayerProtocol>

<capfAuthMode>0</capfAuthMode>

<capfList>

<capf>

<phonePort>3804</phonePort>

</capf>

</capfList>

<certHash></certHash>

<encrConfig>false</encrConfig>

</device>

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Is this a single domain or a multi-domain system? Based in the TFTP log, it looks like the communication between the PBX and the phone is fine.

Open SEP0019E75AA7C0.cnf.xml and see anything suspicious about the user name, password or the domain. I am assuming that this file is created under <working dir>/generated/<domain>/<extension> and not under <working dir>/tftp.

Link to comment
Share on other sites

SIP/2.0 404 Not Found

 

Well, that means that the PBX could not find that extension. In a single domain environment no problem; just use the name "localhost". However for multiple domains a serious problem, as the Cisco phones seem to have a hard time to use DNS names in the registration. So far the workaround is to use a different IP address for each domain. If someone finds out how to make Cisco phones send DNS names, please let us know...

 

Supported: (null),X-cisco-xsi-7.0.1

 

Not sure what RFC "(null)" refers to...

Link to comment
Share on other sites

How would you tie a domain to an IP locally?

 

Well, that means that the PBX could not find that extension. In a single domain environment no problem; just use the name "localhost". However for multiple domains a serious problem, as the Cisco phones seem to have a hard time to use DNS names in the registration. So far the workaround is to use a different IP address for each domain. If someone finds out how to make Cisco phones send DNS names, please let us know...

 

 

 

Not sure what RFC "(null)" refers to...

Link to comment
Share on other sites

How would you tie a domain to an IP locally?

 

Good point. You would have to open a socket for each IP address that you want to use. For example, in the SIP UDP sockets you would write: "12.23.34.45:5060 12.23.34.46:5060 12.23.34.47:5060 12.23.34.48:5060". The PBX remembers what socket was used when receiving a packet and stays with that socket when sending the response.

Link to comment
Share on other sites

How would you tie a domain to an IP locally?

 

Try this - use the IP address of the PBX server under <outboundProxy></outboundProxy>. The generated file does not have any value under it. Then use domain name of the extension under <proxy></proxy>, instead of 192.168.1.254. I think CISCO wants even this to be a FQDN( you can not use any dummy domain).

Link to comment
Share on other sites

After trying that I don't even see sip registration in the log. Must not like it.

 

If I keep cisco phones on only 1 of my 4 domains could I name that one doamin local host or the IP of the sever? Maybe just add an alias. I could then use snom on the other domains. My other three domains are done and working its just this one division I'm adding a domain with cisco only phones. Or would this make my other snoms "Flip Out"?

 

 

I quickly tried this and here iss the log.

 

 

7] 2009/07/24 10:16:09: SIP Rx udp:192.168.1.27:49155:

REGISTER sip:192.168.1.254 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.27:5060;branch=z9hG4bKb5be3f49

From: <sip:311@192.168.1.254>;tag=0019e75aa7c000026a467fec-812307d3

To: <sip:311@192.168.1.254>

Call-ID: 0019e75a-a7c00002-da86110e-2238b0fd@192.168.1.27

Max-Forwards: 70

Date: Tue, 05 May 2009 20:34:24 GMT

CSeq: 101 REGISTER

User-Agent: Cisco-CP7941G/8.5.2

Contact: <sip:311@192.168.1.27:5060;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-0019e75aa7c0>";+u.sip!model.ccm.cisco.com="115"

Supported: (null),X-cisco-xsi-7.0.1

Content-Length: 0

Reason: SIP;cause=200;text="cisco-alarm:25 Name=SEP0019E75AA7C0 Load=SIP41.8-5-2S Last=initialized"

Expires: 3600

 

 

[7] 2009/07/24 10:16:09: SIP Tx udp:192.168.1.27:5060:

SIP/2.0 403 Forbidden

Via: SIP/2.0/UDP 192.168.1.27:5060;branch=z9hG4bKb5be3f49

From: <sip:311@192.168.1.254>;tag=0019e75aa7c000026a467fec-812307d3

To: <sip:311@192.168.1.254>;tag=82734d6b10

Call-ID: 0019e75a-a7c00002-da86110e-2238b0fd@192.168.1.27

CSeq: 101 REGISTER

User-Agent: pbxnsip-PBX/3.4.0.3201

Content-Length: 0

 

 

 

Thanks,

Brian

Link to comment
Share on other sites

I am using the Cisco phones in multi domain mode without any issues. Here is the key to making it work, and keeping the phone stable at the same time. The first thing is make sure you have the SRV records created for the domain. The second thing is the outbound proxy needs to be empty. In the extension proxy field, ONLY type in the dns host name of the PBXnSIP server, and not the FQDN of the server. The reason is the phone will append the DNS suffex it receives from the DHCP server. So obviously you need to make sure your DHCP server is handing out the proper DNS suffex. Even though the phone appends the DNS suffex to resolve the IP of the server, it does not append it in the registration packet, and therefore you need to create a domain alias on the PBXnSIP that is just the host portion of the FQDN. If you do all that, I am sure it will work properly.

Link to comment
Share on other sites

Jlumby,

 

Thanks for the help. I heard you were the god of cisco in multi domain.

 

Are you starting with an xml file by adding a the mac under the extension ( bind to mac) then making the changes below on the generated file. Then naming it with the correct name and adding to the tftp directory?

 

 

Can you explain on this one? "SRV records created for the domain"

 

 

I'm concenred I may have a DNS issue as if I ping the host name of the PBX from the server I get the external IP of the server. My lan connection has no DNS settings listed. I have a small netgear router sedning out itself as DNS since it is doing DHCP. I will add iteself and hand out dns. Hopefully that won't mess up my snoms in my other working domains.

 

Thanks for the help,

 

Brian

 

 

 

 

 

I am using the Cisco phones in multi domain mode without any issues. Here is the key to making it work, and keeping the phone stable at the same time. The first thing is make sure you have the SRV records created for the domain. The second thing is the outbound proxy needs to be empty. In the extension proxy field, ONLY type in the dns host name of the PBXnSIP server, and not the FQDN of the server. The reason is the phone will append the DNS suffex it receives from the DHCP server. So obviously you need to make sure your DHCP server is handing out the proper DNS suffex. Even though the phone appends the DNS suffex to resolve the IP of the server, it does not append it in the registration packet, and therefore you need to create a domain alias on the PBXnSIP that is just the host portion of the FQDN. If you do all that, I am sure it will work properly.
Link to comment
Share on other sites

Well, I do not use the autoprovisioning that is built into PBXnSIP, probably just because I have been using the phones long before they could autoprovision them. I have a base config that I got off of my callmanager, and then I manually modify it to match each phone.

 

As for The SRV record. In simple terms it is a DNS record that tells the client (phone) who is hosting the service they are looking to connect to, which order to try them in, and which port they are listening on. Basically it just points to the basic DNS A record(s), which then resolve to an IP address.

 

As for your DNS issues, I would be happy to PM back and forth with you, since there are tons of different ways you can handle the inside VS outside IP address. The simplest/least expensive, which works well if you are not going to be moving the phones from the inside to the outside of your network frequently is to create 2 different DNS records for your domain. Since you can have multiple aliases in PBXnSIP for your domain, this is not an issue. FOr example if your domain name is voip.yourdomainname.com then I would create the following records

 

A records:

voip.yourdomainname.com - resolves to your public IP address

voipp.yourdomainname.com - resolves to your private IP address

 

SRV Records:

_sip._udp.voip.yourdomainname.com - Lists voip.yourdomainname.com on port 5060

_sip._udp.voipp.yourdomainname.com - Lists voipp.yourdomainname.com on port 5060

 

In PBXnSIP create your primary domain name as: voip.yourdomainname.com

Also list the following aliases for the domain: voipp.yourdomainname.com voipp voip

The last 2 are because the Cisco phone does not append the domain suffex in the regrestration packet.

 

Then in the config file for the phones that are going to be on the inside of your network I would set the extension button proxy to voipp, and the ones sitting on the outside of your network I would set to voip

 

Since this is all additions to what you already have setupo, none of this will have any effect on the SNOM phones

Link to comment
Share on other sites

  • 3 months later...

Revisiting this issue. I have the latest SIP software upgraded from PBXNSIP.

 

Anything changed in this area?

 

"Well, that means that the PBX could not find that extension. In a single domain environment no problem; just use the name "localhost". However for multiple domains a serious problem, as the Cisco phones seem to have a hard time to use DNS names in the registration. So far the workaround is to use a different IP address for each domain. If someone finds out how to make Cisco phones send DNS names, please let us know..."

Link to comment
Share on other sites

Thanks for the replies and the info. My only issue is I have no DNS server on that network. I also have three other companies on the current PBXNSIP setup all in their own domains. Currently just the PBX and a netgear router handing out dhcp on the lan side. Wan goes to a sonicwall firewall. All three use only SNOM phones that have the domain field. I have 8 brand new 7941G phones.May be easier to just sell on ebay and buy Snom.

 

Any ideas on coming in from outside? All four companies are in the same building.

 

Thanks,

Brian

Link to comment
Share on other sites

I'm using the built in tftp on the pbx currently. The SEP_Mac_.cnf / xmls files don't have a registrar or domain field. Only outbound proxy and auth. Its crazy because every other SIP device seems to have the domain field.

 

 

why dont you set up a TFTP server and point the phone to get the files from that server by using option 66 or 150..
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...