Jump to content

DTMF Intermittent on handset


jlr
 Share

Recommended Posts

Using various VoIP handsets on 3.4.0.3201 including a snom 820 I receive mixed results when using defaults for DTMF with my Vitelity SIP trunk. On very few occasions the DTMF works but usually doesn't when entering digits for AVR type systems. Any ideas?

 

TIA

Link to comment
Share on other sites

They (Vitelity) do support RFC2833. In the trunk set-up I have "Trunk requires out of band DTMF tones" set to no.

 

Here's a glimpse of what I see in the log:

 

[9] 2009/11/09 16:11:07: Message repetition, packet dropped

[7] 2009/11/09 16:11:09: Received RFC4733 DTMF on codec 101

[8] 2009/11/09 16:11:19: Packet authenticated by transport layer

[7] 2009/11/09 16:11:19: c26fe9c8@pbx#2101923944: Media-aware pass-through mode

[7] 2009/11/09 16:11:19: Other Ports: 1

[7] 2009/11/09 16:11:19: Call Port: c26fe9c8@pbx#2101923944

 

On the Snom 820 the DTMP Payload type is grayed out I believe from the auto-provisioning pbxnsip does for Snom's.

 

RTP/RTCP:

Dynamic RTP port start: 49152

Dynamic RTP port stop: 65534

DTMF Payload Type: 101

RTCP Support: . on off

RTP Keepalive: . on off

 

For the SIP Identity Settings the 'DTMF via SIP INFO:' is also grayed out to off from auto-provision..

 

Ideas?

Link to comment
Share on other sites

[7] 2009/11/09 16:11:09: Received RFC4733 DTMF on codec 101

 

That looks pretty good.

 

What you can try is to set "Trunk requires out of band-DTMF tones", though I would give that only a small chance. The other thing that you can try is to put the handset into inband mode, so that all DTMF is inband by nature. Higher chance, but this will make it difficult to have DTMF on the PBX.

 

Of course, it would be interesting what the trunk provider returns in the 200 Ok. My guess is that they return support for telephone-event, but when sending the RFC4733 tones it fails.

Link to comment
Share on other sites

That looks pretty good.

 

What you can try is to set "Trunk requires out of band-DTMF tones", though I would give that only a small chance. The other thing that you can try is to put the handset into inband mode, so that all DTMF is inband by nature. Higher chance, but this will make it difficult to have DTMF on the PBX.

 

Of course, it would be interesting what the trunk provider returns in the 200 Ok. My guess is that they return support for telephone-event, but when sending the RFC4733 tones it fails.

 

I tried setting the trunk to requiring in-band. While it's interesting to note that some IVRs seem to get the tones many others don't. I've tried a few different Avaya based along with some unknowns and sometimes it works and others it doesn't. Almost like the DTMF generated is "close enough" for some but not others.

Link to comment
Share on other sites

I tried setting the trunk to requiring in-band. While it's interesting to note that some IVRs seem to get the tones many others don't. I've tried a few different Avaya based along with some unknowns and sometimes it works and others it doesn't. Almost like the DTMF generated is "close enough" for some but not others.

 

Seems to be something with Vitelity's SIP trunking service. I moved my trunk preference up for outbound to Voicepulse and DTMF seems fine through calls there. At least it's been narrowed down. Time to go to them and compare notes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...