Jump to content

Real Instructions for Setting up WAN PNP


iActive
 Share

Recommended Posts

I've have been through so many manuals, wiki's, snome support site, pbxnsip support site, all of these different documents, etc. in regards to WAN PnP and we still have not been able to get it setup. Does anyone have true step by step instructions for setting up WAN based PnP for SnomOne using snom300 phones? Instructions that when followed result in a system that actually works?

Link to comment
Share on other sites

In the most simple scenario it looks like this: Run the PBX on public IP, have the tftp port set up, enter the address of the PBX in the "Setting URL" (or option 66) of the phone (snom 8xx or m9), start the phone and everything else goes automatic.

 

The snom 3xx has no certificates built-in, thats why you need to enter the username/password there before the joy can begin.

 

More complications arise when there are firewalls that are not TFTP friendly, PBX with wrong routing tables or no public IP at all, no TFTP port at all, and so on.

 

We are already working on a new chapter in the admin manual that describes the steps on how to get PnP working in a safe way.

 

 

Link to comment
Share on other sites

A large company out of California specified in the old days that the way to talk to the provisioning phones is tftp. Now we all have to live with that default decision. This is not what I would call NAT-friendly. There are plenty of other ways; but this is the default. You can also use HTTP, but then you need to manually tell that the phones and you need to specify the path from which the files need to be downloaded.

 

If the server is behind NAT you will have a very hard time to get it working anyway. VoIP uses UDP for the media transport, and that is extremly NAT unfriendly. Practically speaking, you need a "routable" IP address--one that can be reached from all devices that indent to use the service. AKA known as "public" IP address (but it does not have to be public, e.g. in company VLAN, VPN and so on).

 

If both the PBX and the phones are behind NAT things get (alomost) funny. "If you want to send me media, send it to 10.1.2.3"--"okay, and if you want to send me something send it to 192.168.1.2". Thank you!

 

Fortunately, the last IPv4 address has just been assigned and hopefully soon the whole NAT madness will be over.

Link to comment
Share on other sites

A large company out of California specified in the old days that the way to talk to the provisioning phones is tftp. Now we all have to live with that default decision. This is not what I would call NAT-friendly. There are plenty of other ways; but this is the default. You can also use HTTP, but then you need to manually tell that the phones and you need to specify the path from which the files need to be downloaded.

 

If the server is behind NAT you will have a very hard time to get it working anyway. VoIP uses UDP for the media transport, and that is extremly NAT unfriendly. Practically speaking, you need a "routable" IP address--one that can be reached from all devices that indent to use the service. AKA known as "public" IP address (but it does not have to be public, e.g. in company VLAN, VPN and so on).

 

If both the PBX and the phones are behind NAT things get (alomost) funny. "If you want to send me media, send it to 10.1.2.3"--"okay, and if you want to send me something send it to 192.168.1.2". Thank you!

 

Fortunately, the last IPv4 address has just been assigned and hopefully soon the whole NAT madness will be over.

 

okay so is there a solid step by step instruction available for setting up tftp? Do I need to create some files ahead of time? if so where do i put them? how should they look? what url do I use?

 

has anyone been able to get it this to work in a similar setup? if so can you share what you did?

Link to comment
Share on other sites

One of the things that I've noticed is that the PBX is not generating all of the files. When I look in the generated directory I see one file with the MAC address of the phone but the file has no information when I look at the contents.

 

In the case of the snom m3 (cry file) thats okay. This is just to prevent a message that the file was not found.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...