Jump to content
Vodia PBX forum
mongoman

Snow Leopard Server Install

Recommended Posts

OK, I'm trying to install snomone on a Snow Leopard Server.

I did everything as instructed, ran the installation program which apparently succeded.

But I can't access the http://localhost admin interface.

 

I have changed the ports in the pbx.xml file to ports that are available on my system, such as http port 83.

 

But I can't connect to localhost:83 either. I dont see that fancy admin interface.

 

Here's as far as my diagnostic skills have taken me:

 

- I have ports in pbx.xml that are available.

- There is no error log in my /usr/Applications/snomone directory as some other post suggested should be there if there were port conflicts.

- I have tried to manually PBX stop and PBX start my service - again, no error messages were given, but when I run the PBX stop command right

after I started PBX, I'm getting:

 

Stopping the PBX Service

No matching processes belonging to you were found

 

So it appears that PBX never ran. I'm really blindfolded as to where to turn to next; my Snow Leopard server is a brand new installation and there are no logs or error messages that would indicate what could be wrong.

 

Any thoughts?

 

Thanks!

 

Mongoman

Share this post


Link to post
Share on other sites

Oh and yes I have tried the other builts that were mention in some other post, so I am now on pbxctrl version 4.2.0.3962.

 

As I dig into this, here's something odd:

 

./pbxctrl-darwin9.0 --no-daemon --log 9

 

gives me:

 

Could not bind socket to port 80 on IP 0.0.0.0

 

- WHY?! First, I set my httpd port to 90 in pbx.xml

 

Second, my IP certainly is not 0.0.0.0 - what's wrong here?

 

Thanks

Share this post


Link to post
Share on other sites

Where is the pbx.xml file located?

You have to do "./pbxctrl-darwin9.0 --dir <pbx.xml directory> --no-daemon --log 9"

 

Otherwise PBX will use the current directory are the working directory and create a default pbx.xml file (with 80 as the port)

Share this post


Link to post
Share on other sites

OK Thank you, I figured that out, and it is now looking to connect to port 90.

 

But still, the IP is listed as 0.0.0.0 :

 

[5] 20110413152925: Starting threads[0] 20110413152925: Could not bind socket to port 90 on IP 0.0.0.0[0] 20110413152925: FATAL: Could not open TCP port 90 for HTTP/HTTPS[0] 20110413152925: Could not bind socket to port 90 on IP [::][0] 20110413152925: FATAL: Could not open TCP port 90 for HTTP/HTTPS[0] 20110413152925: Could not bind socket to port 444 on IP 0.0.0.0

 

Something doesn't seem right here...

 

Any further ideas? I can't believe I'm the only one with this problem as I'm working on an out-of-the-box new snow leopard server system.

Share this post


Link to post
Share on other sites

The next version will make life easier when ports are blocked. As for right now, I agree this version is bitchy about unavailable ports and you need to fix it either by turning off the other services (especially the LDAP port comes as a big surprise) or manually editing the XML file.

Share this post


Link to post
Share on other sites

But still, the IP is listed as 0.0.0.0 :

Don't worry about the 0.0.0.0. The issue is that PBX still can't get the port 90 and 444. So, I would focus on figuring out who is using those ports. You can use netstat command with options to find it.

 

Also, between the stop & start, wait for 30-60 seconds. It is an issue on Mac and Linux based systems.

Share this post


Link to post
Share on other sites

I have exactly the same problem. To test i downloaded the free version of snow one and set it up to mac lion server. For two weeks i can use it internaly but cannot get any sip trunk working. Do you have a solution to fix this issue.? If so please let me know.

Share this post


Link to post
Share on other sites
I have exactly the same problem.

Not sure what that is.

 

Mac OS does not have any impact on the SIP trunking. If you tell us what the problem is with the SIP trunking, we can try to help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...