Jump to content

Outgoing call fails (SNOM ONE (server 2008) > voip.ms)


SFX Group
 Share

Recommended Posts

Hi all

 

I think this might be a routing issue.....

 

2008 64bit (SNOM ONE installed)

XP 64bit with 3CX softphone

iPhone with 3CX softphone

 

All internal stuff works, calls to each extension, voice mail etc..

I can even dial into the DID and it will router to EXT10 (as expect) showing the caller ID from the mobile (Rogers), this works perfectly.

 

However when i try to dial out from Extension 10 to the mobile (on Rogers), the call gets there, shows the DID number (as expected), however once the mobile starts to ring, the 3CX softphone doesn’t change to the REAL ringing tone, after the mobile picks up, the call is dropped on the mobile in 2 seconds (no sound) and the 3CX softphone just says connected.

 

Heres the call log below, i will add, there’s a firewall with a router with the external IP on it (see below for IP setup).

 

 

BELL PPPOE <-----> STATIC IP (3COM router) 10.0.0.1 <---> 10.0.0.2 (3COM firewall) 192.168.1.11 <-----> 192.168.1.63 (SNOM ONE via Server 2008)

 

 

I have a feeling its the last part of the log that gives this away with it showing 10.0.0.2, any idea how to change this in SNOM to hard code to the static IP address?

log.txt

Link to comment
Share on other sites

Based on the log, 3CX is disconnecting the call, 4 seconds after the call is connected

[5] 2011/07/02 21:59:54: SIP Rx udp:192.168.1.51:5060: 
BYE sip:10@192.168.1.63:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.51:5060;branch=z9hG4bK-d8754z-47186f05d0639743-1---d8754z-;rport
Max-Forwards: 70
Contact: <sip:10@192.168.1.51:5060;rinstance=bdbcf2e978355882>
To: <sip:5198417838@192.168.1.63:5060>;tag=eb33ac981f
From: "Ashley - Desk"<sip:10@192.168.1.63:5060>;tag=426f7b7a
Call-ID: NjZlZTMzOGEzZjk3MGFlMTI1ZjZjMDczODZiN2FjMDU.
CSeq: 3 BYE
User-Agent: 3CXPhone 6.0.19548.0
Authorization: Digest username="10",realm="192.168.1.63",nonce="9732003d9542b39e14e85b59305a73c2",uri="sip:10@192.168.1.63:5060",response="570123b478f23c5818223901090c2a09",algorithm=MD5
Content-Length: 0

Link to comment
Share on other sites

Hi

 

Just to make sure things are clear here, when i ring the mobile real number (on rogers) with the 3CX soft phone, this is what happeneds. It will disconnect as i hang up manually on the 3CX once i pick up the call on the mobile, the 3CX phone sales "connected", no sound, however by this time the mobile (rogers) has already hungup as there was no call to connect.

 

I disabled video, identical problem.... have posted another log, this time will not hand up for about 10 seconds, however will be the same problem...

 

This was "ring real number from 3CX on PC to rogers mobile, waited for it to ring for 3 seconds, answer the call on mobile (ir then hung up itself after about 2 seocnds), 3CX says "connected" left it like that 10 seconds then hung up on the 3CX (as it says connected, it would stay off hook all the time).

 

VOIP.MS has no idea what this is doing it, i cleared the log before doing the above so the log only has this call in it...

 

Its this part at the end that worries me "BYE sip:15198417838@10.0.0.2:5060 SIP/2.0" this is an internal "outside" of the Firewall, however the real internal IP is on the router not the firewall! How do i stop this internal IP getting out (as i am sure this is the problem)?????

log.txt

Link to comment
Share on other sites

[5] 2011/07/05 23:47:35:	SIP Tx udp:174.137.63.206:5060:
INVITE sip:15198417838@toronto2.voip.ms;user=phone SIP/2.0
Via: SIP/2.0/UDP 192.168.1.63:5060;branch=z9hG4bK-db44057b734bc2012d6fe5a2dc4cdd88;rport
From: "Ashley Griffin" <sip:12264751002@localhost;user=phone>;tag=59301
To: <sip:15198417838@toronto2.voip.ms;user=phone>
Call-ID: 34789676@pbx
CSeq: 25899 INVITE
Max-Forwards: 70
Contact: <sip:127951@192.168.1.63:5060;transport=udp>
Supported: 100rel, replaces, norefersub
Allow-Events: refer
Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE
Accept: application/sdp
User-Agent: snom-PBX/2011-4.2.0.3981
P-Preferred-Identity: "2665741002" <sip:127951@toronto2.voip.ms>
Content-Type: application/sdp
Content-Length: 229

v=0
o=- 22022 22022 IN IP4 192.168.1.63
s=-
c=IN IP4 192.168.1.63
t=0 0
m=audio 10004 RTP/AVP 0 101
a=rtpmap:0 pcmu/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtcp-xr:rcvr-rtt=all voip-metrics
a=sendrecv

 

Looking at the above INVITE message that is sent on the trunk, SDP has 192.168.1.63 as the media IP. I am assuming this is not a routeble IP address from the carrier's perspective. So, there was no media coming from the carrier and that's why 3CX is disconnecting the call.

 

Please refer http://kiwi.pbxnsip.com/index.php/Office_with_private_and_public_IP_addresses on how to configure the PBX to send the routable (public) IP address in the SDP so that external devices can reach the PBX.

Link to comment
Share on other sites

Hi

 

This is drving me abit nuts...

 

The 192.168.1.63 address is the internal IP address of the SNOM ONE box, it appears (by design which would be correct) the SIP packet is going from the internal address, Ive added 2 lines to the main config in SNOM ONE (none have made any difference):

 

SIP IP Replacement List: 192.168.1.63/206.248.136.39

IP Routing List: 192.168.1.0/255.255.255.0/192.168.1.63 0.0.0.0/0.0.0.0/206.248.136.39

 

206.248.136.39 is the external IP address voip.ms will need to see...

 

However same problem, can get calls comming in (from real rogers to DID), calling internal extenstion to a real rogers mobile number, it rings but can not connect (same as before) the below log is from start of call from internal extenstion (3CX soft phone) to the real rogers number, however i have not hung up on the 3CX here, just let the mobile (rogers) close the call as it always does after 1-2 seconds.

 

Can see the internal address now has the external IP, however i would have thought that would fix it, it hasnt though! :(

 

Many Thanks

Ashley

log.txt

Link to comment
Share on other sites

Hi, it is my cell phone on my desk, i did answer it, however what worries me here is voip.ms have no idea, and SNOM ONE doesnt work.... so ive been told to look at other makes.

 

Ive updated the past post and put the logs in to a text file.... :)

 

 

Thing is it cant be this hard to make voip work with a 3CX softphone, SNOM ONE and voip.ms and a static IP address. I am sure this is a voip.ms issue.

 

However i have been warned not to throw money at this as at the moment my bill is not being paid as its been deemed as a failed project.

 

With this in mind, i assume voip.ms was supposed to sent a SIP 200 OK once the call was answered on the mobile rogers number? If so this would indicate a voip.ms problem, maybe with the way SNOM is registered in. voip.ms has been set to ATA phone (and not PBX like asterisk), when it was set to a PBX system like asterisk then nothing worked, maybe this is the problem?

 

I am sure i asked someone whats the best service to use with SNOM and was told voip.ms, ideas here would be nice.... does anyone use voip.ms ir should i change to a new provider that i know works with SNOM ONE?

 

What should the voip.ms system be set to (as i can set it up) with regards ATA phone or PBX settings, i have no idea what any of those do and neither do voip.ms with an answer like "try ATA phone setting instead".

 

Ive been thinking about buying a SNOM 320, however as above thats out of my pocket, if i cant get this to work i wont get paid... :(

 

UPDATE

Tried both ATA and PBX settings at voip.ms, identical problems with both settings.

 

However i do get 2 seconds of sound when i set "follow RTP" (Settings > ports > follow RTP) in SNOM ONE, that seems to help abit, it still cuts out but now i get 2 seconds of sound from the rogers mobile before it hangs up (same problem just with abit of sound now).... :(

Link to comment
Share on other sites

Had a response from voip.ms, they have confirmed as long as the RTP ports are between 10000-20000 its ok, i have set it on the firewall (external and Windows 2008) to ports 10001 - 10005

 

I have also tried this with the PC (3CX soft phone) and server 2008 (SNOM ONE) firewalls off, have an identical issue.

 

That said, for some reason now the 3CX no longer seems to want to work with the voice mail (call its own extension, it isnt sending the PIN keytones to the server when entering the pin code, this is a new issue i dont want to look at until i get voip working outside (if i can persist with this due to the fact i wont be paid for this now).

Link to comment
Share on other sites

At the end of it comes down to understanding the network structure and making sure that the packets flow in/out of the PBX, phone & provider. Every installations can be different based on the routers/firewalls/network interface on the host etc. The below links talks about different scenario that can be helpful.

http://kiwi.pbxnsip.com/index.php/One-way_Audio

http://kiwi.pbxnsip.com/index.php/Office_with_private_and_public_IP_addresses

Link to comment
Share on other sites

  • 2 weeks later...

UPDATE

 

Ive now changed the 3COM Superstack firewall to a newer Watchguard.

 

This is now doing the PPPOE meaning the firewall actually has the static external IP (still have the 3COM ADSL modem but its now a bridge), i removed these 2 lines and restarteed the server:

 

SIP IP Replacement List: 192.168.1.63/206.248.136.39

IP Routing List: 192.168.1.0/255.255.255.0/192.168.1.63 0.0.0.0/0.0.0.0/206.248.136.39

 

The 3CX softphone seems to be fully working with the Rogers mobile number (both ways). I will now likly buy a SNOM phone to fully test this as it seems way better without the NAT between the firewall and ADSL/PPPOE log in (NAT).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...