Jump to content

404 not found on some calls after upgrade from version 3 to 4


reco
 Share

Recommended Posts

hi there,

 

on some calls i am getting 404 not found and i cannot figure out why.

any idea?

 

thanx

 

 

 

SIP/2.0 100 Trying

Via: SIP/2.0/TLS 10.0.24.138:4993;branch=z9hG4bK-69lcg8nopbbd;rport=4993

From: "First Last" <sip:12@domain.com>;tag=koerzr4mij

To: <sip:2223335555@domain.com;user=phone>;tag=0a70de7b9f

Call-ID: 1d74263c345d-dg32cs7hcuwn

CSeq: 1 INVITE

Content-Length: 0

 

 

[8] 20111010131442: Incoming call: Request URI sip:2223335555@domain.com;user=phone, To is <sip:2223335555@domain.com;user=phone>

[8] 20111010131442: Set the To domain based on From user 12@domain.com

[9] 20111010131442: SIP Tx tls:10.0.24.138:4993:

SIP/2.0 404 Not Found

Via: SIP/2.0/TLS 10.0.24.138:4993;branch=z9hG4bK-69lcg8nopbbd;rport=4993

From: "First Last" <sip:12@domain.com>;tag=koerzr4mij

To: <sip:2223335555@domain.com;user=phone>;tag=0a70de7b9f

Call-ID: 1d74263c345d-dg32cs7hcuwn

CSeq: 1 INVITE

Contact: <sip:12@10.0.24.2:5061;transport=tls>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: pbxnsip-PBX/4.2.1.4025

Content-Length: 0

Link to comment
Share on other sites

Check this:

  • Do you have a domain with the name "domain.com"? Configured on your PBX?
  • Did you set a country code for the domain? If you set it to "1", all numbers in the dialplan will be presented as 10-digit numbers (xxxxxxxxxx or 011yxz). Make sure that the dialplan does that.
  • If you have only one domain running on your PBX, you can also add the name "localhost" to the list of domains, this acts like a wildcard
  • Do you have a account with the name "12" on your system?
  • Does this account have a dial plan assigned either on account level or domain level that allows dialling this number?

I guess the call does never make it to the trunk level, looking at the log. Right?

 

 

Link to comment
Share on other sites

hi there,

 

Do you have a domain with the name "domain.com"? Configured on your PBX?

 

nope i just replaced my domain with domain.com

 

Did you set a country code for the domain? If you set it to "1", all numbers in the dialplan will be presented as 10-digit numbers (xxxxxxxxxx or 011yxz). Make sure that the dialplan does that.

 

i have country code set to: 1

area code to : 212

phone number: 212 333 5555

 

If you have only one domain running on your PBX, you can also add the name "localhost" to the list of domains, this acts like a wildcard

 

i have multiple domains so not localhost configured

 

Do you have a account with the name "12" on your system?

 

yes absolutely. also i do have an extension 12 in other domains.

 

Does this account have a dial plan assigned either on account level or domain level that allows dialling this number?

 

account has a domain default dial plan

 

I guess the call does never make it to the trunk level, looking at the log. Right?

 

yes looks like.

 

 

any suggestions?

Link to comment
Share on other sites

Hmm. It is not very clear. Do you have trunk logging turned on? If it would associate the call with a trunk, it would say so in the log. And if it would not associate the call with a trunk and the from-User is not known, then it would also say so. Otherwise, you would see that it tries to go through a dialplan, but again nothing in the log. For for now, I think the "bug" must be in the logging part...

 

 

Link to comment
Share on other sites

Hmm. It is not very clear. Do you have trunk logging turned on? If it would associate the call with a trunk, it would say so in the log. And if it would not associate the call with a trunk and the from-User is not known, then it would also say so. Otherwise, you would see that it tries to go through a dialplan, but again nothing in the log. For for now, I think the "bug" must be in the logging part...

 

i think i found the issue.

 

with version 3 i used to add a `Try Loopback` with pattern `*` Replacement `` (empty) in the beginning of a dial plan to enable inter domain calling followed by a trunk.

 

dial plan csv:

 

50;*;;*;
200;voxbeam_nex9;;*;

with the loopback i have the issue. once i remove it seems to work fine:

 

working dial plan:

 

200;voxbeam_nex9;;*;

 

reco

Link to comment
Share on other sites

i am monitoring my dial plans.

 

seems rules which should match are skipped cause of co lines?

can somebody explain me the reason for this?

i would expect the pbx to send the call to trunk: voxbeam_js

 

 

[8] 20111010171436: To is <sip:12129960700@johnsheeley.com;user=phone>, user 0, domain 5

[8] 20111010171436: From user 20

[8] 20111010171436: Call state for call object 455: idle

[7] 20111010171436: set_codecs: for 70b7263c8244-u3zz195hutuu codecs "", codec_preference count 7

[9] 20111010171436: Dialplan: Evaluating !^311!sip:12126399675@\r;user=phone!i against 2129960700@johnsheeley.com

[9] 20111010171436: Dialplan: Evaluating !^(\+?[0-9]*)@.*!sip:\1@\r;user=phone!i against 2129960700@johnsheeley.com

[7] 20111010171436: Skipping pattern match because CO-line is not available for trunk voxbeam_js

 

 

my dial plan:

51;icall-domestic-sheeley;;^311;12126399675
101;voxbeam_js;;*;
400;AmericanVOIP domestic JS;;^([0-9]{10})@.*;"sip:1\1@\r;user=phone"
401;AmericanVOIP domestic JS;;^1([0-9]{10})@.*;"sip:1\1@\r;user=phone"
403;AmericanVOIP international JS;;^011([0-9]*)@.*;"sip:011\1@\r;user=phone"
500;icall-domestic-sheeley;;^([0-9]{10})@.*;"sip:1\1@\r;user=phone"
501;icall-domestic-sheeley;;^1([0-9]{10})@.*;"sip:1\1@\r;user=phone"
502;icall-international-sheeley;;^011([0-9]*)@.*;"sip:011\1@\r;user=phone"

 

trunk `voxbeam_js` has no co lines

 

any idea whats going on?

 

thanx

Link to comment
Share on other sites

[7] 20111010171436: Skipping pattern match because CO-line is not available for trunk voxbeam_js

 

It could be that the user has seized a CO-line when placing the call (why is another question). Anyway, I remember there were some situations where the CO line could get stuck "on", but as far as I remember the situation goes away after the next reboot or after the seizure timeout (usually 60 seconds).

Link to comment
Share on other sites

Does this user has any button configured on button 1? When you dial something, the phone sends the "seize" to the PBX if the button 1 configured to do co-line. This is an undesirable condition and can cause this issue.

 

To verify this, you can modify the button configuration from "button 1" and reboot the phone (reboot is not really needed, but it will cleanup any old settings set on the buttons).

Link to comment
Share on other sites

It could be that the user has seized a CO-line when placing the call (why is another question). Anyway, I remember there were some situations where the CO line could get stuck "on", but as far as I remember the situation goes away after the next reboot or after the seizure timeout (usually 60 seconds).

 

i am actually tempted to track the concept of co-lines totally and use park orbits instead.

they are trunk independent. what do you think?

 

would be cool if there is a way to get rid of the feature codes in the dialed list and the announcement that a call was parked in the orbit #

 

x

Link to comment
Share on other sites

Does this user has any button configured on button 1? When you dial something, the phone sends the "seize" to the PBX if the button 1 configured to do co-line. This is an undesirable condition and can cause this issue.

 

To verify this, you can modify the button configuration from "button 1" and reboot the phone (reboot is not really needed, but it will cleanup any old settings set on the buttons).

 

this could be the issue. i deleted all the co lines from all trunks and domains. that solved the issue for now.

will try to bring them back.

 

if this is the case what should i do with button 1? just no config?

 

x

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...