Jump to content

Including Cell Phone in calls to Extension Problem


Dale Weaver
 Share

Recommended Posts

We have Snom setting "Include the cell phone in calls to extension" set to "After 5 seconds". If we have the "Confirmation" field set to "Press 1 to connect call", the desk phone will ring for 5 seconds, then both desk phone and cell phone start ringing. This is great. However, we do not want to press "1" on the cell phone to accept the call. We want to accept it as soon as we answer. Logically we set the "Confirmation" field to "No confirmation required". Now the desk phone rings for 5 seconds and then displays a message, "Call completed elsewhere" and stops ringing, then the cell phone starts ringing. This is not what we want. We want both phones to ring but without the cell phone having to press "1". That way if the cell phone doesn't answer, the voicemail is left on Snom.

 

Anybody know how to fix this?

Link to comment
Share on other sites

The call does transfer. That is not the problem. If I set it to immediate, the call will transfer immediately to the cell phone. What I want is for the office phone to stay ringing while the cell phone is ringing. It does this if I set the "Confirmation" field to "Press 1 to connect call". Both cell phone and office phone will ring at the same time. However, on the cell phone side we don't want to have to press 1 to accept the call. But when we set the "Confirmation" field to "No confirmation required" and not change anything else, the office phone stops ringing when the cell phone starts ringing. We want them to both stay ringing at the same time.

Link to comment
Share on other sites

We have Snom setting "Include the cell phone in calls to extension" set to "After 5 seconds". If we have the "Confirmation" field set to "Press 1 to connect call", the desk phone will ring for 5 seconds, then both desk phone and cell phone start ringing. This is great. However, we do not want to press "1" on the cell phone to accept the call. We want to accept it as soon as we answer. Logically we set the "Confirmation" field to "No confirmation required". Now the desk phone rings for 5 seconds and then displays a message, "Call completed elsewhere" and stops ringing, then the cell phone starts ringing. This is not what we want. We want both phones to ring but without the cell phone having to press "1". That way if the cell phone doesn't answer, the voicemail is left on Snom.

 

Anybody know how to fix this?

 

First, if you truly don't want the call to inadvertently be left on the voicemail of the mobile device you will *need* to have the "press 1 to connect" turned on. (remember that the pbx has no control over when the mobile device voicemail picks up)

 

whether the way it works (deskphone not ringing) is intended, snom would best answer.

Link to comment
Share on other sites

Couple of things here

 


  •  
  • The cell phone user has to press 1 to confirm that it is really a person answered the call and not the cell phone voice mail.
  • The reason why you see "call completed elsewhere" is because PBX receives 200 OK message from either the trunk provider or the gateway.

 

So, if you can make sure that PBX does not receive 200 OK till a human being answers the cell phone, then you will not get into this situation. You can always ask the provider/gateway to send 18x message instead of 200 OK. Also, if you want the extension's voice mail to answer before the cell phone voice mail, then you have to set the "Extension->Mailbox: Time until mailbox picks up:" less than the cell phone's voice mail setting.

Link to comment
Share on other sites

>>Also, if you want the extension's voice mail to answer before the cell phone voice mail, then you have to set the "Extension->Mailbox: Time until mailbox picks up:" less than the cell phone's voice mail setting.

 

the challenge here is that some mobile phones don't always have consistent ring to voicemail pickup time, but if it does then that would work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...