Jump to content

Incoming call with berofix


cosymed
 Share

Recommended Posts

I'm new to all this voip stuff, so please excuse my missing knowledge.

 

I can successfully place outbound calls with our berofix and snomONE/4.5.0.1090 Epsilon Geminids. But receiving calls doesn't work and i'm quite lost here. I followed the description on the beronet wiki Berofix with Snom One to set the system up but i'm always getting the error message "Received incoming call without trunk information and user has not been found". I've "played" with the General Settings of the trunk to no avail.

 

Here is the sip log:

[8] 2012/10/17 11:51:46:	Last message repeated 2 times
[5] 2012/10/17 11:51:46:	SIP Rx udp:192.168.4.230:5060:
INVITE sip:939642@192.168.4.210 SIP/2.0
Via: SIP/2.0/UDP 192.168.4.230;rport;branch=z9hG4bKFSr4807ve0N7m
Max-Forwards: 70
From: "0840793960" <sip:0840793960@192.168.4.230>;tag=Dv5766vK8pNUg
To: "" <sip:939642@192.168.4.210>
Call-ID: dbfe9e45-92f3-1230-7a93-899e4e38b674
CSeq: 34901287 INVITE
Contact: <sip:192.168.4.230;transport=udp>
User-Agent: Berofix VOIP Gateway (2.2)
Allow: INVITE, ACK, BYE, CANCEL, OPTIONS, PRACK, MESSAGE, SUBSCRIBE, NOTIFY, REFER, UPDATE, INFO, REGISTER
Supported: timer, 100rel, replaces
Min-SE: 120
Privacy: none
Content-Type: application/sdp
Content-Disposition: session
Content-Length: 220
P-Asserted-Identity: "" <sip:0840793960@192.168.4.230;user=phone>
P-Preferred-Identity: "" <sip:0840793960@192.168.4.230;user=phone>
Remote-Party-ID: "" <sip:0840793960@192.168.4.230;user=phone>;party=calling;privacy=off;screen=no

v=0
o=- 513107643738542725 5066403480193230594 IN IP4 192.168.4.230
s=-
c=IN IP4 192.168.4.230
t=0 0
m=audio 5004 RTP/AVP 8 101
a=rtpmap:8 pcma/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
[8] 2012/10/17 11:51:46:	Allocating for call port 49, SIP call id dbfe9e45-92f3-1230-7a93-899e4e38b674
[5] 2012/10/17 11:51:46:	SIP Tx udp:192.168.4.230:5060:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.4.230;rport=5060;branch=z9hG4bKFSr4807ve0N7m
From: "0840793960" <sip:0840793960@192.168.4.230>;tag=Dv5766vK8pNUg
To: <sip:939642@192.168.4.210>;tag=0efc4008a0
Call-ID: dbfe9e45-92f3-1230-7a93-899e4e38b674
CSeq: 34901287 INVITE
Content-Length: 0

[7] 2012/10/17 11:51:46:	Set packet length to 20
[6] 2012/10/17 11:51:46:	Call-leg 49: Sending RTP for dbfe9e45-92f3-1230-7a93-899e4e38b674 to 192.168.4.230:5004, codec not set yet
[8] 2012/10/17 11:51:46:	Incoming call: Request URI sip:939642@192.168.4.210, To is <sip:939642@192.168.4.210>
[5] 2012/10/17 11:51:46:	Received incoming call without trunk information and user has not been found
[8] 2012/10/17 11:51:46:	call port 49: state code from 0 to 404
[7] 2012/10/17 11:51:46:	Set packet length to 20
[5] 2012/10/17 11:51:46:	SIP Tx udp:192.168.4.230:5060:
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 192.168.4.230;rport=5060;branch=z9hG4bKFSr4807ve0N7m
From: "0840793960" <sip:0840793960@192.168.4.230>;tag=Dv5766vK8pNUg
To: <sip:939642@192.168.4.210>;tag=0efc4008a0
Call-ID: dbfe9e45-92f3-1230-7a93-899e4e38b674
CSeq: 34901287 INVITE
Contact: <sip:939642@192.168.4.210:5060>
Supported: 100rel, replaces, norefersub
Allow-Events: refer
Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE
Accept: application/sdp
User-Agent: snomONE/4.5.0.1090 Epsilon Geminids
Content-Length: 0

[5] 2012/10/17 11:51:46:	SIP Rx udp:192.168.4.230:5060:
ACK sip:939642@192.168.4.210 SIP/2.0
Via: SIP/2.0/UDP 192.168.4.230;rport;branch=z9hG4bKFSr4807ve0N7m
Max-Forwards: 70
From: "0840793960" <sip:0840793960@192.168.4.230>;tag=Dv5766vK8pNUg
To: "" <sip:939642@192.168.4.210>;tag=0efc4008a0
Call-ID: dbfe9e45-92f3-1230-7a93-899e4e38b674
CSeq: 34901287 ACK
Content-Length: 0

[8] 2012/10/17 11:51:46:	Clearing call port 49, SIP call id dbfe9e45-92f3-1230-7a93-899e4e38b674
[8] 2012/10/17 11:51:46:	Hangup: Call 49 not found

 

and here the configuration of the trunk:

# Trunk 1 in domain pbx.cosymed.de
Name: berofix
Type: proxy
To: sip
RegPass: ********
Direction: 
Disabled: false
Global: false
Display: 
RegAccount: snomone
RegRegistrar: 
RegKeep: 
RegUser: snomone
Icid: 
Require: 
OutboundProxy: 192.168.4.230
Ani: 
DialExtension: !([0-9]{2}$)!!t!41
Prefix: 
Trusted: true
AcceptRedirect: false
RfcRtp: false
Analog: false
SendEmail: 
UseUuid: false
Ring180: false
Failover: never
HeaderRequestUri: {request-uri}
HeaderFrom: {ext}
HeaderTo: {request-uri}
HeaderPai: {ext}
HeaderPpi: {ext}
HeaderRpi: {ext}
HeaderPrivacy: id
HeaderRpiCharging: icid-value={icid-value};icid-generated-at={ip-address};orig-ioi={domain}
BlockCidPrefix: 
Glob: 
RequestTimeout: 
Codecs: 8
CodecLock: true
DtmfMode: 
Expires: 3600
FromUser: 
Tel: true
TranscodeDtmf: true
AssociatedAddresses: 1.2.3.4
InterOffice: false
DialPlan: 
UseEpid: false
CidUpdate: 
Ignore18xSDP: false
UserHdr: 
Diversion: 
Colines: 
DialogPermission: 

 

Thanks.

Link to comment
Share on other sites

[5] 2012/10/17 11:51:46: Received incoming call without trunk information and user has not been found

 

Did you set up a trunk for the gateway? Make sure that the outbound proxy is set to 192.168.4.230. Then the PBX will know it comes from the gateway.

 

Next step is to make sure that 939642 is a alias name of one of the accounts. Just pick the extension (or other account type) that should receive calls for this number and add the alias name to it. Account name will then look like "45 939642" (space between the alias names). More information can be found at http://wiki.snomone.com/index.php?title=Routing_a_Call_to_the_Proper_Extension and http://wiki.snomone.com/index.php?title=Inbound_Calls.

Link to comment
Share on other sites

Yes i configured a trunk and i already added the configuration of the trunk in my first post.

I can already place outbound calls and i set the "Send call to extension" option in the trunk to "!([0-9]{2}$)!\1!t!41", which should mitigate adding an alias name to an extension, if i understood that correctly. The /1 gets stripped in the snom ONE web interface if it should show the trunk in text form.

Link to comment
Share on other sites

Yes i configured a trunk and i already added the configuration of the trunk in my first post.

I can already place outbound calls and i set the "Send call to extension" option in the trunk to "!([0-9]{2}$)!\1!t!41", which should mitigate adding an alias name to an extension, if i understood that correctly. The /1 gets stripped in the snom ONE web interface if it should show the trunk in text form.

 

Ops sorry did not see that. Please choose "gateway" mode, not proxy mode and use 192.168.4.230 as associated address (not 1.2.3.4). And the pattern should be "!([0-9]{2}$)!t!41".

Link to comment
Share on other sites

I already tried that, but nevertheless changed it again.

 

# Trunk 1 in domain pbx.cosymed.de
Name: berofix
Type: gateway
To: sip
RegPass: ********
Direction: 
Disabled: false
Global: true
Display: 
RegAccount: 
RegRegistrar: 192.168.4.230
RegKeep: 
RegUser: 
Icid: 
Require: 
OutboundProxy: 192.168.4.230
Ani: 
DialExtension: !([0-9]{2}$)!t!41
Prefix: 
Trusted: true
AcceptRedirect: false
RfcRtp: false
Analog: false
SendEmail: 
UseUuid: false
Ring180: false
Failover: never
HeaderRequestUri: {request-uri}
HeaderFrom: {ext}
HeaderTo: {request-uri}
HeaderPai: {ext}
HeaderPpi: {ext}
HeaderRpi: {ext}
HeaderPrivacy: id
HeaderRpiCharging: icid-value={icid-value};icid-generated-at={ip-address};orig-ioi={domain}
BlockCidPrefix: 
Glob: 
RequestTimeout: 
Codecs: 8
CodecLock: true
DtmfMode: 
Expires: 3600
FromUser: 
Tel: true
TranscodeDtmf: true
AssociatedAddresses: 192.168.4.230
InterOffice: false
DialPlan: 
UseEpid: false
CidUpdate: 
Ignore18xSDP: false
UserHdr: 
Diversion: 
Colines: 
DialogPermission: 

 

I still get the same error message.

 

Edit: Forgot to change the Associated Adresses and the error message is now Trunk berofix@pbx.cosymed.de has country code 49, area code 8407. So i think it's one step in the right direction.

Link to comment
Share on other sites

Inbound calling works with Send call to extension set to "!([0-9]{2}$)!\1!t!41". But it sends the call always to the extension 41 even if the called number is 939642.

Does someone know what is really used from "To" (log: To is <sip:939642@192.168.4.210>) in the Send call to extension regular expression?

 

"!([0-9]{2}$)!t!41" doesn't work btw.

Link to comment
Share on other sites

Problem solved.

 

I had to add another "!" to the Send call To Extension option. The correct regular expression that worked for me is "!([0-9]{2}$)!\1!t!40!".

A lot of the examples from the wiki, if not all of them, didn't work for me and are perhaps also missing the last "!".

 

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...