Jump to content

401 error on SIP registration


mcbizman
 Share

Recommended Posts

Hi everyone

 

I have recently installed snomONE on a Windows 2011 server to see whether it would be a better solution to the NCH Software Axon Virtual PBX I have been trying for the last 12 months. I am in Australia and use Internode as my ISP.

 

I have set up and entered entered all the required ISP details into the pbx.company.com domain, but continually get a "401 Unauthorized (Registration failed, retry after 60 seconds)" message when trying to register. I have confirmed all login settings are correct by getting registration in both the Axon Virtual PBX and a Ninja Pro (CTI) softphone. All inbound and outbound protocls and ports have been allowed in the firewall.

 

Any suggestions on what might be causing the registration to fail.

 

Michael Carlin

Link to comment
Share on other sites

Hi everyone

 

I have recently installed snomONE on a Windows 2011 server to see whether it would be a better solution to the NCH Software Axon Virtual PBX I have been trying for the last 12 months. I am in Australia and use Internode as my ISP.

 

I have set up and entered entered all the required ISP details into the pbx.company.com domain, but continually get a "401 Unauthorized (Registration failed, retry after 60 seconds)" message when trying to register. I have confirmed all login settings are correct by getting registration in both the Axon Virtual PBX and a Ninja Pro (CTI) softphone. All inbound and outbound protocls and ports have been allowed in the firewall.

 

Any suggestions on what might be causing the registration to fail.

 

Michael Carlin

 

Need a bit more info mate.

 

Edit your trunk, at the top switch to text based editing and copy what you have (obviously remove your number and username/password) and paste it here so I can see what you have setup.

Link to comment
Share on other sites

Hi metwest

 

Trunk settings as requested.

 

# Trunk 2 in domain pbx.company.com

Name: Internode

Type: register

To: sip

RegPass:

Direction:

Disabled: false

Global: false

Display: MCBizman

RegAccount:

RegRegistrar: sip.internode.on.net

RegKeep:

RegUser:

Icid:

Require:

OutboundProxy: sip.internode.on.net

Ani:

DialExtension: 40

Trusted: false

AcceptRedirect: false

RfcRtp: false

Analog: false

RtpBegin:

RtpEnd:

Prack: false

SendEmail:

UseUuid: false

Ring180: false

Failover: never

HeaderRequestUri: {request-uri}

HeaderFrom: {trunk}

HeaderTo: {request-uri}

HeaderPai:

HeaderPpi:

HeaderRpi:

HeaderPrivacy:

HeaderRpiCharging:

BlockCidPrefix:

Glob:

RequestTimeout:

Codecs:

CodecLock: true

DtmfMode:

Expires: 3600

Fraction: 128

Minimum: 10

FromUser:

Tel: true

TranscodeDtmf: false

AssociatedAddresses:

InterOffice: false

DialPlan:

UseEpid: false

CidUpdate:

Ignore18xSDP: false

UserHdr:

Diversion:

CoBusy: 500 Line Unavailable

Colines:

DialogPermission:

Link to comment
Share on other sites

I am not sure by your response, if you left the actual url as "pbx.company.com" but unless you added an alias ie yourcompany.localurl.com, to the ip of internet connection, it wont work. The registrant will not be able to find the url pbx.company.com as it doesnt exist.

Did you leave the registration username off on purpose or is it really not there.

Link to comment
Share on other sites

Try the following:

 

# Trunk 2 in domain pbx.company.com

Name: Internode

Type: register

To: sip

RegPass:

Direction:

Disabled: false

Global: false

Display: MCBizman

RegAccount:

RegRegistrar: sip.internode.on.net:5060

RegKeep:

RegUser:

Icid:

Require:

OutboundProxy: sip.internode.on.net:5060

Ani:

DialExtension: 40

Trusted: false

AcceptRedirect: false

RfcRtp: false

Analog: false

RtpBegin:

RtpEnd:

Prack: false

SendEmail:

UseUuid: false

Ring180: false

Failover: never

HeaderRequestUri: {request-uri}

HeaderFrom: {trunk}

HeaderTo: {request-uri}

HeaderPai:

HeaderPpi:

HeaderRpi:

HeaderPrivacy:

HeaderRpiCharging:

BlockCidPrefix:

Glob:

RequestTimeout:

Codecs:

CodecLock: true

DtmfMode:

Expires: 120

Fraction: 230

Minimum: 30

FromUser:

Tel: true

TranscodeDtmf: false

AssociatedAddresses:

InterOffice: false

DialPlan:

UseEpid: false

CidUpdate:

Ignore18xSDP: false

UserHdr:

Diversion:

CoBusy: 500 Line Unavailable

Colines:

DialogPermission:

Link to comment
Share on other sites

Try the following:

 

# Trunk 2 in domain pbx.company.com

Name: Internode

Type: register

To: sip

RegPass:

Direction:

Disabled: false

Global: false

Display: MCBizman

RegAccount:

RegRegistrar: sip.internode.on.net:5060

RegKeep:

RegUser:

Icid:

Require:

OutboundProxy: sip.internode.on.net:5060

Ani:

DialExtension: 40

Trusted: false

AcceptRedirect: false

RfcRtp: false

Analog: false

RtpBegin:

RtpEnd:

Prack: false

SendEmail:

UseUuid: false

Ring180: false

Failover: never

HeaderRequestUri: {request-uri}

HeaderFrom: {trunk}

HeaderTo: {request-uri}

HeaderPai:

HeaderPpi:

HeaderRpi:

HeaderPrivacy:

HeaderRpiCharging:

BlockCidPrefix:

Glob:

RequestTimeout:

Codecs:

CodecLock: true

DtmfMode:

Expires: 120

Fraction: 230

Minimum: 30

FromUser:

Tel: true

TranscodeDtmf: false

AssociatedAddresses:

InterOffice: false

DialPlan:

UseEpid: false

CidUpdate:

Ignore18xSDP: false

UserHdr:

Diversion:

CoBusy: 500 Line Unavailable

Colines:

DialogPermission:

 

Thanks. At first it was not working, returning a 408 error (Registration timeout), but by playing with the registration duration I eventually got registration to happen. Now I can continue the setup process and get calls working.

Link to comment
Share on other sites

No problem

 

Timers are tricky since 5.0. That's what we use for Engin but Internode must be different, you may need to fine tune them a little more if you get random 408 errors.

 

I'm guessing it was the :5060 that fixed the 401 registration problem.

 

OK, so now I have the SIP registered, but cannot get any devices to register with the domain (not even snomONE UC Client!). When I enter the Setup details of MCBMServer.MELLOR-1.local for the server and the domain with the extension user details then save, I get the following log report:

2013/05/03 12:10:22 Start

2013/05/03 12:10:22 PnP: Starting to download files

2013/05/03 12:10:42 Webclient request Timeout: MCBMServer.MELLOR-1.local /prov/snom-m9-000413000000.xml

2013/05/03 12:10:42 PnP: Received from MCBMServer.MELLOR-1.local code 408

2013/05/03 12:10:42 Downloading http://MCBMServer.MELLOR-1.local/prov/snom-m9-000413000000.xml failed with code 408

 

Also, as can be seen in the log report, the server details are changed from MCBMServer.MELLOR-1.local to http://MCBMServer.MELLOR-1.local/prov/snom-m9-000413000000.xml.

 

What am I missing in the domain or extensino setup?

Link to comment
Share on other sites

Maybe you are just blacklisted on the PBX? That would explain the 408.

 

No, not black-listed as the computer UCClient is loaded on is part of the network range allowed in snomONE. Any other ideas, as this is very frustrating.

Link to comment
Share on other sites

No, not black-listed as the computer UCClient is loaded on is part of the network range allowed in snomONE. Any other ideas, as this is very frustrating.

 

What version of Snom One are you using? Try 5.08. (5.09 has some issues with pnp)

 

Also maybe first try a simple softphone to start with and just enter the username, password and server address (ip address of system) and see if you have success.

 

If not post log errors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...