Jump to content

Service Flag on Extension


maslym
 Share

Recommended Posts

I am trying to use the service flag feature of the extension to redirect calls to the cell phone number and it doesn't work very well.

On the Redirection page of the extension, I enter the cell phone number and set "Include the cell phone in calls to extension" to "Immediately".

When the extension has no registrations, if the service flag is Clear, incoming calls to the extension are answered by the voice mail. If the service flag is Set, incoming calls to the extension are redirected to the cell phone number.

When the extension has at least one registration, incoming calls to the extension always ring both the registered ATA and the cell phone number simultaneously no matter whether the status of the service flag is Clear or Set.

This problem is found on both pbxctrl-suse10-2.1.2.2292 and pbxctrl-suse10-2.1.6.2446. Have I missed something or it's a bug?

Any idea?

The service flag feature on other accounts such as auto attendant works fine.

 

Thanks.

Link to comment
Share on other sites

My understanding is that service flag is only to redirect the cell phone after hours so it doesnt ring say at 2am if someone calls the work extension. So it sounds like you are not seeing the service flag take effect after hours. The extension should always ring regardless of the service flag and only the cell phone should be affected by the flag.

Link to comment
Share on other sites

Guest Paul McCabe

I just tried testing this with the following setup:

PBX = 2.1.6.2448

Include the cell phone in calls to extension: Immediately

Service Flag: Explicitly Specify Available Times

Days of the Week: <No times specified for any day>

 

Result when I call my extension: Extension only rings once and then my cell begins ringing.

Expected result: If no Available Times are set, I would not expect my cell to ring at all.

 

I also explicity set the Monday time to 15:30-20:30 and called by extension at 15:15. My cell phone rang though I expected it to only ring today between 3:30PM and 8:30PM

 

This appears to be a bug that we will have to look into...

Link to comment
Share on other sites

When the extension has no registrations, if the service flag is Clear, incoming calls to the extension are answered by the voice mail. If the service flag is Set, incoming calls to the extension are redirected to the cell phone number.

 

You mean you expect the reverse logic? The service flag should have a function like "office hours", that means you specify when the cell should to be included in the call. That means if you say e.g. 9AM-6PM then you will hear the cell phone ringing.

 

IMHO most people would like to specify when they are available on the cell phone. Our first experience was that we got calls at 3 AM in the night on the cell phone, and it became clear that we need to specify the operation hours when redirection should be allowed.

Link to comment
Share on other sites

You mean you expect the reverse logic? The service flag should have a function like "office hours", that means you specify when the cell should to be included in the call. That means if you say e.g. 9AM-6PM then you will hear the cell phone ringing.

 

But the fact is that the cell is also included in the call even after the "office hours". It seems to me that the service flag setup on the extension is totally ignored.

Based on how the service flag works on other accounts such as auto attendant, my understanding is that during the office hours, incoming calls will ring the extension only. After the office hours, incoming calls will also ring the cell.

Link to comment
Share on other sites

Did you check if the time is correct on the system? Are you using the right time zone for the system, domain and extension?

 

Actually I set the mode of the Service Flag account to Manual and toggled the status of it between Clear and Set manually by calling it. The result is still the same.

Link to comment
Share on other sites

  • 4 months later...
Actually I set the mode of the Service Flag account to Manual and toggled the status of it between Clear and Set manually by calling it. The result is still the same.

 

 

I second that emotion; :o my time is correct, and I even tried setting the hours to GMT times on a lark, but the result is the same: The cell phone is called no matter what time frames I enter into for the Service Flag on the Redirection screen in an individual Extension.

 

I'm using 2.1.12.2489 (Linux).

 

DK

Link to comment
Share on other sites

I second that emotion; B) my time is correct, and I even tried setting the hours to GMT times on a lark, but the result is the same: The cell phone is called no matter what time frames I enter into for the Service Flag on the Redirection screen in an individual Extension.

 

I'm using 2.1.12.2489 (Linux).

 

DK

 

 

Speaking of which, I have had 2 Customers now that have found this feature themselves through the Web Interface and want this feature to function properly (right now it does not function at all).

 

Can someone please reply on this issue?

 

Any timeline on when we can expect this to be patched?

 

 

Thanks!

 

DK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...