Jump to content

0 KB Tar file in backup


Carlos Montemayor
 Share

Recommended Posts

Hi,

 

I am trying to make a backup file, but I am getting a 0 KB TAR File as a result. I figured that the actual backup must be larger that the allowed limit, so I deleted all the recordings of conversations and increased the limit of the backup file to the maximum of 10 MB, however, that did not help. I continue to have a 0 KB tar file.

 

What can it be? I am using version 5.1.2 64 bit debian hosted.

 

Regards

Link to comment
Share on other sites

Agreed.

 

Could you please outline the procedure to do the file system backup? I mean, I accessed the server using SSH and gave the tar command but it did not work. I have my backup file now thanks from the help of Vodia support, however, since this is something that should be done every so often, I should be able to do it by myself. How should I use the tar command?

 

Regards

Link to comment
Share on other sites

cd /usr/local/snomONE
tar cvfz /whereever/backup20140116.tgz --exclude tftp --exclude 'audio_*' .

Note that there is no "-" before the options to tar. You might want to exclude also other directories, e.g. the recordings in case you are performing automatic recordings. For more information, search for "man tar" in the search engine of your chioce... In Windows, you can just ZIP the folder.

Link to comment
Share on other sites

Hi

 

So the main trick was to issue the command once positioned in the right directory. However, I had to write the command as previously recommended, as follows:

 

tar -zcvf backup20140123.tar.gz /desired-directory

 

That was the way that I was able to get my file. Thanks!

 

Regarding excluding things, If I would like to keep everything exception made of the recorded conversations the command would be:

 

tar -zcvf name-of-backup-file.tar.gz /desired-directory --exclude /recordings/pbx.company1.com --exclude /recordings/pbx.company2.com and so forth?

 

Regards

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...