Jump to content
Vodia PBX forum
LouisG

Externe Rufnummer bei Weiterleitung anzeigen lassen

Recommended Posts

Hallo.

 

Ich habe folgendes System. Eine Snom One Pbx an einer Fritzbox. Dann habe ich eine Rufnummer die als Hotlinenummer dient und per Kurzwahltaste an einem Snom 300 weitergeleitet wird an ein Handy.

 

Wenn der Anruf am Handy ankommt sehe ich allerdings nur die Hotlinenummer und nicht die Nummer des Anrufenden.

Kann mir hier jemand weiterhelfen? Vielen Dank schon mal im Vorraus

Share this post


Link to post
Share on other sites

Ja das dürfte inzwischen ein Klassiker sein. Die meisten SIP-Trunk Anbieter erlauben es nicht dass eine Nummer angezeigt wird die nicht zum Anschluss gehört. Z.B. könnte man da ja die Rufnummer von Angela Merkel (soweit bekannt) anzeigen lassen, obwohl sie gar nicht am Telefon ist. Um das sicher durchführen zu können, muss der Anbieter wissen woher der ursprüngliche Anruf kommt. Wir verwenden dazu den In-Reply-To Header (RFC3261); aber wie gesagt das wird nur von ganz wenigen Anbietern unterstützt.

Share this post


Link to post
Share on other sites

Der wird immer angezeigt (das schadet nicht). Offenbar unterstützt die Telekom das nicht. Die meisten Anbieter untertützen dass nicht; die Angst eine Caller-ID anzuzeigen die nicht vom Kunden kommt ist wohl zu groß. Aber vielleicht würde ich trotzdem mal nachfragen; bei ISDN gehts ja schliesslich auch.

Share this post


Link to post
Share on other sites

Hallo,

 

ich bin mir nicht sicher ob hierfür einen neuen Post aufmachen soll oder diesen benutzen, ich probier erstamla hier.

 

Unser Anbieter sipgate scheint das zu unterstützen, dennoch funktioniert das irgendwie nicht. Was kann ich machen. In unserer Hostet Version sind schon einige Einstellungen gemacht Orden, und ich würde ungern da jetzt dran rum Pfuschen. ich schreib mal was Spinate als Vorgabe macht:

 

Bei ausgehenden Gesprächen setzen Sie bitte die gewünschte Absenderrufnummer im E164-Format (also international ohne führende Nullen oder "+"-Zeichen) als neuen Header P-Preferred-Identity:

SipAddHeader(P-Preferred-Identity: <sip:492111234567@sipconnect.sipgate.de>) Möchten Sie die Rufnummer unterdrücken, geht dies so:

SipAddHeader(P-Preferred-Identity: <sip:492111234567@sipconnect.sipgate.de>) SipAddHeader(Privacy: id)

Eingehende Anrufe werden Ihnen mit der vollen gewählten E164-Nummer in der Request URI signalisiert. So können Sie problemlos in der Variable ${EXTEN} damit arbeiten. Ein Herausschneiden der Nummer aus der To- URI ist nicht nötig.

Wenn Sie in Ihrer Telefonanlage Rufumleitungen schalten, können Sie dies auch signaliseren. Dazu nutzen Sie bitte den Diversion-Header und tragen dort die original angerufene Nummer (im folgenden Beispiel wurde diese im Dialplan in die Variable ORIGEXTEN geschrieben) ein:

SipAddHeader(Diversion: <${ORIGEXTEN}@sipconnect.sipgate.de>)

 

Kann man damit auf eine Lösung kommen?

 

Danke schonmal!

Share this post


Link to post
Share on other sites

Wir unterstützen auch Diversion; das ist in der Tat eine Möglichkeit da einen Schritt weiterzukommen. Das schöne an Diversion ist dass man da nicht an anderen Headern herumfummeln muss, es also relativ leicht möglich ist das einmal auszuprobieren. Ich würde vorher ein "Backup" der Trunk-Daten machen (Copy & Paste im Text-Mode in der Leitung/Trunk), für denn Fall dass doch was untergeht.

Share this post


Link to post
Share on other sites

Der Trunk hat folgende Einstellungen:

# Trunk 2 in domain awebfon.hostedi.am
Name: SipGateAA-HA
Type: register
RegPass: ********
Direction:
Disabled: false
Global: false
Display: 1707635t0
RegAccount: 1707635t0
RegRegistrar: sipconnect.sipgate.de
WrtcDestName:
WrtcDestNumber:
RegKeep:
RegUser: 1707635t0
Icid:
Require:
OutboundProxy: sip:sipconnect.sipgate.de:5060
Ani: *
DialExtension: !380371([0-9]+)$!!t!15
Trusted: false
AcceptRedirect: false
RfcRtp: false
BehindNat: false
RtcpXr: false
Analog: false
RtpBegin:
RtpEnd:
Prack: true
SendEmail:
UseUuid: false
Ring180: false
Failover: never
HeaderRequestUri: {request-uri}
HeaderFrom: {trunk}
HeaderTo: {request-uri}
HeaderPai:
HeaderPpi: <{ext-ani-e164}@{trunk-host}>
HeaderRpi:
HeaderPrivacy: {if clip true}id{fi clip true}
HeaderRpiCharging:
BlockCidPrefix:
Glob: plus
RequestTimeout:
Codecs: 18 2 9 3 8 0
CodecLock: false
Pcap: false
DtmfMode:
Expires: 3600
Fraction: 128
Minimum: 10
FromUser:
FromSource: ppi
Tel: true
TranscodeDtmf: false
AssociatedAddresses:
InterOffice: false
DialPlan:
UseEpid: false
CidUpdate:
Ignore18xSDP: true
UserHdr:
Diversion: {rfc}
CoBusy: 486 Busy
CoDest:
Colines:
DialogPermission:
Muss ich in Diversion Header was anderes als Standart RFC einstellen?

Share this post


Link to post
Share on other sites

Ja wir müssen mal sehen was gerade mit dem Diversion-Header los ist. Das ist auf der To-Do Liste.

 

Hallo,

gibts da schon News ob der Diversion-Header nun funktioniert oder nicht?

 

Wir haben es letztes Jahr aufgegeben mit der Rufweiterleitung zu spielen(der offizielle SnomOne Support konnte auch nicht mehr helfen), allerdings beschweren sich (zurecht) immer mehr Endkunden darüber dass eben immer nur die eigenen Nummer angezeigt wird.

 

Gibt es eine Möglichkeit den Division Header irgendwie zu sehen (also wie der im Normalfall aufgebaut ist)? In den normalen Logs (stufe 9) wäre mir da nichts aufgefallen...

 

Im Prinzip würde es reichen den normalen Header so umzuschreiben dass dort die originale Nummer weggeht (unser Provider unterstützt das so, wir haben dort einen Trunk). Derzeit verwenden wir aufgrund unserer Config eh schon angepasste Header...

 

HeaderRequestUri: {request-uri}

HeaderFrom: "{ext-display}" <sip:{ext-ani}@DOMAIN.at;user=phone

HeaderTo: <sip:{global-uri-number}@DOMAIN.at>

HeaderPai: {ext-ani}@DOMAIN.at

HeaderPpi:

HeaderRpi:

HeaderPrivacy: {if clip true}id{fi clip true}

HeaderRpiCharging:

Share this post


Link to post
Share on other sites

Bei VOIP über ein ISDN Gateway funktioniert die Weiterleitung der original Nummer ohne Probleme. Man muss allerdings das kostenpflichtige Feature "CLIP no screening" aktiviert haben. Ich habe an den Trunkeinstellungen der snomONE nichts geändert. Diversion: {rfc} >> Standard(RFC). Es kommt hier auf die Einstellungen im Gateway an. Bei unserem Patton Gateway musste ich ein 3 stufige "Complex Function" bei abgehenden Calls hinterlegen. Sie überschreibt die ausgehende Nummer mit der Rufnummer des orginal Anrufers calling-e164 Of > calling-e164 To.

 

Grüße

Gifti

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...