Jump to content

Deutsche Telekom


Recommended Posts

  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

On 7/18/2018 at 6:33 PM, Bronko said:

Here we have the Log Entries for one of my DTAG Number with normal (currently failed Registration) "Proxy address": "tel.t-online.de"

[8] 18:23:52.446	TRUN:	Trunk 5: Preparing for re-registration
[8] 18:23:52.446	TRUN:	Trunk 5: sending discover message for tel.t-online.de
[8] 18:23:52.449	TRUN:	Trunk 5 (03????????) is associated with the following addresses: tls: tls: tls:
[8] 18:23:52.450	TRUN:	Trunk 03????????): Sending registration to sip:tel.t-online.de
[5] 18:24:24.451	TRUN:	Registration on trunk 5 (03????????) failed with code 408. Retry in 60 seconds

May be we don't have to use TLS here?

Since I doubted the TLS Trunk availability for DTAG private costumers I tried to extend "Proxy address"  by:



Both is working fine:

[8] 0:19:09.003	TRUN:	Trunk 5: sending discover message for tel.t-online.de
[8] 0:19:09.162	TRUN:	Trunk 5 (03????????) is associated with the following addresses: udp:

Why the PBX was using TLS since July, 10 at 02:38 am?

Different NAPTR record in DNS of tel.t-online.de?

Link to comment
Share on other sites

On 7/11/2018 at 4:17 PM, Bronko said:

Yes... the time is typical for Deutsche Telekom to load new running_config in network devices.

$ dig -t NAPTR tel.t-online.de

; <<>> DiG 9.11.2-P1 <<>> -t NAPTR tel.t-online.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61953
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;tel.t-online.de.		IN	NAPTR

tel.t-online.de.	4425	IN	NAPTR	20 0 "s" "SIP+D2U" "" _sip._udp.tel.t-online.de.
tel.t-online.de.	4425	IN	NAPTR	10 0 "s" "SIPS+D2T" "" _sips._tcp.tel.t-online.de.
tel.t-online.de.	4425	IN	NAPTR	30 0 "s" "SIP+D2T" "" _sip._tcp.tel.t-online.de.

;; Query time: 0 msec
;; WHEN: Wed Jul 11 16:19:24 CEST 2018
;; MSG SIZE  rcvd: 208

I'm currently on my investigation in wireshark, any special request?

Here we see _sips._tcp. have highest Priority (10), why the PBX don't fallback to next Prio _sip._udp. (20) or _sip._tcp. in the case of failure?

Link to comment
Share on other sites

On 7/20/2018 at 8:43 PM, Vodia PBX said:

Ehhhhhhhhhhhhhh so going back to UDP works for you? That would answer the question if your IP address works, but it would still make me wonder why TLS does not work. And if UDP works, maybe TCP also works (which is a lot more stable than UDP).

Sorry, once more: SIPS (5061) isn't available for private costumers on DTAG, but it seems they are playing currently on this feature.

"Proxy address:"


is working too!


Link to comment
Share on other sites

  • 4 weeks later...

So, we had the issue that outgoing calls were not working for a few days. We would always get a "SIP/2.0 503 Service Unavailable" back. Incoming calls and registration worked fine.

I saw the tls: connections in the log and didn't think much of it ("well finally DTAG got their asses up and encrypted SIP"), though thanks to this thread I've found this to be the root cause of the problem. Changing the transport manually to either UDP or TCP solves the outgoing call problem 100 % of the time. Thanks for debugging this and sharing your findings!

Link to comment
Share on other sites

  • 3 weeks later...
On 8/15/2018 at 12:22 PM, sfp0 said:

..Thanks for debugging this and sharing your findings!

You are welcome...

One additional comment for DTAG Trunk Setup:

Around the time of these issue (408) my extensions (phones: Gigasets, snom870) starts again to don't play a ringback tone for some  called numbers; some of these DTAG, too.

Over the years and for now I found these Ringback setup works as it should:


Screenshot from 2018-08-31 11-42-02.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...