Jump to content

Page ALL not working


malcolm@joosse.me
 Share

Recommended Posts

II have a home install of Vodia 65.0 Win2019 Server.  There are 16 phone handsets on the network.

I want to be able to page all handsets for any of the handsets.

I thought this would be easy, but it appears I have missed something.

image.png.c633c1923ed4e33ff63904ccbc388ced.png

 

all extension permissions are the same

image.thumb.png.c30eb62c2f4ed4b84bbe92c52caf2a67.png

 

This is what I see when I test the call.  It appears it is not hanging up the call after the page as well.  When you dial 800# you hear the paging tone, but there is no audio, then the exist tone when you hang up.

image.png.2f0eea06ab7e7bda7cb15b1f92d49f6d.png

 

I have tried multi and unioast and both play the paging tone, but no  voice.

All the handsets are Yealink T58's with recent firmware

Please help.

 

Link to comment
Share on other sites

1. Can you change the source from "2*" to just "*" ?

2. Why are you dialing 800# ? Is dialing just 800 not working?

3. Have you provisioned the phones AFTER you made all the multicast setting on the PBX? If not, can you please make the above changes and provision few of the phone to try out again?

4. Also, if PBX and phones are on the same LAN, you can even turn on the LAN prov.

Link to comment
Share on other sites

On 8/4/2020 at 12:29 AM, Support said:

1. Can you change the source from "2*" to just "*" ? Done

2. Why are you dialing 800# ? Is dialing just 800 not working? Either works, but # just dials out without having to press the send or wait 4sec on a Yealink.

3. Have you provisioned the phones AFTER you made all the multicast setting on the PBX? If not, can you please make the above changes and provision few of the phone to try out again? This may be the problem.  I did "Re-sync the accounts" option.  Is this enough, or do I need to do a "Reprovision"?

4. Also, if PBX and phones are on the same LAN, you can even turn on the LAN prov. I could not find any option to turn this feature on.  The phones and Vodia are on the same LAN.

Appreciate the assistance,  I have multicast on, but I think the Reprovision is needed, not a resync, which I have been doing

Link to comment
Share on other sites

  • 2 months later...

Sorry for the delay in replying to this thread, but I am still having issues.  I managed to get to their site on Friday to do some testing.

I have still been trying to setup a "Paging ALL" group with 16 handsets, and also 3 individual paging groups of about 6 extensions in each group as 3 separate "floor paging" groups

Ideally I would like to only use Unicast paging, as Vodia is running on a powerful server in a house, so load is not an issue.  Is there a software limitation for Unicast in Vodia ?

When I setup each paging level group, it will fail with "not available" on the screen of the handset making the call.  I have worked out that any more than 3 extensions in a Unicast paging causes the paging group to come up on the handset as "Not Available".  As soon as I add a 4th extension, it will fail.  3 extensions in the group works fine

From what I have read in the documentation (https://doc.vodia.com/paginggroups) I should be able to have 10 extensions in a Unicast group. Is there some trick or something I have missed in getting more than 3 handsets to work ?

I changed the Page All to Multicast and followed the recommendation of having the source set to *

The Problem I am having with the "Page All" when setup with Multicast with LAN Paging for all 16 handsets, I hear the announcement tone on all the handsets, but no voice audio.  I have tried several different codecs, but nothing seems to enable the voice to be heard on the handsets. I have reprovisioned the phones after each change and can see the changes in the handset configuration.  

One thing i noticed when doing Multicast NO LAN paging, was that the call was not disconnecting when I would hang up. I would see the call in the "active calls" and would have to delete it.  After checking the logs, I see that a call made to the "Page All" group  would go out on the SIP Trunk. 

image.png.11ca105543b2efce59b609a17cf58f60.png

I cannot seem to find anywhere where this can be configured.  The paging is all setup under "paging groups" and configured the same as the documentation.

So I am not sure why paging has gone so wrong, as I though I have setup everything correctly. Everything else is working fine.

Please help, as testing onsite is difficult, due to CV19 and getting access to the site.

Link to comment
Share on other sites

There is usually a limit of number of multicast paging groups that you can have on a single phone between 8 and 10 groups. Make sure that you don't have too many groups on each device. The PBX itself has no limit (apart from possible license limits). 

Depending on the network setup, you might have to explicitly tell the PBX to what IP address it should bind the multicast sockets. If there are multiple interfaces, it might bind to the wrong interface and then the phones would not see any multicast traffic coming in.

Unicast  makes sense if there are less than lets say 5 phones in a group. Its not only the server load, its also the problem that all phones have to accept the call before the page can begin. There is no hardcoded limit. 10 might be a high number, but it should still work. I would always prefer multicast if the page is in the LAN.

You also need to make sure that the extension starting the page has the permission to do so. 

The page should not go to a trunk. The only case where I can imagine this is when the page number is an emergency number. It is not a good idea to use an emergency number for a paging group. 

If you have remote access to the PBX you should be able to "see" what is going on in the network with Wireshark, either on the PBX itself or on a desktop phone (most desktop phones have a Wireshark feature from the web interface). 

Link to comment
Share on other sites

Thanks for the assistance.

The paging groups all have * for the Source, I can hear the default paging tone when I dial, so I do not think permissions is the issue.

The server has 5 NIC's with only 1 dedicated for Voice. I can see that under the System Status overview, they are all bound to the Vodia IPv4 address.  How can I have it only bound to the single IP ?

It is possible that Multicast is on a different interface, but I cannot find where to bind Vodia to only one NIC.

The network has 3 separate VLANs (Data, CCTV and Voice), each bound to a different NIC, with one spare and another for the server management card.

I think the best way to setup these paging groups is with Multicast LAN Paging, as they are all on the same LAN segment, and I think that it most likely is due to the interface bindings.

Hopefully I can bind Vodia to a single NIC and this might solve the problems.

 

Link to comment
Share on other sites

I was having a further search and found this https://doc.vodia.com/onewayaudio which lists a one way audio problem fix for Yealink.

I checked my Vodia server and have 49152-64512 in the TCP & UDP port ranges in Vodia.  On the Yealink T58's the range for the "Reserve Port scope" is 50000-50249, there is no RTP port listed in the Yealink, but I suspect it is the "Reserve Port"

Could this possibly be an issue, as the server is outside the range of the handsets ?

I also found the IP Binding under the RTP section, to bind to the specific IP

 

Link to comment
Share on other sites

You can check if there is a one way audio problem by just calling that extension. If it works, it will also work for paging. The ports can be different on the phone and the PBX, e.g. sending from the PBX port 1234 to the phone port 2345 would be perfectly fine. 

I would still use the PCAP feature for the phone to capture multicast traffic. Then you can see what is actually arriving in terms of multicast RTP on the phone—or its absence. If there is no RTP when it should, binding the multicast RTP to a specific IP address (if there are more than one) on the PBX may be the answer.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...