Jump to content

Issues with Yealink RPS since upgrade


GregV
 Share

Recommended Posts

Recently upgraded to 67.0.5.

Communication with Yealink RPS seems to be broken.

Enabled logging 9 and seeing RPS failed messages when the Vodia PBX tries to communicate with Yealink RPS.

" Problems with adding Yealink server http://xxx.xxx/prov/yealink.cfg?rps=1 and name e320536db9415xxxxxx"
 

"Add Yealink MAC 805E0C0Axxxx to server undefined"

"RPS failed"

Tried regenerating the API key and Secret, no change.

Checked my servers IP is in the allowed list on the Yealink RPS.

This was working perfectly before the upgrade.

Is there a know issue?

P.S. SNOM RPS working fine

Link to comment
Share on other sites

There was an issue with deleting MAC, but more of cosmetic nature. Adding a MAC was working fine. There were a few messages from Yealink about updates of the RPS, maybe you were just hitting the maintenance window. 

Link to comment
Share on other sites

  • 3 weeks later...

For some reason the communication between my Vodia PBX AWS Instance and Yealink is failing and I don't know why.

I have the correct API key and secret in place, and the API path is default "https://api-dm.yealink.com:8443/xmlrpc"

I have also added the public IP of my server to the Allow list in Yealink DM.

But every time the Vodia PBX needs to contact Yealink to update I get failures;

   "Problems with adding Yealink server http://xxx.xx.xxxx.com.au/prov/yealink.cfg?rps=1 and name d635e03fd52be8585876

   "Add Yealink MAC 805EC0CDD185 to server undefined"

   "RPS failed"

It retires 4 times and stops.

I've tried this with new PBX domains and old ones, new MAC addresses and old ones, they all fail now.

This use to work well, but since the upgrade to 67.0.5 its stopped working.

Can you suggest what I might be able to do to troubleshoot this further?
 
 
Link to comment
Share on other sites

Please go to /reg_certificate.htm and hit the reset button at the bottom of the page and see if that helps.

Also make sure that the RPS server has not been blacklisted from under the /reg_access.htm page

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...