Jump to content

Yealink Provision does not work new version


Guest LapeuilleTelecom
 Share

Recommended Posts

Guest LapeuilleTelecom

Tried to provision Yealink via old system. Old version worked fine. New one no create server name. Is it because of tenant no longer dns address?

 

[7] 10:53:29.299   https://api-dm.yealink.com:8443/api/open/v1/server/add: Return code 200 (126 bytes)ⓘ
{"ret":-1,"data":null,"error":{"msg":null,"errorCode":400,"fieldErrors":[{"field":"serverName","msg":"server.name.existed"}]}}
[8] 10:53:29.299   https://api-dm.yealink.com:8443/api/open/v1/server/add: Return headersⓘ
Server: nginx
Date: Tue, 15 Nov 2021 15:53:29 GMT
Content-Type: application/json;charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
X-Application-Context: business-ws-rps:cluster-primary-first-test:9983
Strict-Transport-Security: max-age=16000000;includeSubDomains;preload;
X-Frame-Options: DENY
Referrer-Policy: no-referrer-when-downgrade
X-Content-Type-Options: nosniff
X-XSS-Protection: 1;mode=block
[8] 10:53:29.299    Add Yealink MAC 805E0C49ABCD to server undefinedⓘ
[9] 10:53:29.299    https:api-dm.yealink.com:8443: Send request (427 bytes)ⓘ
POST https://api-dm.yealink.com:8443/api/open/v1/device/add HTTP/1.1
Host: api-dm.yealink.com:8443
Content-Type: application/json
Content-MD5: eEFKxQFqyrHaT3nR3TqVOw==

Link to comment
Share on other sites

Hello,

Just to add to this, i decided to test on 68.0.4. I got the same results.

 

The logs look pretty much identical. It populates on the RPS portion but the server name is blank/null.

 

Tested with an older v67. The problem did not exist and created the entries without issue.

 

The biggest difference between these versions is that on v68. the domains are called "Tenants". Is the PBX trying to send the system name when creating the records? It should always be the DNS of the tenant/pbx.

 

The firmware of the phone doesn't really matter because at this level it's the PBX failing the API call to Yealink's RPS and providing it with a null/blank server name. Any phone will fail provisioning in this condition.

You might want to address this ASAP since this affects everyone with a Yealink RPS account.

Link to comment
Share on other sites

  • 1 month later...

I can confirm this is indeed not working correctly. 

This is what's happening.

1. Vodia -> add server -> {name, url} -> yealink rps -> returns 400 {server name already in use} //This is where you should have stopped executing your code.  I can't find the POST BODY in the logs, so I don't know what you sent originally. 
2. Voida -> add device -> {mac, serverName} -> yealink rps -> returns 400 {server name is undefined} //ServerName is undefined, because it was not created in step one.
3. Repeat 3 more times ha.

The original error "server name already in use" is strange. I would have to see what name was being sent. This error happened to me too. But, I have a fresh RPS account with nothing in it.

This isn't that big of a deal for me. I remember a couple of years ago, when yealink was changing and deprecating core urls and functions MONTHLY. At the company I did work for. I created my own autop service with the yealink rps. Boy was it a pain. Every month, was some crazy breaking change. 

I am just adding the servers manually in the RPS until this is fixed. No biggie. The Grandstream RPS is outdated too. It's not working for the new GDMS. But, again, I just do that part manually. I really don't mind.

 

Advice to anyone landing here, just create the server and add the device in RPS Management, and then add the mac to the extension in Vodia and don't forget to open it for provision.

Link to comment
Share on other sites

  • 1 month later...

The problem is that the RPS server does return server name in use, but there is no way to find the server. At least we did not figure out how to find it... IMHO the API should be updated to resolve this. The other way to get this working is to remove the server from the RPS web interface and sync the phone again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...