Jump to content

Broadvox Static Trunk Setup


Worm78
 Share

Recommended Posts

I currently have a Teliax trunk setup and working using the registration type. I'm looking to switch to Broadvox due to constant outages and poor support with Teliax.

 

I have setup an account with Broadvox. They have two types at which you can setup. Static which acts as a Gateway and needs registration turned off. Then dynamic which seems to work like the regular registering trunk. I know there is a few issues that were discussed in this post with the TO field. http://forum.pbxnsip.com/index.php?showtop...amp;hl=broadvox I have also seen a few posts regarding the domain name being local host and not the public ip causing issues.

 

Question is, is there a way to disable registraton on that specific trunk and not across the board, or can you even disable it across the board. This would work long term but not during testing as this would eliminate the ability for me to keep my Teliax trunk up. I have looked at the tips on the wiki for broadvox but it doesn't seem to help.

 

Currently running version 1.5.2.10a

 

 

 

Thank You,

Brian

Link to comment
Share on other sites

I currently have a Teliax trunk setup and working using the registration type. I'm looking to switch to Broadvox due to constant outages and poor support with Teliax.

 

I have setup an account with Broadvox. They have two types at which you can setup. Static which acts as a Gateway and needs registration turned off. Then dynamic which seems to work like the regular registering trunk. I know there is a few issues that were discussed in this post with the TO field. http://forum.pbxnsip.com/index.php?showtop...amp;hl=broadvox I have also seen a few posts regarding the domain name being local host and not the public ip causing issues.

 

Question is, is there a way to disable registraton on that specific trunk and not across the board, or can you even disable it across the board. This would work long term but not during testing as this would eliminate the ability for me to keep my Teliax trunk up. I have looked at the tips on the wiki for broadvox but it doesn't seem to help.

 

Well, in gateway mode you can use the "domain" name to present something else than "localhost" (for example, you can put your public IP there). Always use the outbound proxy! Broadvox also changed their software a lot, there is no need to turn UUID off now any more.

 

Registration mode has the advantage that you can register easily; but the caller-ID presentation is more difficult. Therefore I would tend to prefer the gateway mode. You can switch the trunk in the PBX between gateway and registration mode either during the setup or later in the select field when editing the trunk.

 

BTW I think it is awesome that Broadvox supports both register mode and gateway mode.

 

Currently running version 1.5.2.10a

 

I see you like to good old stuff. Consider moving to the latest (maybe first with a 3-minute demo key, get it here: http://www.pbxnsip.com/trial). A lot of new feature and improvements over the last couple of years!

Link to comment
Share on other sites

I'm currently receiving (408 Request Timeout (Registration failed, retry after 60 seconds)) in the trunk list. I spoke to Broadvox and they said to leave the registration info blank. I have triedb oth ways but get the same results.

 

 

I also have not changed the localhost to anything. Will changing this cause any other issues?

 

I'm thinking I have the same issue as this guy.

 

http://forum.pbxnsip.com/index.php?showtop...amp;hl=broadvox

 

However he is using dynamic as he has a user and password.

 

Thanks,

Brian

 

 

 

 

 

 

 

Well, in gateway mode you can use the "domain" name to present something else than "localhost" (for example, you can put your public IP there). Always use the outbound proxy! Broadvox also changed their software a lot, there is no need to turn UUID off now any more.

 

Registration mode has the advantage that you can register easily; but the caller-ID presentation is more difficult. Therefore I would tend to prefer the gateway mode. You can switch the trunk in the PBX between gateway and registration mode either during the setup or later in the select field when editing the trunk.

 

BTW I think it is awesome that Broadvox supports both register mode and gateway mode.

 

 

 

I see you like to good old stuff. Consider moving to the latest (maybe first with a 3-minute demo key, get it here: http://www.pbxnsip.com/trial). A lot of new feature and improvements over the last couple of years!

Link to comment
Share on other sites

I'm currently receiving (408 Request Timeout (Registration failed, retry after 60 seconds)) in the trunk list. I spoke to Broadvox and they said to leave the registration info blank. I have triedb oth ways but get the same results.

 

 

I also have not changed the localhost to anything. Will changing this cause any other issues?

 

I'm thinking I have the same issue as this guy.

 

http://forum.pbxnsip.com/index.php?showtop...amp;hl=broadvox

 

However he is using dynamic as he has a user and password.

 

Thanks,

Brian

 

Have you changed the trunk type to "SIP Gateway"? After that,

-Set the domain and the outbound proxy fields to IP address of Broadvox's IP

-Clear out the password fields (after you save the page you would still see ***** in that field. That's okay)

-Hit "Save"

Link to comment
Share on other sites

Have you changed the trunk type to "SIP Gateway"? After that,

-Set the domain and the outbound proxy fields to IP address of Broadvox's IP

-Clear out the password fields (after you save the page you would still see ***** in that field. That's okay)

-Hit "Save"

We are using Broadvox as a Gateway at several clients without any issues.

Link to comment
Share on other sites

Have you changed the trunk type to "SIP Gateway"? After that,

-Set the domain and the outbound proxy fields to IP address of Broadvox's IP

-Clear out the password fields (after you save the page you would still see ***** in that field. That's okay)

-Hit "Save"

 

 

The domain is named my public IP or the IP I connect to at Broadvox?

 

Thanks,

BR

Link to comment
Share on other sites

Attached is a screenshot of one of my broadvox config's, you may need 2 inbound trunks as they sometimes send calls from multiple IP Addresses or DNS names.

post-288-1229354076_thumb.jpg

 

Thanks for the help but i can't view the picture. It is weird. It says I'm not logged in however It shows me logged in just above the error. Same issue from two machines after relogging in.

 

Must be a forum bug.

 

BR

Link to comment
Share on other sites

Thanks for the help but i can't view the picture. It is weird. It says I'm not logged in however It shows me logged in just above the error. Same issue from two machines after relogging in.

 

Must be a forum bug.

 

BR

If you send me a private message with your email address, I can send you the image as an attachment.

Link to comment
Share on other sites

  • 4 weeks later...
If you send me a private message with your email address, I can send you the image as an attachment.

 

 

All is good with my Trunk setup. Thanks for the help.

 

One issue I'm still having is caller ID. I only have one DID coming in on one trunk. One domain. There is an alias on it with my outside static IP. Broadvox said my From User is blank. Said it shouyld be in a sip.cfg on an asterisk system. Anyone know what that equates to in PBXNSIP gui? I have tried RFC settings with no luck. How did you get yours to work?

Link to comment
Share on other sites

All is good with my Trunk setup. Thanks for the help.

 

One issue I'm still having is caller ID. I only have one DID coming in on one trunk. One domain. There is an alias on it with my outside static IP. Broadvox said my From User is blank. Said it shouyld be in a sip.cfg on an asterisk system. Anyone know what that equates to in PBXNSIP gui? I have tried RFC settings with no luck. How did you get yours to work?

What do you have set for the ANI on the trunk?

Link to comment
Share on other sites

This should work for Broadvox, unless they are overwriting the caller ID on their end.

Global: yes

Trunk ANI: 5555551212

Remote Party/Privacy Indication: Remote-Party-ID

 

 

No luck I did just realize something, took me a second and shouldn't admit it. The EXT i'm testing from is ext 121 Hence the 9 121 being sent to my cell. Is there a global setting for caller id anywehre? My old provider had it set and over wrote on their end so i never had the issue.

 

 

Brian

Link to comment
Share on other sites

No luck I did just realize something, took me a second and shouldn't admit it. The EXT i'm testing from is ext 121 Hence the 9 121 being sent to my cell. Is there a global setting for caller id anywehre? My old provider had it set and over wrote on their end so i never had the issue.

 

 

Brian

 

 

 

Just got it :) There was a 9 in the prefix area...oops

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...