Jump to content

NO RINGBACK TONE


Friedom-Tech
 Share

Recommended Posts

HI;

 

i am using a PRI card with pbxnsip latest version but i have an issue where a caller calls in and does not hear any audio untill the caller picks up or it goes to voicemail...im assuming it is not playing the ringback tone but i checked the audio folder and the ringback.wav file is there.

 

pls advise asap as clients are hanging up the phone because they think it is not going through

Link to comment
Share on other sites

i am using a PRI card with pbxnsip latest version but i have an issue where a caller calls in and does not hear any audio untill the caller picks up or it goes to voicemail...im assuming it is not playing the ringback tone but i checked the audio folder and the ringback.wav file is there.

 

Some trunks cannot deal with early media. Check if you have the flag "Ringback" set to "Message 180".

 

You can easily see if the PBX sends media by using Wireshark. That should further help to nail the problem.

Link to comment
Share on other sites

Some trunks cannot deal with early media. Check if you have the flag "Ringback" set to "Message 180".

 

You can easily see if the PBX sends media by using Wireshark. That should further help to nail the problem.

 

Hi; it was using Message 180 at first but even after i changed to media it still didnt work!!

Link to comment
Share on other sites

Looks like you need Wireshark to see what is going on.

 

I dont think it is a wireshark issue as the logfile does not show that it is playin Ringback.wav...i will show below the logfile.

 

5] 2009/02/05 09:18:47: Identify trunk (IP address and DID match) 2

[7] 2009/02/05 09:18:47: Set packet length to 20

[6] 2009/02/05 09:18:47: Sending RTP for e74464f9-f38f-11dd-bf57-d03f7f763324@pbx#ae480c5bb3 to 10.0.10.16:14010

[5] 2009/02/05 09:18:47: Trunk T1 sends call to 8401 in domain localhost

[7] 2009/02/05 09:18:47: Attendant: Calling extension 8401

[7] 2009/02/05 09:18:47: Set packet length to 20

[7] 2009/02/05 09:18:47: Call e05e8ec6@pbx#3380: Clear last request

 

I HAVE LOOKED AT OTHER PBX'S AND THEY SHOW THE FOLLOWING LINE WHICH THIS PBX IS NOT SHOWING

 

[8] 2009/02/05 09:20:32: Play audio_en/ringback.wav

 

why would my phone system stop playing this back? system files corrupted?

 

pls advise asap

 

thank you

Link to comment
Share on other sites

I dont think it is a wireshark issue as the logfile does not show that it is playin Ringback.wav...i will show below the logfile.

 

5] 2009/02/05 09:18:47: Identify trunk (IP address and DID match) 2

[7] 2009/02/05 09:18:47: Set packet length to 20

[6] 2009/02/05 09:18:47: Sending RTP for e74464f9-f38f-11dd-bf57-d03f7f763324@pbx#ae480c5bb3 to 10.0.10.16:14010

[5] 2009/02/05 09:18:47: Trunk T1 sends call to 8401 in domain localhost

[7] 2009/02/05 09:18:47: Attendant: Calling extension 8401

[7] 2009/02/05 09:18:47: Set packet length to 20

[7] 2009/02/05 09:18:47: Call e05e8ec6@pbx#3380: Clear last request

 

I HAVE LOOKED AT OTHER PBX'S AND THEY SHOW THE FOLLOWING LINE WHICH THIS PBX IS NOT SHOWING

 

[8] 2009/02/05 09:20:32: Play audio_en/ringback.wav

 

why would my phone system stop playing this back? system files corrupted?

 

Well, the reason could be that the system is not supposed to signal that the other side is actually ringing. Or something simple like the log level is set to 7 and the PBX would not show a message on log level 8. I assume the file is in the file system. Corrupy file systems are pretty low probability these days.

 

It could be really something that the phone is really not ringing or that the PBX does not know about it. A Wireshark trace from the PBX server will show this.

Link to comment
Share on other sites

make sure you downloaded:

 

http://pbxnsip.com/download/audio_moh_30.zip

and

http://pbxnsip.com/download/audio_en_30.zip

 

 

are you using the NETBORDER product? or a gateway?

 

i had those folders in there but redownloaded them just incase.

the system has also been working for months untill a few days ago....i am using the Netborder Gateway with a Sangoma card.

Link to comment
Share on other sites

Well, the reason could be that the system is not supposed to signal that the other side is actually ringing. Or something simple like the log level is set to 7 and the PBX would not show a message on log level 8. I assume the file is in the file system. Corrupy file systems are pretty low probability these days.

 

It could be really something that the phone is really not ringing or that the PBX does not know about it. A Wireshark trace from the PBX server will show this.

 

im sorry but im not understanding what you are saying.

 

the log level on both pbx's are set with exactly the same settings and when i look in the list of active calls i see the incoming call and once the person picks up audio both ways is fine....

 

please advise exactly what you want me to do to further troubleshoot this.

Link to comment
Share on other sites

im sorry but im not understanding what you are saying.

 

the log level on both pbx's are set with exactly the same settings and when i look in the list of active calls i see the incoming call and once the person picks up audio both ways is fine....

 

please advise exactly what you want me to do to further troubleshoot this.

 

im looking in the log now and for some reason now i see that it is playing rinback.wav...could this be an issue with my sangoma card?

Link to comment
Share on other sites

  • 2 weeks later...
this is still an open issue which is obviously an emergency as far as the client is concerned...they have clients hanging up all day frustrated that calls are not getting through.

 

can you please advise exactly what info you need from me...

 

thank you;

 

Hi;

 

this was fixed by Sangoma.

 

thank you for all your help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...