Jump to content

autoprovisioning snom


novo
 Share

Recommended Posts

I need to Update via HTTP or HTTPS!

 

root 2213 0.7 4.9 121648 25448 pts/0 S<l 15:35 0:05 /opt/pbxnsip/pbxctrl-debian4.0-3.3.0.3165 --dir /opt/pbxnsip/

 

I have a File named "settings-000413266111.xml" in the "html" Folder ind my pbxnsip root directory!

pbxnsip:/opt/pbxnsip/html# ll

total 4

-rw-r--r-- 1 root root 903 2009-03-25 14:55 settings-000413266111.xml

 

My Snom 370 is configured to Update from http://<IP-Adress of pbxnsip>/prvisioning/settings-000413266111.xml

 

pbxnsip:/opt/pbxnsip/html# tail -f /opt/pbxnsip/pbxnsip.log

[5] 20090325153728: Web Server: File snom370/snom370-firmware.htm not found

Link to comment
Share on other sites

I need to Update via HTTP or HTTPS!

 

root 2213 0.7 4.9 121648 25448 pts/0 S<l 15:35 0:05 /opt/pbxnsip/pbxctrl-debian4.0-3.3.0.3165 --dir /opt/pbxnsip/

 

I have a File named "settings-000413266111.xml" in the "html" Folder ind my pbxnsip root directory!

pbxnsip:/opt/pbxnsip/html# ll

total 4

-rw-r--r-- 1 root root 903 2009-03-25 14:55 settings-000413266111.xml

 

My Snom 370 is configured to Update from http://<IP-Adress of pbxnsip>/prvisioning/settings-000413266111.xml

 

pbxnsip:/opt/pbxnsip/html# tail -f /opt/pbxnsip/pbxnsip.log

[5] 20090325153728: Web Server: File snom370/snom370-firmware.htm not found

 

Since you are using 3.3.0.3165 of the PBX, you need to set 'just' the IP address of the PBX under snom 370's "Settings URL" (no http or the full path). Also, put the MAC address of the phone under "Registration" tab->"Bind to MAC Address" on PBX. Reset the phone.

Link to comment
Share on other sites

Since you are using 3.3.0.3165 of the PBX, you need to set 'just' the IP address of the PBX under snom 370's "Settings URL" (no http or the full path). Also, put the MAC address of the phone under "Registration" tab->"Bind to MAC Address" on PBX. Reset the phone.

 

 

it doesen't work, now i get some error in the Log from my Snom 370 (Firmware 7.3.14)

[5]24/12/2001 00:00:55: Fetching URL: tftp://xxx.xxx.xxx.xxx/snom370.htm

[5]24/12/2001 00:00:55: Conf setup: return code 500; requeueing >tftp://xxx.xxx.xxx.xxx/snom370.htm<; attempt: 8, state: 32

 

i need to provisioning by "HTTP" not "tftp"!

I dont see errors in the PBXnSIP Log!

 

The Snom Phones and the PBX are not in the same network!

Link to comment
Share on other sites

it doesen't work, now i get some error in the Log from my Snom 370 (Firmware 7.3.14)

[5]24/12/2001 00:00:55: Fetching URL: tftp://xxx.xxx.xxx.xxx/snom370.htm

[5]24/12/2001 00:00:55: Conf setup: return code 500; requeueing >tftp://xxx.xxx.xxx.xxx/snom370.htm<; attempt: 8, state: 32

 

i need to provisioning by "HTTP" not "tftp"!

I dont see errors in the PBXnSIP Log!

 

The Snom Phones and the PBX are not in the same network!

 

If you are not in the same LAN; you must set the username and password now.

 

I used a string like "http://pbx.pbxnsip.com:2345/provisioning/snom820.htm", and that worked without problems. Using 3.3.1.3171, though. If you need a build to try this out, let us know.

Link to comment
Share on other sites

If you are not in the same LAN; you must set the username and password now.

 

I used a string like "http://pbx.pbxnsip.com:2345/provisioning/snom820.htm", and that worked without problems. Using 3.3.1.3171, though. If you need a build to try this out, let us know.

 

 

i have set username and password for the HTTP Client in Snom

 

now the error

[5]24/12/2001 00:00:34: Fetching URL: http://xxx.xxx.xxx.xxx/provisioning/settin...00413266111.xml

[1]24/12/2001 00:00:34: Conf setup: code: 404, host: xxx.xxx.xxx.xxx, file: /provisioning/settings-000413266111.xml

 

yes, i need the download link for this build!

Link to comment
Share on other sites

If you are not in the same LAN; you must set the username and password now.

 

I used a string like "http://pbx.pbxnsip.com:2345/provisioning/snom820.htm",'>http://pbx.pbxnsip.com:2345/provisioning/snom820.htm", and that worked without problems. Using 3.3.1.3171, though. If you need a build to try this out, let us know.

 

 

 

"http://pbx.pbxnsip.com:2345/provisioning/snom820.htm

 

is it necessary to use a Port?

 

same error,

 

Snom 370

[5]24/12/2001 00:00:34: Fetching URL: http://xxx.xxx.xxx.xxx/provisioning/settin...00413266111.xml

[1]24/12/2001 00:00:34: Conf setup: code: 404, host: xxx.xxx.xxx.xxx:80, file: /provisioning/settings-000413266111.xml

 

 

tail -f /opt/pbxnsip/pbxnsip.log

Web Server: File snom370/snom370-firmware.htm not found

Link to comment
Share on other sites

"http://pbx.pbxnsip.com:2345/provisioning/snom820.htm

 

is it necessary to use a Port?

 

same error,

 

Snom 370

[5]24/12/2001 00:00:34: Fetching URL: http://xxx.xxx.xxx.xxx/provisioning/settin...00413266111.xml

[1]24/12/2001 00:00:34: Conf setup: code: 404, host: xxx.xxx.xxx.xxx:80, file: /provisioning/settings-000413266111.xml

 

 

tail -f /opt/pbxnsip/pbxnsip.log

Web Server: File snom370/snom370-firmware.htm not found

 

If you are running the HTTP port on port 80, then you don't have to put the port there. If you are using a snom 370, then the URL should look like this: http://xxx.xxx.xxx.xxx/provisioning/snom370.htm.

Link to comment
Share on other sites

If you are running the HTTP port on port 80, then you don't have to put the port there. If you are using a snom 370, then the URL should look like this: http://xxx.xxx.xxx.xxx/provisioning/snom370.htm.

 

 

same error: :(

 

on pbx

pbxnsip:/opt/pbxnsip# tail -f /opt/pbxnsip/pbxnsip.log

[5] 20090331110323: Web Server: File snom370/snom370-firmware.htm not found

 

 

on snom

[5]24/12/2001 00:00:44: Conf setup: return code 400; requeueing http://xxx.xxx.xxx.xxx/provisioning/snom370.htm<; attempt: 1, state: 32

[5]24/12/2001 00:00:47: Fetching URL: http://xxx.xxx.xxx.xxx/provisioning/snom370.htm

 

when i use an standard webserver (http://webserver/snom.xml) with the snom xml config file - it works!

it is not a snom problem.

 

where is the error?

Link to comment
Share on other sites

same error: :angry:

 

on pbx

pbxnsip:/opt/pbxnsip# tail -f /opt/pbxnsip/pbxnsip.log

[5] 20090331110323: Web Server: File snom370/snom370-firmware.htm not found

 

 

on snom

[5]24/12/2001 00:00:44: Conf setup: return code 400; requeueing http://xxx.xxx.xxx.xxx/provisioning/snom370.htm<; attempt: 1, state: 32

[5]24/12/2001 00:00:47: Fetching URL: http://xxx.xxx.xxx.xxx/provisioning/snom370.htm

 

when i use an standard webserver (http://webserver/snom.xml) with the snom xml config file - it works!

it is not a snom problem.

 

where is the error?

 

I am getting the exact same error as novo using the 3.3.1.3171 build.

 

Joso

Link to comment
Share on other sites

I am getting the exact same error as novo using the 3.3.1.3171 build.

 

Joso

 

Joso, if you are not particular about the HTTP provisioning, you can follow these and get the phone provisioned

 

On the PBX:

 

1. Put the MAC address of the phone under the extension's "Registration page->Bind to MAC Address" field

2. Admin->Settings->PnP page- Trust MAC address ON

3. Admin->Settings->PnP page- point to the correct version of the firmware, something like http://provisioning.snom.com/download/fw/s....3.14-SIP-f.bin

 

 

On the phone, under Advanced->Update page

 

1. Update Policy: Update automatically

2. Settings URL: tftp://pbx-ip

3. Subscribe config: off

4. PnP Config: off

 

Hit "Save", then it will ask to reboot. After the reboot is successful (it goes through couple of reboots), you should have the phone registered.

Link to comment
Share on other sites

Joso, if you are not particular about the HTTP provisioning, you can follow these and get the phone provisioned

 

On the PBX:

 

1. Put the MAC address of the phone under the extension's "Registration page->Bind to MAC Address" field

2. Admin->Settings->PnP page- Trust MAC address ON

3. Admin->Settings->PnP page- point to the correct version of the firmware, something like http://provisioning.snom.com/download/fw/s....3.14-SIP-f.bin

 

 

On the phone, under Advanced->Update page

 

1. Update Policy: Update automatically

2. Settings URL: tftp://pbx-ip

3. Subscribe config: off

4. PnP Config: off

 

Hit "Save", then it will ask to reboot. After the reboot is successful (it goes through couple of reboots), you should have the phone registered.

 

One thing i noticed is when upgrading to 3.3.1, my pnp parameters are missing. the html folder holds all my settings. even internally the phones don't pick up the settings i have.

Link to comment
Share on other sites

One thing i noticed is when upgrading to 3.3.1, my pnp parameters are missing. the html folder holds all my settings. even internally the phones don't pick up the settings i have.

 

What missing parameters are you talking about?

There are couple of places you have PnP related settings

Admin->Settings->PnP page

Domain->Settings page: Provisioning Parameters section

Link to comment
Share on other sites

What missing parameters are you talking about?

There are couple of places you have PnP related settings

Admin->Settings->PnP page

Domain->Settings page: Provisioning Parameters section

 

The snom PnP is still a little bit work in progresss, I think we have to come out with a 3.3.2 build that seems to clean all the problems with the snom PnP up (and also some smaller issues we found with Polycom and Linksys). If you can hold it for one or two more days, hopefully then we have a version that makes plug and play a positive experience.

Link to comment
Share on other sites

i am referring to Admin->Settings->PnP page

 

as of now, i have reverted back to 3.2 until 3.3.2 comes out. with 3.2, my polycom conference phones work and my snom's provision great over http (remotely) as well as internally. Although i would like to use 3.3.X because of some nice features, especially customized email messages.

 

Thanks

 

Joso

Link to comment
Share on other sites

as of now, i have reverted back to 3.2 until 3.3.2 comes out. with 3.2, my polycom conference phones work and my snom's provision great over http (remotely) as well as internally. Although i would like to use 3.3.X because of some nice features, especially customized email messages.

 

3.2 is pretty stable. If you don't need the L&G this is very reasonable.

Link to comment
Share on other sites

now i use the version 3.2.0.3143 (Debian Linux 4) an get the error in the snom log!

 

"Conf setup: code 302"

 

 

--snip--

<?xml version="1.0" encoding="utf-8"?>

<settings>

<phone-settings>

<language perm="RW">Deutsch</language>

<web_language perm="RW">Deutsch</web_language>

<timezone perm="RW">GER+1</timezone>

<tone_scheme perm="RW">GER</tone_scheme>

<date_us_format perm="R">off</date_us_format>

<time_24_format perm="R">on</time_24_format>

<ntp_server perm="RW">time.sdt.net</ntp_server>

<user_server_type idx="1" perm="">pbxnsip</user_server_type>

<user_proxy_require idx="1" perm="">buttons</user_proxy_require>

</phone-settings>

</settings>

--snip--

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...