Jump to content

CPU SPIKING ALL THE TIME


Friedom-Tech
 Share

Recommended Posts

Hi;

 

Sorry to bother but I have an urgent issue by a client.

 

He is using a CS410 with approx 10 Snom 360's and all was working great but the past few days call quality has been really crappy..when someone is on the pohne and a second call comes in they cannot speak or hear anything....

 

I already tried switching the ISP they use to the backup DSL and tried a backup carrier but that didnt change anything in addition to the fact that even calls to mailbox sound garbled at times.

 

i noticed that the CPU is spiking alot and before i throw out this CS appliance and put this on a windows server can someone please advise what steps i can take to try and resolve this?

 

it is running latest version of pbx 3.4.

 

Thank you;

Michael

Link to comment
Share on other sites

He is using a CS410 with approx 10 Snom 360's and all was working great but the past few days call quality has been really crappy..when someone is on the pohne and a second call comes in they cannot speak or hear anything....

 

I already tried switching the ISP they use to the backup DSL and tried a backup carrier but that didnt change anything in addition to the fact that even calls to mailbox sound garbled at times.

 

i noticed that the CPU is spiking alot and before i throw out this CS appliance and put this on a windows server can someone please advise what steps i can take to try and resolve this?

 

it is running latest version of pbx 3.4.

 

Because it is a embedded CPU, the CPU load is much "higher" as on a GHz CPU. So the spinking should be no worries unless you really hit the 75 % blue line.

 

You can find out if you have a CPU spike problem if the call quality on internal calls (LAN to LAN) are also not okay.

Link to comment
Share on other sites

Because it is a embedded CPU, the CPU load is much "higher" as on a GHz CPU. So the spinking should be no worries unless you really hit the 75 % blue line.

 

You can find out if you have a CPU spike problem if the call quality on internal calls (LAN to LAN) are also not okay.

 

that's exactly what is happening!

 

and he does not have more call volume then in the past few weeks but past week has been unbearable....

Link to comment
Share on other sites

that's exactly what is happening!

 

and he does not have more call volume then in the past few weeks but past week has been unbearable....

 

So internal calls are also a problem? If you need more CPU "juice" maybe you have to transfer the domain to a different host. For example, check out SheevaPlug.

 

The reason could be that the codec has changed? I guess the file system still has enough space?

Link to comment
Share on other sites

So internal calls are also a problem? If you need more CPU "juice" maybe you have to transfer the domain to a different host. For example, check out SheevaPlug.

 

The reason could be that the codec has changed? I guess the file system still has enough space?

 

i am plannin gon moving this to a windows server anyway but this cannot be the problme as they have had the same number of users for the past two to three months with no issues...why now?

codec has not been changed and as far as i know file system is fine...how do i check?

Link to comment
Share on other sites

i am plannin gon moving this to a windows server anyway but this cannot be the problme as they have had the same number of users for the past two to three months with no issues...why now?

codec has not been changed and as far as i know file system is fine...how do i check?

 

It could be that the file system gets jammed, and the OS has to use the CPU to clean up sectors. It might take a long time to find out what exactly caused the problems; IMHO it is easier to just try another hardware platform.

Link to comment
Share on other sites

  • 2 weeks later...
It could be that the file system gets jammed, and the OS has to use the CPU to clean up sectors. It might take a long time to find out what exactly caused the problems; IMHO it is easier to just try another hardware platform.

 

ok so i moved this on to a windows sevrer box and now quality seems to be better the only problem is that i am watching the process in the task manager and it may be leasking memory because right now it is at 485,236K!!!!!!

 

please advise possible causes asap.

Link to comment
Share on other sites

ok so i moved this on to a windows sevrer box and now quality seems to be better the only problem is that i am watching the process in the task manager and it may be leasking memory because right now it is at 485,236K!!!!!!

 

There must be something that stresses the system badly. Did you check if there is a lot of HTTP traffic? How many threads and Handles does the process have? Maybe you can send us a PM with RemoteDesktop login so that we can take a look around what could be the problem.

Link to comment
Share on other sites

There must be something that stresses the system badly. Did you check if there is a lot of HTTP traffic? How many threads and Handles does the process have? Maybe you can send us a PM with RemoteDesktop login so that we can take a look around what could be the problem.

 

Also, check any instances of PAC running against this PBX (it generates HTTP traffic towards the PBX).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...