Jump to content

pbxnsip and ocs r2 on a 2008 server


Recommended Posts

Just curious, does anyone have pbxnsip 4.x running on 2008 without issue? I've run into another issue and I'm starting to wonder if it's just not possible to get this config running. Is anyone running ocs r2 with pbxnsip 4.x on 2003 ok? should i just downgrade 3.x?


This time round when I call an external #, if the external user answers the calls after 5 or so seconds, the ocs client doesnt acknowledge the answer and keeps saying 'calling' however the external caller hears silence. If the remote party answers the call within about 5 seconds, everything is ok. inbound calls do not experience this problem.



[9] 2010/04/14 18:23:33: Message repetition, packet dropped

[7] 2010/04/14 18:23:33: SIP Rx tcp:

PRACK sip:+9053614585@;transport=tcp SIP/2.0

FROM: <sip:+internal#;user=phone>;epid=0C4547F37F;tag=f3f0467ad7

TO: <sip:+external#@;user=phone>;tag=5b7337002b


CALL-ID: 8956ea68-416d-47de-a96a-5173591cd18b


VIA: SIP/2.0/TCP;branch=z9hG4bK4741eef2


USER-AGENT: RTCC/ MediationServer

RAck: 1 44 INVITE



[7] 2010/04/14 18:23:33: SIP Tx tcp:

SIP/2.0 200 Ok

Via: SIP/2.0/TCP;branch=z9hG4bK4741eef2

From: <sip:+internal#@dc1-mediation;user=phone>;tag=f3f0467ad7;epid=0C4547F37F

To: <sip:+external@;user=phone>;tag=5b7337002b

Call-ID: 8956ea68-416d-47de-a96a-5173591cd18b

CSeq: 45 PRACK

Contact: <sip:+internal#@;transport=tcp>

User-Agent: pbxnsip-PBX/

Content-Length: 0


so this happens :



[6] 2010/04/14 18:23:36: SIP TCP/TLS timeout on, closing connection


which then causes this error :


[6] 2010/04/14 18:23:49: Response to must be sent over existing connection ( ; being mediation server.


and the call is gone.

Link to comment
Share on other sites

ok, I've tried the following. tried using the 2007 ocs mediation server. same problem. tried the mediation server on 2003. same problem. tried pbxnsip on 2003. same problem. All signs are pointing to a problem with pbxnsip ... :)


same error in all configs :


[6] 2010/04/15 10:44:32: SIP TCP/TLS timeout on, closing connection


update : just tested with 3.4 & the problem is gone, so as I suspected it is a problem in ver 4 ... however I can't use 3.4 because of the 30 second silence issue with ocs ...


happy to test/troubleshoot with anyone to resolve this issue!

Link to comment
Share on other sites



I had the same problem i got it working by changing the trunk setup



set Request Timeout: to 10 and it should work fine(i think the sec to the old ver 3. wasn't working 100% and now they fixed it so you need to change the settings )


let me know if it worked for you


thank you for replying.


I know it's right in front of me, but I can't find the setting :) can you (or anyone) tell me where to find this setting?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...