Jump to content

Email Problems


catprotec
 Share

Recommended Posts

Hi @all,

 

maybe someone cann help me - i'm trying to get the SMTP-Mail to work but :( :

 

PBX hast the IP 192.168.10.60

 

Exchange has the IP 192.168.10.12

 

SMTP-Setup as follows:

 

"Von" Addresse (z.B. "PBX" <pbx@domain.com>): admin@domain.com

Konto (z.B. pbx): admin@domain.com

Passwort (z.B. geheim): xxxxx

Passwort (Wiederholung): xxxxx

SMTP Server (z.B. smtp.domain.com): 192.168.10.12

Verschlüsselung: Immer TLS verwenden

 

i've also tried No TLS - same problem

 

LOG-View:

 

[8] 2010/05/21 13:04:53: SMTP: Connect to 192.168.10.12:465

[3] 2010/05/21 13:04:53: Could not connect to 192.168.10.12:465

[9] 2010/05/21 13:04:53: SMTP 192.168.10.12: send_client_hello(03014bf668d5b49af8948167052caef61853727576429393b530941d080fcb

655f87000004000400050100)

[1] 2010/05/21 13:04:53: Could not send via TCP: 52 bytes

[5] 2010/05/21 13:04:53: SMTP: Socket error

 

if using a telnet session it is possible to send Mails trough the Exchange - so relaying is allowed for IP 192.168.10.60

 

 

Any ideas ?

Link to comment
Share on other sites

Hi @all,

 

maybe someone cann help me - i'm trying to get the SMTP-Mail to work but :( :

 

PBX hast the IP 192.168.10.60

 

Exchange has the IP 192.168.10.12

 

SMTP-Setup as follows:

 

"Von" Addresse (z.B. "PBX" <pbx@domain.com>): admin@domain.com

Konto (z.B. pbx): admin@domain.com

Passwort (z.B. geheim): xxxxx

Passwort (Wiederholung): xxxxx

SMTP Server (z.B. smtp.domain.com): 192.168.10.12

Verschlüsselung: Immer TLS verwenden

 

i've also tried No TLS - same problem

 

LOG-View:

 

[8] 2010/05/21 13:04:53: SMTP: Connect to 192.168.10.12:465

[3] 2010/05/21 13:04:53: Could not connect to 192.168.10.12:465

[9] 2010/05/21 13:04:53: SMTP 192.168.10.12: send_client_hello(03014bf668d5b49af8948167052caef61853727576429393b530941d080fcb

655f87000004000400050100)

[1] 2010/05/21 13:04:53: Could not send via TCP: 52 bytes

[5] 2010/05/21 13:04:53: SMTP: Socket error

 

if using a telnet session it is possible to send Mails trough the Exchange - so relaying is allowed for IP 192.168.10.60

 

 

Any ideas ?

 

I see the following -

[3] 2010/05/21 13:04:53: Could not connect to 192.168.10.12:465

 

Is 465 the port where the email server is running?

Link to comment
Share on other sites

I see the following -

[3] 2010/05/21 13:04:53: Could not connect to 192.168.10.12:465

 

Is 465 the port where the email server is running?

 

 

if "use TLS always" is flagged then the pbx tries to connect to :465

 

if "use TLS never" is flagged then it tries :25 which also doesn't work

Link to comment
Share on other sites

  • 2 weeks later...

ok i captured the interface while pbx is trying to connect to smtp-server

 

very strange thing - wireshark doesn't see any packet for the exchange-server ip-address

 

i'm a bit confused about that - ok - i tried a web.de - email-account - same problems

 

"could not connect to ..."

 

if i use an outlook client with the same credentials it works

Link to comment
Share on other sites

Email troubleshoot with Exchange:

 

-can another windows client send email using same credentials?

-if so--turn up pbxnsip logging to 9, turn "log mail events" loggin on and send an email by going to an extension | email | click on "Click here to send the welcome email again."

 

The logging is very detailed and will tell you exactly what didn't work. I just used it.

 

for exchange 2010 we have encryption=automatic in pbxnsip email setup.

 

matt

Link to comment
Share on other sites

Also check the settings for the Windows firewall. Maybe it is allowed to accept connections, but not allowed to connect to the outside world. Also, sometimes the virus scanner puts itself into the loop and fishes out the email traffic. Try to disable the scanner for a minute and see if that does any change.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...