Jump to content

No audio /ring back on external phones


Steve B
 Share

Recommended Posts

I have been using the newest version of snomeONE on centOS and for some reason when I take one of the phones (in this case a grandstream GXP2000) to my home office and try to connect to the PBX, it will connect but when I call, no ringback tone or audio when the call connects. I did have audio about three days ago before my IP got banned for to many failed registrations. I have allowed my IP so I would assume that would not be a problem. Xlite will not work either. I thought it may be the router but I have tried 3 different routers with no resolution.

 

The GXP2000 does connect at the office which is on the same subnet as the pbx. If this helps, the GXP2000 at the office always disconnects when transferring a call to another phone (snom320).

 

Any Ideas?

Link to comment
Share on other sites

Hello,

 

How many phones do you have connected?

 

Bear in mind that snom ONE free will allow only 2 non snom phones. Any chance there are more than this trying to register to snom oNE? Non snom softphones count towards the 2.

 

Matt

 

two snom (office) 1 grandstream and 1 xlite

Link to comment
Share on other sites

I have been using the newest version of snomeONE on centOS and for some reason when I take one of the phones (in this case a grandstream GXP2000) to my home office and try to connect to the PBX, it will connect but when I call, no ringback tone or audio when the call connects. I did have audio about three days ago before my IP got banned for to many failed registrations. I have allowed my IP so I would assume that would not be a problem. Xlite will not work either. I thought it may be the router but I have tried 3 different routers with no resolution.

 

The GXP2000 does connect at the office which is on the same subnet as the pbx. If this helps, the GXP2000 at the office always disconnects when transferring a call to another phone (snom320).

 

Any Ideas?

 

There can be many reasons according to your description... If you get the phone registered the blacklisting will not be the problem. I would focus on something basic like calling the mailbox to see if the audio path could be established. I guess you have the audio_en (or whatever language you installed) and the audio_moh files installed, otherwise you would experience the "digital silence" experience (the Linux installation process requires this manual installation step). Also you could try to call the mailbox not from behind a router, maybe you have the chance to call on the local link and see if that works.

Link to comment
Share on other sites

There can be many reasons according to your description... If you get the phone registered the blacklisting will not be the problem. I would focus on something basic like calling the mailbox to see if the audio path could be established. I guess you have the audio_en (or whatever language you installed) and the audio_moh files installed, otherwise you would experience the "digital silence" experience (the Linux installation process requires this manual installation step). Also you could try to call the mailbox not from behind a router, maybe you have the chance to call on the local link and see if that works.

To make sure it wasn't a phone compatibility issue, I brought a Snom 320 (That works at the office on the same subnet and uses the same gateway) to my home office and I can dial number just fine, just no audio what so ever, either way.

 

I attached a log file of trying to dial *97 from the phone.

 

If it helps, the other problem we are having is that call parking does not work. I put a call on hold and dial *85"send" and it says call parking has failed.

 

Thank you,

Link to comment
Share on other sites

To make sure it wasn't a phone compatibility issue, I brought a Snom 320 (That works at the office on the same subnet and uses the same gateway) to my home office and I can dial number just fine, just no audio what so ever, either way.

 

I attached a log file of trying to dial *97 from the phone.

 

If it helps, the other problem we are having is that call parking does not work. I put a call on hold and dial *85"send" and it says call parking has failed.

 

Thank you,

 

First did you attach the file?

Second, did you try "*85+Park orbit account+send"? There is some change in the PO on the latest versions.

Link to comment
Share on other sites

Ok, once I made an orbit account, call parking works fine. But still have outside network audio does not work.

 

So I tried the Snom320 from above at a customers site to see if it would sync up and it banned the IP for 3 unsuccessful SIP login attempts. I have allowed my home office IP because it banned it earlier so I wonder why it is banning the phone when it is outside the network. I tried capturing a log but the log was already full and deleted the log entries.

Link to comment
Share on other sites

So I tried the Snom320 from above at a customers site to see if it would sync up and it banned the IP for 3 unsuccessful SIP login attempts. I have allowed my home office IP because it banned it earlier so I wonder why it is banning the phone when it is outside the network. I tried capturing a log but the log was already full and deleted the log entries.

 

Maybe the blacklisting is too agressive in your setup. Increase the number of attempts and/or whitelist the IP address. Then it should not be the problem any more...

Link to comment
Share on other sites

Maybe the blacklisting is too agressive in your setup. Increase the number of attempts and/or whitelist the IP address. Then it should not be the problem any more...

 

-SOLVED-

 

OK I figured it out, for some reason when I "saved" the firewall settings on CentOS5 it didn't actually save the settings, it went back to default.

 

I have attached a quick how to I made for setting up the firewall in centOS5, is that ok?

Configuring CentOS5 firewall for snomONE.pdf

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...