Jump to content

Mailbox option - Email - delete message BUG


voipguy
 Share

Recommended Posts

Just found this bug today which I hope will be fixed soon.

 

PBXNSIP 4.2.0.3981 Linux 32 bit running on centos 5 64bit

 

We have an after hours mailbox 250 that is setup to email the voice message to 2 email addressess...1 goes to my Outlook email box and the other goes to my gmail email account which is setup on my iPhone. On my iPhone I use the built in email client to retrieve my gmail email/voice messages and I click on the attachment to listen to the wave file in my iphone and it plays the voicemail message over the iphone speaker.

 

The above setup has worked for the past 2 years until today when I set the option under Accounts then under the Email tab you will see the option "After sending a message" it was set to "keep message as new message" but today I changed it to "delete the message". I still get the voicemail message sent to both email addresses and when I listen to the message on my Outlook desktop email 1 account it plays fine but on my iphone when you click on the wave file it opens and states "This movie format is not supported." so now it can't play the attached wave files....I then put the option "After sending a message" back to what it was "keep message as new message" and left a test message and now on my iPhone when I click on the attached wave file it plays no problem. You can duplicate this bug everytime you toggle that option/setting.

 

It's not the iPhone, it's not gmail....it's when I set the "After sending a message" to "delete the message" then all messages sent to my iPhone can't play the wave file. All the messages sent to my Outlook desktop email 1 account play fine.

 

I also have other mailboxes set to send messages to my iphone and I can play those wave files because I have the "After sending a message" it set to "keep message as new message". We want our after hours mailbox 250 to delete the message after it emails it but because of this bug we can't.

 

It looks like when the setting "After sending a message" is set to "delete the message" it is not formatting the wave file properly and that's why the iphone can't play it?? soon as you turn it back to "keep message as new message" the iphone can then play the new messages/wave files that come in.

 

Anyone that wants to test this of course would have to have an iPhone and an email account setup on your iPhone and have your voicemail messages sent there....doesn't matter if it's a gmail email account.

 

Please confirm this is a bug.

 

Thanks

Link to comment
Share on other sites

The whole topic of sending out multiple messages is messy. We'll clean it up in the next major release. Right now you have to live with the limitation that if you want to delete the message after sending it out, you can have only on email recipient. If you want to have more than one, you'll have to use the workaround with an email list, where the server takes care about sending it to more than one recipient.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...