Jump to content

CDR & Voicemail Emails just stopped...


jesse
 Share

Recommended Posts

Out of the blue on Friday afternoon our servers emails just stopped. Based on the log file it's still trying to send them, but has been unsuccessful:

 

Emails: Successful sent: 0 Unsuccessful attempts: 4313 (Warning: Last email could not be sent!)

 

We contacted our email provider to make sure they weren't blocking our server and they confirmed they are not. We then tried using random email accounts, including gmail, as the sending email account and we continue to get the same errors. Here's an example from the log file. I replaced actual IP addresses and domain names with X's for security purposes. Anyone have any reccomendations?

 

[8] 2011/02/20 14:30:47: SMTP: Connect to xxx.xxx.xxx.xxx:25

[8] 2011/02/20 14:30:48: SMTP: Received 220 mail.xxxxxxxxxxxxx.com ESMTP Postfix (Ubuntu)

 

[8] 2011/02/20 14:30:48: SMTP: Send EHLO localhost

 

[8] 2011/02/20 14:30:48: SMTP: Received 250-mail.xxxxxxxxxxxxx.com

250-PIPELINING

250-SIZE 30960000

250-VRFY

250-ETRN

250-STARTTLS

250-AUTH CRAM-MD5 PLAIN LOGIN

250-AUTH=CRAM-MD5 PLAIN LOGIN

250-ENHANCEDSTATUSCODES

250-8BITMIME

250 DSN

 

[8] 2011/02/20 14:30:48: SMTP: Send STARTTLS

 

[8] 2011/02/20 14:30:48: SMTP: Received 220 2.0.0 Ready to start TLS

 

[8] 2011/02/20 14:30:48: SMTP: Send EHLO localhost

 

[5] 2011/02/20 14:30:48: SMTP: Connection refused on xxx.xxx.xxx.xxx:25

Link to comment
Share on other sites

  • 3 weeks later...

You probably see the following in the log: "[4] 2011/03/10 15:49:45: Certificate for Equifax Secure Certificate Authority not available" (TLS).

 

You need to import the following certificate to make gmail happen (see http://www.geotrust.com/resources/root-certificates/):

 

-----BEGIN CERTIFICATE-----
MIIDIDCCAomgAwIBAgIENd70zzANBgkqhkiG9w0BAQUFADBOMQswCQYDVQQGEwJV
UzEQMA4GA1UEChMHRXF1aWZheDEtMCsGA1UECxMkRXF1aWZheCBTZWN1cmUgQ2Vy
dGlmaWNhdGUgQXV0aG9yaXR5MB4XDTk4MDgyMjE2NDE1MVoXDTE4MDgyMjE2NDE1
MVowTjELMAkGA1UEBhMCVVMxEDAOBgNVBAoTB0VxdWlmYXgxLTArBgNVBAsTJEVx
dWlmYXggU2VjdXJlIENlcnRpZmljYXRlIEF1dGhvcml0eTCBnzANBgkqhkiG9w0B
AQEFAAOBjQAwgYkCgYEAwV2xWGcIYu6gmi0fCG2RFGiYCh7+2gRvE4RiIcPRfM6f
BeC4AfBONOziipUEZKzxa1NfBbPLZ4C/QgKO/t0BCezhABRP/PvwDN1Dulsr4R+A
cJkVV5MW8Q+XarfCaCMczE1ZMKxRHjuvK9buY0V7xdlfUNLjUA86iOe/FP3gx7kC
AwEAAaOCAQkwggEFMHAGA1UdHwRpMGcwZaBjoGGkXzBdMQswCQYDVQQGEwJVUzEQ
MA4GA1UEChMHRXF1aWZheDEtMCsGA1UECxMkRXF1aWZheCBTZWN1cmUgQ2VydGlm
aWNhdGUgQXV0aG9yaXR5MQ0wCwYDVQQDEwRDUkwxMBoGA1UdEAQTMBGBDzIwMTgw
ODIyMTY0MTUxWjALBgNVHQ8EBAMCAQYwHwYDVR0jBBgwFoAUSOZo+SvSspXXR9gj
IBBPM5iQn9QwHQYDVR0OBBYEFEjmaPkr0rKV10fYIyAQTzOYkJ/UMAwGA1UdEwQF
MAMBAf8wGgYJKoZIhvZ9B0EABA0wCxsFVjMuMGMDAgbAMA0GCSqGSIb3DQEBBQUA
A4GBAFjOKer89961zgK5F7WF0bnj4JXMJTENAKaSbn+2kmOeUJXRmm/kEd5jhW6Y
7qj/WsjTVbJmcVfewCHrPSqnI0kBBIZCe/zuf6IWUrVnZ9NA2zsmWLIodz2uFHdh
1voqZiegDfqnc1zqcPGUIWVEX/r87yloqaKHee9570+sB3c4
-----END CERTIFICATE-----

 

Go to admin/settings/certificates and import it as "Trusted Root CA for server authentication". Then it should work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...