Jump to content
Vodia PBX forum
Ryan

MOH RTP Input

Recommended Posts

When selecting a new Music On Hold source, there is an option for "RTP Stream". It asks for a port number; does the PBX actually listen on this port? I have tried entering an unused port here, and restarting the server, and it does not listen on that port. Am I doing something wrong?

Share this post


Link to post
Share on other sites

Yes, the pbx actually listen to RTP ports, how are you streaming the media?

 

 

 

 

 

http://wiki.snomone.com/index.php?title=Music_on_Hold_Sources

 

 

"Important: Be sure to specify the port on which the system should listen for RTP input (e.g., 42000). This port must be available on the system. If you change the setting, you might need to restart the system service so that the change takes effect"

Share this post


Link to post
Share on other sites

Yes, the pbx actually listen to RTP ports, how are you streaming the media?

 

 

 

 

 

http://wiki.snomone.com/index.php?title=Music_on_Hold_Sources

 

 

"Important: Be sure to specify the port on which the system should listen for RTP input (e.g., 42000). This port must be available on the system. If you change the setting, you might need to restart the system service so that the change takes effect"

 

As stated, when I saved that music on hold item, and restart the PBX service, and run `netstat`, it is NOT listening on the port I specified.

 

I am going to be using VLC to stream data to the specified port. But I cannot stream to that port until the PBX is listening on the port.

Share this post


Link to post
Share on other sites

This is kind of urgent and a customer needs a reply soon; is this a bug in the system since it's not listening on the port I specified? Or do I have to do something else after adding that MOH?

Share this post


Link to post
Share on other sites

It starts listening on the port only when a call is placed on hold? It's not always listening? That is odd....How can I have a client connect and stream to a nonexistent port? I need to set something up and have it streaming to that port.

Share this post


Link to post
Share on other sites

Ah, I got it working. I streamed via VLC using:

 

cvlc http://[shoutcastip]:[shoutcastport] --loop --norm-max-level=5 --sout='#transcode{acodec=ulaw,samplerate=8000,channels=1,ab=16}:rtp{dst=[PBXNSIP IP],port-audio=[PBXNSIP MOH PORT]]'

 

This is streaming an MP3 shoutcast radio stream to the RTP on Pbxnsip.

 

It seems to be streaming when I put myself on hold. It is however very choppy, chopping about every second or 2. I will try and run VLC on the same box and see if that improves the choppiness.

 

Any suggestions for streaming RTP with less choppiness are welcome.

Share this post


Link to post
Share on other sites

When I attempted to set this up using a similar playback method (vlc transcoding into ulaw and streaming to the entered port) I ran into a major issue.

 

The issue is that every second phone call placed on hold plays a single audio packet over and over. Taking the call off hold and placing it back on hold results in a smooth stream where each audio packet is played in the correct order. (let's call it "first and second slot" on hold - the first slot works, the second just loops the last packet over and over)

 

However, cycling hold again will repeat the last audio packet over and over and over. Cycling again results in a smooth stream.

 

Stopping the player results in all on-hold activities looping the last packet. Placing a call on hold in 'First Slot' while the player is stopped, then starting the player, will restore the audio stream when the player is rebooted.

 

Placing a call on hold in the 'Second Slot' while the player is stopped, then starting the player, continues to loop the last audio packet over and over.

 

I read that the RTP stream used to be an internal thing in the CS410 where a player streamed to an RTP port on it's local interface. Perhaps the PBX is still looking for this source on every second try?

Share this post


Link to post
Share on other sites

cvlc http://[shoutcastip]:[shoutcastport] --loop --norm-max-level=5 --sout='#transcode{acodec=ulaw,samplerate=8000,channels=1,ab=16}:rtp{dst=[PBXNSIP IP],port-audio=[PBXNSIP MOH PORT]]'

 

Is there a option to tell the cvlc what the packet size for RTP should be? Try to set it to 10 ms or 20 ms. That might help solving the problem.

Share this post


Link to post
Share on other sites

--rtp-caching=<integer [0 .. 65535]> RTP de-jitter buffer length (msec)

 

That's all I found in the docs. Googling shows no options for RTP Packet size.

 

Any other ideas?

Share this post


Link to post
Share on other sites

Can I ask how YOU, Pbxnsip tested the RTP? Because no matter what I try, ffmpeg or vlc, I get a clicking sound in the background and it just sounds terrible.

Share this post


Link to post
Share on other sites

Check your inbox.

Any information I should know? I've the same problem with PBXnSIP. Regardless which Streaming Software I use (I've followed all the steps of your instructions exactly) I always get terrible noise when selecting the RTP Source an listen to the MOH. Music Streaming itself should be no problem as I'm able to receive Audio with VLC at the Machine where the PBX is installed. I wonder, why I also get this noise even in case the streaming source is stopped, regardless of the Port specified in the pbx (yes, I restarted service upon changing the port).

 

Best regards,

 

Lucas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...