Jump to content

Login auf Endgeraete funktioniert nicht


TPaulat
 Share

Recommended Posts

Ich habe schon seit ewiger Zeit folgendes Problem:

 

Ich kann mich auf den verwendeten Endgeraeten (snom 320 und 870) nur per admin/0000 anmelden. Ein direkter Userlogin (z.B. 11/1234 fuer Nst. 11) ist nicht moeglich.

 

Mittlerweile habe ich alles durch und finde die Loesung nicht. In einem separaten, anderen System funktioniert es, ich weis allerdings nicht mehr wie ich es dort konfiguriert habe...

 

Da frueher ein Login nicht notwednig war, jedoch mittlerweile ein Modul fuer das CRM gekauft wurde und wir dafuer die TAPI Anbindung benoetigen braeuchte ich dringend Hilfe wie das Problem zu loesen ist...

Link to comment
Share on other sites

Sind die Geräte mit Plug and Play configuriert? Dann werden standardmäßig die Angaben die in der Domäne im Bereich PnP angegeben sind (username, password, PIN) provisioniert und alle Telefone haben die gleichen Login-Daten. Bei Telefonen die auch mit zwei Logins klar kommen (snom m9) kann man sich darüberhinaus auch mit dem Benutzernamen und dem Benutzer-Passwort anmelden.

Link to comment
Share on other sites

Hallo !

 

bei uns werden die endgeräte auch über Pnp bespielt. Funktioniert alles wunderbar, nur nach dem überspielen er neuen daten funktioniert der administratorlogin nicht mehr.

 

Sprich:

ich melde mich auf der Weboberfläche an. (Logindaten funktionieren wie gewünscht)

nun gehe ich auf "Erweitert" und hier soll ich den administratorlogin eingeben.

Dieser wird aber nicht angenommen.

 

Wo genau in der SnomOne wird dieser Login festgelegt ?

 

 

Vielen dank !

 

Gruß

Patrick

Link to comment
Share on other sites

Das kann man sehen und auch ändern in WebPage Control, dann PnP auswählen, snom_3xx_phone.xml:

 

<http_user perm="RW">{admin-user}</http_user>
<http_pass perm="RW">{admin-pass}</http_pass>
<admin_mode_password>{admin-pin}</admin_mode_password>
<admin_mode_password_confirm>{admin-pin}</admin_mode_password_confirm>
<admin_mode perm="">off</admin_mode>

Link to comment
Share on other sites

Ich würde einfach das Template ändern, dort kann man leicht einstellen ob das Telefon nun im Admin-Mode sein soll oder nicht und welche PIN verwendet werden soll.

 

An welcher Stelle (Software Version der snomONE v2011-4.5.0.1050 Coma Berenicids (CentOS32) muss ich denn das Template aendern? Wie gesagt, mein Problem ist das ich mich nicht per Nebenstelle auf der Telefon GUI anmelden kann (obwohl das Telefon per Nebenstelle (Nst. Nr. xx + PIN) eingerichtet wurde. Fuer den Webservice Zugriff funktioniert jedoch nur der admin + 1234

 

Das schliesst damit natuerlich aus das TAPI Software zur Kommunkation mit der CRM Software benutzt werden kann...

 

Entweder bin ich wirklich zu dumm es zu loesen oder ich finde es einfach nicht mehr :(

 

Das gleiche Problem tritt uebrigens auch bei den snom 870 auf!

Link to comment
Share on other sites

Das Ganze geht vom Webinterface aus. Dort kann man sowoh lim Admin, auch im Domain oder sogar auf Extension-Ebene die Templates änder (Web Page Control). Ein guter Anhaltspunkt sind die Dateien, die im Directory "generated" abgelegt werden, dort kann man sehen welche Files die PBX generiert hat und auch was drin steht. Dann braucht man nicht alle Files zu durchwühlen.

Settings für die Telefone gibt es tonnenweise. Die sind unter wiki.snom.com dokumentiert.

Link to comment
Share on other sites

Die PIN steht generell auf 1234 (einfacher geht wirklich nicht...) aber bekomme den Login trotzdem irgendwie nicht hin :-( Zweifel langsam an mir. Wie kann ich denn nachtraeglich die Telefone "nicht PnP" anmelden?

 

Wir brauchen leider den direkten Login per User auf dem Telefon :-(

Link to comment
Share on other sites

Habe mittlerweile folgende Sache gefunden:

 

<dst perm="RW">3600 3.5.7 2:0:0 10.5.7 2:0:0</dst>

<http_user perm="RW">admin</http_user>

<http_pass perm="RW">+#Zftk#57qS!r§Mg</http_pass>

<http_client_user perm="RW">47;domain=pbx.core.local</http_client_user>

<http_client_pass perm="RW">r2Gp3oK4/P76RfIl</http_client_pass>

<with_flash perm="RW">off</with_flash>

<language perm="RW">Deutsch</language>

 

Dies ist aus /usr/local/snomONE/generated/pbx.core.local/47/snom_3xx_phone.xml entnommen.

Soweit so gut. Bedeutet, das fuer den User gesetzte Passwort ist

 

<http_pass perm="RW">+#Zftk#57qS!r§Mg</http_pass>

 

Der Benutzer ist auf

 

<http_client_user perm="RW">47;domain=pbx.core.local</http_client_user>

 

 

gesetzt wobei ich leider nicht verstehe (denke langsam wirklich ich bin zu dumm...) WIE ich das ganze auf die Individuelle Nebenstelle (bedeutet statt admin eine Variable) setzen kann und wo das Passwort zu aendern ist...

Link to comment
Share on other sites

<http_user perm="RW">admin</http_user>

<http_pass perm="RW">+#Zftk#57qS!r§Mg</http_pass>

 

Damit sollte das Login auf das Telefon möglich sein. Die "47;domain=pbx.core.local" sind deswegen so komisch weil eine alte Firmware-Version kein @ zugelassen hat, und das wird auch nur verwendet wenn das Telefon etwas von der PBX will.

 

Vielleicht gibt es schlichtweg ein Encoding Problem beim Copy & Paste. Das Passwort ist zwar ziemlich kryptisch (was gut ist), sollte aber nur reine ASCII-Zeichen enthalten. Ich sehe da allerdings ein A mit einem Dach drüber, das riecht nach einem Problem.

Link to comment
Share on other sites

Habe gestern Abend nach viel probieren und testen den PIN aendern koennen (direkt ueber die GUI des IP Phones QoS/Security HTTP Access) und auch von Admin auf den jeweiligen User umgeschaltet. Login geht somit jedoch wird durch das Provisioning nach einem Neustart der User wieder auf admin gestellt. Wie kann man dies auf Dauer verhindern?

 

Ich benoetige den admin account nicht sondern wirklich named user accounts auf den IP Phones.

 

Vielen Dank im Allgemeinen fuer die Unterstuetzung!

Link to comment
Share on other sites

Ansonsten ist es ja auch möglich, die Konfiguration auch auf Nebenstellen-Ebene zu steuern. Mit anderen Worten, man kann für jedes Telefon das Template so anpassen, dass dort z.B. die CRM-Einbinding gleich mit provisioniert werden kann, ohne dass man sich mit dem HTTP-Login auf dem Telefon rumärgern muss.

Link to comment
Share on other sites

So, habe das Problem endgueltig geloest.

 

Ich bin dabei folgendermassen vorgegangen:

 

unter http://pbx.domain.local/dom_texts.htm das Sheet snom_3xx_phone.xml editiert und in den Zeilen welche zu editieren sein sollten das "RW" durch ein "!" ersetzt.

 

Original: <http_user perm="RW"></http_user>

Geandert: <http_user perm="!"></http_user>

 

siehe dazu: Features/Mass Deployment/Setting Files/XML/Flags (http://wiki.snom.com/PERMISSIONFLAG)

 

Flags are defined as "permission flags" in the string "perm" within XML tags. Valid values are:

• perm="!": The configuration parameter can be changed by the user. However the parameter value will only be stored if that parameter has not been changed yet by the user. Only parameter definitions using perm="$" are overwriting previous user changes.

• perm="&" or perm="R" or perm=" ": The configuration parameter becomes write-protected (read only)

• perm="$" or perm="RW" The configuration parameter can be changed but will be overwritten on reboot.

 

 

Somit kann ich (zwar nur einzeln ueber die Phone GUI aber immerhin) pro Telefon den Login User vom Standard "admin" auf einen beliebigen Wert aendern welcher auch nach dem Reboot bestehen bleibt!

 

Das war schlicht und ergreifend alles was ich erreichen wollte :)

 

Problem geloest, ich hoffe das anderen Nutzer durch diese Antwort eventuell auch geholfen wird!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...