Jump to content

Fax Setup


Tony
 Share

Recommended Posts

I am testing the pbxnsip as a possible replacement for our old Panasonic PBX. I have managed to get everything configured and working pretty much like I want it except for fax. We have 4 analog lines with one being used for voice and fax both. I am trying to use a Grandstream GXW4104 FXO gateway for the incoming lines and a Grandstream Handytone 486 at the fax machine. I have it configured for T.38 Relay mode. I have the Handytone set to extension 100 and set for T.38 mode. When I test send a fax, the auto attendant picks up and the call will not go through. How do I configure the system to forward fax calls to extension 100 and all other calls to the auto attendant? Thanks in advance for your assistance.

Link to comment
Share on other sites

Practically all installations just assign a DID to a FAX. Then there is no need for a fax detection. But it would be interesting to see if we also get the FAX detection working in the auto attendant.

 

The PBX has a fax CNG tone detection (1100 Hz) - if the PBX detects a FAX tone, it sends the DTMF 'F' to the application. You can use this for example in the auto attendant as a direct destination. But you must perform inband detection in this case, because the FAX tone is usually not part of the RFC 2833.

Link to comment
Share on other sites

I have tried turning on the inband detection on the Admin - Settings page and using F as the user input on the Direct Destinations section to route the call to extension 100 but it isn't working. The auto attendant never gets a DTMF signal. Are there any special settings that need to be made in the gateway?

Link to comment
Share on other sites

The pbx will not route calls based on the protocol, it justs respects T38 and does with it what the SIP signaling says to ..

 

I generally keep fax lines out of my VoIP systems as a rule, I have found it's more headaches than it's worth .,.

 

 

trying to save the customer $40 a month for that line could cost you thousands in service calls when you are constantly going back for intermittent issues that are very hard to reproduce and become bothersome ,

 

 

Unfortunately the old Avayas and Panasonics were very good using TDM signaling to allow the customer use of the 4th line ,

 

 

what I do is using the Audiocodes or Patton gateways I cancel inbound routing for line 4 on the gateway (the fax line) but I allow outbound calls on it and take it out of the hunt group ,... thus it is available for outbound calls but only routes to the fax machine,

 

maybe a nice compromise ,,, as for the pbxnsip admin suggestion to use a DID, he is in Europe where ISDN is everywhere they have it good there ..:)

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 year later...
Practically all installations just assign a DID to a FAX. Then there is no need for a fax detection. But it would be interesting to see if we also get the FAX detection working in the auto attendant.

 

The PBX has a fax CNG tone detection (1100 Hz) - if the PBX detects a FAX tone, it sends the DTMF 'F' to the application. You can use this for example in the auto attendant as a direct destination. But you must perform inband detection in this case, because the FAX tone is usually not part of the RFC 2833.

How to do this? Up to now we didn't had any success receiving a fax on a Fax Machine connected to a Grandstream HandyTone-286. The Auto Attendand recognizes the Fax tone and sends the DTMF "F", but I think there is a problem switching to T.38. I'm searching for a solution one DID is routed directly to the extension (no problem) but setting "Extension is only speaking T.38" seems to be impossible. I can prefer between lots of audio codes but I'm missing the T.38 Codec in the Extension Setup (PBXnSIP). Also, I can enable T.38 Fax on the Grandstream but I cannot set, the Grandstream is ONLY speaking T.38.

 

There's a nice advice in this thread:

QUOTE(brandywinetech.com @ Jan 30 2008, 09:14 PM) <{POST_SNAPBACK}>

I have found it's more headaches than it's worth trying to save the customer $40 a month for that line could cost you thousands in service calls when you are constantly going back for intermittent issues that are very hard to reproduce and become bothersome

 

 

But that isn't easy: Unfortunately I cannot setup PSTN Lines (with seperate fax-numbers), because the fax numbers on the businesscards are DID-Numbers of the Trunk connected to the PBX.

 

Not even the following Workaround is a solution:

We've just set an external Number on the Fax Extension "when not registered". This is a PSTN Line with a Fax Machine, working well, when called directly. Obviosly the calls forwarded to this numbers are not re-routed but pushed through and parsed through the PBX so the connection is always lost after starting the fax-transmission. I can see the Fax-Sender-ID on the display of the fax machine. Then the connection is lost always. Absolutely no success.

 

Regards,

 

Lucas Hummig

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...