Jump to content
Vodia PBX forum
cwernstedt

Rewriting inbound caller IDs?

Recommended Posts

One of our SIP-trunk providers isn't particularly good about how they present the CIDs on inbound calls.

Is there a way to rewrite these according to some rules, for example replacing 001 with +1 , or adding a country code to local numbers.

Note for clarity: I'm talking about how numbers are presented in the From field in CDRs, logs, etc.
 

 

 

Share this post


Link to post
Share on other sites

Hi, 

Well, it's the inbound (not dialed) that I'm looking to change. In other words, the number that is presented on calees' phones and in logs etc.

The trunk provider presents local numbers without the correct international prefix, which makes it difficult to process these calls correctly.  
 

Share this post


Link to post
Share on other sites

Ok. Where do I configure these things in this version? Ideally I would like to prefix +423 to all numbers lacking a 00 prefix (local numbers) and replace 00 prefixes with + for international numbers.

So 2371336 would turn into +423 2371336 and 0013343456666 would turn into +1 3343456666 .

(Incoming calls only)

Share this post


Link to post
Share on other sites

I was wondering if there is a handbook somewhere on this. I was wondering why the Vodia would remove +1 from calls. I see them as being presented but in log files but in the call logs and on the phone, the number gets changed from  +15555551212 to 555-555-1212 in the logs, and 5555551212 on the phone.

The list of expressions above only directs the call, it doesnt seem to have anything to do with inbound caller id as mentioned above.

Where is the setting for caller id.

Thanks

Share this post


Link to post
Share on other sites

Inbound caller ID settings headers: https://doc.vodia.com/trunk_custom_headers (you can navigate on the left hand side to look for more settings).

And the admin level shows the +1 along with the numbers in the call logs if you want to take a look. Inside the domain, it's the default setting that reformats the number to look like 555-555-1212 by default.

Share this post


Link to post
Share on other sites

i am not clear by your response.

When i click on the link....the first thing it says is:

Trunk Custom Headers

The PBX can send just about anything in the SIP headers when making outbound calls. This is particularly useful if the trunk provider needs special parameters/values in the SIP headers.

When you say the left hand side, is this a reply for the question regarding expressions, as i am just looking for quidance. I tried to use your example above and it didnt work and the call went to voicemail.

!^([2-9]{10})$!+\1! !^([1-9]{11})$!+\1! 38

i understand that the default setting using 1 but why not +1  as that will not work.

In any event, if there is no way to actually receive calls 1+, just say so. I cannot find a way to do so using the default 1 settings.

 

thanks

Share this post


Link to post
Share on other sites

The headers are really just about outbound calls. There is no need to come up with headers on inbound calls.

Generally the idea is that telephone numbers should be converted into the internal "global" format. That means in the case of the PBX, that the numbers start with a +-symbol. There are a couple of settings for the trunk on how it expects the numbers and that usuually works well (there are a few providers that send e.g. From in international format and To in E164-format which is causing a lot of confusion).

So I would recommend to review the format of the trunk and check if the numbers are read correctly. Then there is no need to use the ERE pattern matching for inbound calls.

Share this post


Link to post
Share on other sites
On 4/24/2020 at 6:11 PM, koolandrew said:

i am not clear by your response.

Pasted the wrong URL. Anyway, should be clearer now.

Share this post


Link to post
Share on other sites

The calls are coming in as 1+. If we dont have default country set as 1, then we can receive the calls at 1+ but it causes all kinds of other issues. If we leave the 1 as default, we cannot get +1...this is why i  was asking about expressions.

Share this post


Link to post
Share on other sites

geez... i just read this again...no wonder i can get help............it is +1 the + sign..that is the big dilemma here....+1

if i write 1+ again...kick me out of the forum...lol

Share this post


Link to post
Share on other sites

Well, there is the possibility to edit a post! 1+ is very confusing indeed. Anyway there is another post about it, in a nutshell I would just look at the logs along the processing of the call and make adjustments so that the numbers make sense in each step.

Share this post


Link to post
Share on other sites

I have tried many times. I try to get help on the forum. And this the response.. how about this is how you do it.. ir forget it can't be done. Please?

Share this post


Link to post
Share on other sites

Is the field "Rewrite global numbers" being set to "Don't rewrite" not helping, inside the trunk settings?

Share this post


Link to post
Share on other sites

I am sorry but the confusion continues.

Are you referring to outbound calls, i need to ask to make sure. If so, how will this help with the dial plan when + is involved. The dial plan directs to the trunk.  These settings make no difference.

Share this post


Link to post
Share on other sites
12 minutes ago, koolandrew said:

If so, how will this help with the dial plan when + is involved.

Yes, that's what it's supposed to do. 

Again, we're talking about inbound calls here right? I wasn't referring to dial plans at all. These are just trunk setting which "should" take effect on inbound calls.

Share this post


Link to post
Share on other sites

When the country code is set back to 1, and that setting of dont rewrite on a trunk is set, the + gets removed when using "dont rewrite" or "use + symbol at the beginning". I dont think there is any way to use the 1 as country code and keep +1555555555 (for example) on inbound calls.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...