Jump to content

Group Pick up not working version 65.0.8


Recommended Posts


Since Upgrading to  65.0.8 on Centos-64 *87 pickup does not work anymore and seems to dial out via trunk? i get number not recognised from my provider. Below is the log output


Dial number *87 from user 681 and dial plan XXXXXXⓘ
[4] 14:22:43.045 Last message repeated 2 timesⓘ
[8] 14:22:43.045 Port 648: Disconnect all others except leg 1427ⓘ
[8] 14:22:43.045 Dialing star code *87ⓘ
[8] 14:22:43.045 Handle star code *87ⓘ
[8] 14:22:43.045 Code pickup *87ⓘ
[7] 14:22:43.045 Undirected call pickup from 656 673 678 651 711 651 failedⓘ
[7] 14:22:43.045 Last message repeated 2 timesⓘ
[5] 14:22:43.045 Code pickup failed *87ⓘ
[5] 14:22:43.045 Last message repeated 2 timesⓘ
[5] 14:22:43.045 *87 does not match any star codeⓘ
Link to comment
Share on other sites

There is something keeping the PBX from picking up that call. Possible reasons are permissions (is that extension allowed to pick up the call), the call is already gone (should be easy to reproduce), that extension cannot pick up calls (e.g. because it is a hotel room extension),  or one of the extensions is actually ringing, but from a group. In the latter case there is a flag that tells the PBX weather such calls should be picked up, the default is not.

If the star code is not handled, the PBX continues finding a way to terminate the call. Its debatable—probably its better to send the call to a IVR that tells the caller that the action failed. We'll address that in on of the next versions but here it is more cosmetic. 

Link to comment
Share on other sites

We just tried it on our local test system and it worked fine with the "Group Pickup" button on Snom, Yealink and Grandstream phone.

Pbx Version 65.0.8

All we did was add all the extensions that you want to monitor under "Explicitly specify pickup preference" section and add a button on the same phone, and everytime someone calls these buttons, the buttons starts to blink and can pick up then.

*87 is a lengthier way of achieving the same scenario, but that worked for us as well.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...