Jump to content

Cross domain calling


CarlH
 Share

Recommended Posts

Hi,

 

I would like some more info on this. Is it possible for you to write some type of step by step guide on how to configure cross domain calling? I have read several topics about this but haven't seen any clear information on what to do. Is it possible that you could write some kind of step by step because I don't think I'm the only one with this request.

 

Lets say we have two domains

 

domain1.net and domain2.net

 

in domain 1 we have nr 10-50

in domain 2 we have nr 10-50 as well

 

In the dial plan we currently have pattern * for the trunk.

 

Would it be possible to configure the dial plans so that you call domain2 by pressing eg #1 and then the nr eg #110 for nr 10 in domain2

 

One of the domains is localhost with domain01.net as alias name.

 

Br

Carl

Link to comment
Share on other sites

  • Replies 51
  • Created
  • Last Reply

Top Posters In This Topic

We previously used tel:alias to call numbers in other domains but since upgrading to version 3 this doesn't work anymore.

 

I read about the try loopback option as trunk but did not get it to work.

 

What i did was that I disabled loopback detection and then added "Try loopback" to the dialplan with the lowest "pref" and * as "pattern".

 

I'm guessing that's not all there is to it but since I can't find any more info about this I'm asking here

Link to comment
Share on other sites

We previously used tel:alias to call numbers in other domains but since upgrading to version 3 this doesn't work anymore.

 

I read about the try loopback option as trunk but did not get it to work.

 

What i did was that I disabled loopback detection and then added "Try loopback" to the dialplan with the lowest "pref" and * as "pattern".

 

I'm guessing that's not all there is to it but since I can't find any more info about this I'm asking here

 

You can still get the tel:alias functionality back by typing the alias number on the same field as the "Account Number(s)". This is the first filed on the account/extension page. Ex: If you want to alias 1234561234 to for extension 40, then type "40 1234561234" without quotes on the "Account Number(s)" field.

Link to comment
Share on other sites

This didn't work for me. I made two accounts 43 0842013043 on domain01 and 30 0842016130 on domain02

 

I still cant call cross domains wit the alias. Do I need to cahnge anything in dialpans or trunks?

 

I finally got it working! I used both alias on each extension and "try loopback" in the dialplan. I can now call the alias I set in other domains.

Link to comment
Share on other sites

  • 2 months later...
  • 3 months later...
I have had some success, however I am concerned that loopback detection needs to be turned off. Is there a way to keep loopback detection on to protect from external loops, however trust the dialplan?

 

No. Loopback detection does not differentiate between sources... Would it make any difference? For example, what if the PBX users really create a loop (a@domainb redirects to b@domaina and b@domaina redirects to a@domainb)?

Link to comment
Share on other sites

I am just thinking statistically it would be more common for a user to accidentally create a loop back to their own domain, and since the average user cannot get to the dialplan, we would assume someone with knowledge would be editing the dialplan. Therefore if it utilizes the Try Loopback in the dialplan it could be trusted, and if it looped internally, or through the phone company it should not be trusted. It would be neat if there was a TTL for the loopback protection. This way it could be turned on, however it would kill any loop after a preset number of hops.

Link to comment
Share on other sites

Well you guys are getting much further than I have been able to at this time.

 

Running 3.3.1.3177 (Linux), alias set on hunt group 113 in B.domain.com to 5554443333

 

Dial Plan in A.domain.com has one entry Try Loopback match * with null replacement.

 

Debug going and the log tells be the following.

 

[9] 20090706153623: Dialplan: Evaluating !^(\+?[0-9]*)@.*!sip:\1@\r;user=phone!i against 5554443333@A.domain.com

[8] 20090706153623: Dialplan TEST: 5554443333@A.domain.com not found in the local system

 

I read this and say to my self - of course 5554443333@A.domain.com is not found in the local system, because it is 5554443333@B.domain.com.

 

These types of changes is what keeps us running 3.1.0.3031 (Linux). If it's not broken, why fix it...?

 

I think it is going to be easier to figure out how to get my sofswitch vendor to change their code than to make changes on every server and domain dial plan whenever or if ever we figure out this 'new' method for inter-domain dialing.

 

Right now - leaving it setup the old way on this version the log file just states - [5] 20090706162813: Received loopback request without tag.

If I could figure out what this highly detailed debug message means - I could probably get the softswitch vendors help.

 

Any ideas on which tag this message talks about? Could if be the ftag in the Record-Route header? Does this need to have a different tag id? Or does the the tag of the from header need to change when coming back to the PBX?

 

Thoughts?

Link to comment
Share on other sites

Any progress on this topic? There are many of us who cannot get inter-domain calling to work for various reasons. There are also those of us that do not configure our servers with a single "common" trunk that all of the domains use. For instance, in our case we have multiple domains per server with each domain having it's own trunks.

 

Well you guys are getting much further than I have been able to at this time.

 

Running 3.3.1.3177 (Linux), alias set on hunt group 113 in B.domain.com to 5554443333

 

Dial Plan in A.domain.com has one entry Try Loopback match * with null replacement.

 

Debug going and the log tells be the following.

 

[9] 20090706153623: Dialplan: Evaluating !^(\+?[0-9]*)@.*!sip:\1@\r;user=phone!i against 5554443333@A.domain.com

[8] 20090706153623: Dialplan TEST: 5554443333@A.domain.com not found in the local system

 

I read this and say to my self - of course 5554443333@A.domain.com is not found in the local system, because it is 5554443333@B.domain.com.

 

These types of changes is what keeps us running 3.1.0.3031 (Linux). If it's not broken, why fix it...?

 

I think it is going to be easier to figure out how to get my sofswitch vendor to change their code than to make changes on every server and domain dial plan whenever or if ever we figure out this 'new' method for inter-domain dialing.

 

Right now - leaving it setup the old way on this version the log file just states - [5] 20090706162813: Received loopback request without tag.

If I could figure out what this highly detailed debug message means - I could probably get the softswitch vendors help.

 

Any ideas on which tag this message talks about? Could if be the ftag in the Record-Route header? Does this need to have a different tag id? Or does the the tag of the from header need to change when coming back to the PBX?

 

Thoughts?

Link to comment
Share on other sites

  • 2 weeks later...

Hi pbxnsip support,

 

Any update on this topic?

I found the same problem while testing the latest release (3.4.0.3201). Following is what I got from the log while calling trunk b on domain B from trunk a on domain A.

------------------------------------------------------------------------------------------

Received loopback request without tag

Received incoming call without trunk information and user has not been found

------------------------------------------------------------------------------------------

I can make such inter domain call on version 2.xx.xx.

 

Thanks,

 

Yimin

Link to comment
Share on other sites

Can you please take a look at the "Try Loopback" section from https://www.pbxnsipsupport.com/index.php?_m...kbarticleid=326?

 

Hi pbxnsip support,

 

Any update on this topic?

I found the same problem while testing the latest release (3.4.0.3201). Following is what I got from the log while calling trunk b on domain B from trunk a on domain A.

------------------------------------------------------------------------------------------

Received loopback request without tag

Received incoming call without trunk information and user has not been found

------------------------------------------------------------------------------------------

I can make such inter domain call on version 2.xx.xx.

 

Thanks,

 

Yimin

Link to comment
Share on other sites

Hi pbxnsip support,

 

Thank you for the update.

First of all I tried the 'loopback' method and for some reason it didn't work.

Even though the 'loopback' method works, it is still not a practical solution for us. We provide hosted PBX service and we have more than 80 domains on one server. If we use the 'loopback' method, we have to put all trunk DIDs in the dial plan of all domains. And each time when we add a new domain, we have to update the dial plan of all domains with the trunk DID of the new domain.

Currently we are using external SIP proxy server to route the call back. Each time when we add a new domain, we don't need to worry about the routing issue since the external SIP proxy server will handle that properly. This setup is working very well on the old version pbxnsip software.

 

Thanks,

 

Yimin

Link to comment
Share on other sites

Currently we are using external SIP proxy server to route the call back. Each time when we add a new domain, we don't need to worry about the routing issue since the external SIP proxy server will handle that properly. This setup is working very well on the old version pbxnsip software.

 

That is definitevely the best way to address the problem. The loopback is just a "hack" to get small systems working where the usage of a external SIP proxy is not feasable.

 

So do you have a problem with the loop detection? Does the PBX detect a loop when it should not?

Link to comment
Share on other sites

Hi pbxnsip support,

 

Then what's the solution for big systems like ours?

I am not sure if the loopback detection works.

If the loopback detection is on. Following one line is found in the logfile.

Received loopback request without tag

If the loopback detection is off. Following two lines are found in the logfile.

Received loopback request without tag

Received incoming call without trunk information and user has not been found

 

Thanks,

 

Yimin

Link to comment
Share on other sites

Then what's the solution for big systems like ours?

I am not sure if the loopback detection works.

If the loopback detection is on. Following one line is found in the logfile.

Received loopback request without tag

If the loopback detection is off. Following two lines are found in the logfile.

Received loopback request without tag

Received incoming call without trunk information and user has not been found

 

The best solution for large system is to use a SIP proxy to route the calls between the domains and the other destinations. The dial plan will then become pretty simple--just send everything to the proxy. The proxy then has to make the decision if the call should be routed to a PBX or to the PSTN gateway (whatever that is).

 

In this setup, you need to turn off loopback detection; because it is perfectly legal that one domain calls another on the same system.

Link to comment
Share on other sites

Hi pbxnsip support,

 

That's the setup we have been using since version 2 and now it stops working on almost all version 3.x release after version 3.0.1.3023.

We can see that the call is routed back to the pbxnsip server by the SIP proxy server and the pbxnsip server sends back 'Not found' to the SIP proxy server. The loopback detection is turned off.

Following are the error messages found in pbxnsip logfile.

[5] 2009/07/30 10:31:10: Received loopback request without tag

[5] 2009/07/30 10:31:10: Received incoming call without trunk information and user has not been found

 

Thank you,

 

Yimin

Link to comment
Share on other sites

[5] 2009/07/30 10:31:10: Received loopback request without tag

 

That's okay if you turn the loopback detection off. This is just a notification that there is a loopback request that needs to be processed.

 

[5] 2009/07/30 10:31:10: Received incoming call without trunk information and user has not been found

 

Do you have a trunk that has the outbound proxy set to the SIP proxy? Seems the PBX has problems identifying the source of the request. Make sure that this trunk also accepts inbound calls.

Link to comment
Share on other sites

Hi pbxnsip support,

 

That's the setup we have been using since version 2 and now it stops working on almost all version 3.x release after version 3.0.1.3023.

We can see that the call is routed back to the pbxnsip server by the SIP proxy server and the pbxnsip server sends back 'Not found' to the SIP proxy server. The loopback detection is turned off.

Following are the error messages found in pbxnsip logfile.

[5] 2009/07/30 10:31:10: Received loopback request without tag

[5] 2009/07/30 10:31:10: Received incoming call without trunk information and user has not been found

 

Thank you,

 

Yimin

 

Few steps to note here

1. Set the country code under the Domain Settings of the calling domain

2. On the calling domain, create a dial plan entry with trunk "try loopback" and pattern, for example, 7* and the replacement 7* (or whatever that matches your destination domain accounts). Just for testing purposes, make this as the highest priority entry. Later you can place it at the position.

3. Assign this dial plan (that contains the above dialplan entry) to either the calling domain or the calling extension.

4. Pick up the phone and dial the other domain's extension number.

5. call should go through.

Link to comment
Share on other sites

That's okay if you turn the loopback detection off. This is just a notification that there is a loopback request that needs to be processed.

 

 

 

Do you have a trunk that has the outbound proxy set to the SIP proxy? Seems the PBX has problems identifying the source of the request. Make sure that this trunk also accepts inbound calls.

 

I tried to set the outbound proxy to the SIP proxy and it didn't make any difference.

Link to comment
Share on other sites

Few steps to note here

1. Set the country code under the Domain Settings of the calling domain

2. On the calling domain, create a dial plan entry with trunk "try loopback" and pattern, for example, 7* and the replacement 7* (or whatever that matches your destination domain accounts). Just for testing purposes, make this as the highest priority entry. Later you can place it at the position.

3. Assign this dial plan (that contains the above dialplan entry) to either the calling domain or the calling extension.

4. Pick up the phone and dial the other domain's extension number.

5. call should go through.

Yes, the call goes through.

But what we need is a solution for multi-domain environment on one server.

For example, if we have three domains: A, B and C. Both domain A and B have extension 905. Domain C has extension 901.

How can extension 901 in domain C call extension 905 in either domain A or B without calling the trunk DID of either domain A or B first?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...