Jump to content

callback from personal virtual assistent


stoneracer
 Share

Recommended Posts

Hello,

 

maybe I'm just to stupid, but I can't find the answer on my own :-(

I've enabled the personal virtual assistant for one extension and entered the cell phone number. After calling the extension -0 from my cell phone I reached by personal virtual assistant which offers me the following two options:

 

1: make an outgoing call

2: go to the auto attended

 

Since I've disabled by mailbox this feature is not offered, but how do I enable the feature to receive a callback?

I already thought this might only be available with an active mailbox, but after I enabled the mailbox I just got 3 options:

 

1: make an ouztgoing call

2: go to mailbox

3: go to the auto attended

 

Could someone please explain how to enable the callback feature?

 

Version: pbxctrl-debian4.0-2011-4.3.0.5020

Link to comment
Share on other sites

Check the domain settings, there is a field called "Offer Camp On" which will enable a user to callback when a user is busy. Should be turned on by default.

 

Well "Offer Camp On" is enabled in my setup, I've also tried to disable this feature and after that enable it again, but the result was the same as before. Any ideas how to fix this issue?

 

btw our setup has several auto attendends, can I choose which one is called from the personal virtual assistent?

Link to comment
Share on other sites

Not sure, but the problem could be solved with the new cell phone menus on the head version. The whole assistant has gone through a major overhaul.

 

I did a test upgrade to version 4.3.0.5020 but the result stays the same :-(

Any ideas how to fix this? Are there any other config options which could influence the callback behavior?

Link to comment
Share on other sites

We tested is here again and it seems to work fine. As long as the PBX detects the incoming caller is associated cell phone number & you are calling the attendant, PBX should play all the options. Make sure that you have all the audio files in the directory.

 

These are files needed for this operation (For English),

audio_en/aa_outbound.wav audio_en/bi_press_1.wav

audio_en/aa_recv_cb.wav audio_en/bi_press_2.wav

audio_en/aa_goto_mailbox.wav audio_en/bi_press_3.wav

audio_en/aa_goto_attendant.wav audio_en/bi_press_4.wav

Link to comment
Share on other sites

  • 1 year later...

Hello,

 

maybe I'm just to stupid, but I can't find the answer on my own :-(

I've enabled the personal virtual assistant for one extension and entered the cell phone number. After calling the extension -0 from my cell phone I reached by personal virtual assistant which offers me the following two options:

 

1: make an outgoing call

2: go to the auto attended

 

Since I've disabled by mailbox this feature is not offered, but how do I enable the feature to receive a callback?

I already thought this might only be available with an active mailbox, but after I enabled the mailbox I just got 3 options:

 

1: make an ouztgoing call

2: go to mailbox

3: go to the auto attended

 

Could someone please explain how to enable the callback feature?

 

Version: pbxctrl-debian4.0-2011-4.3.0.5020

 

Hi,

 

FYI, by dint of searching and reinstall my snomONE I found why the callback function was not proposed in the Personal Virtual Assistant.

 

Indeed, for this option to be proposed in the Personal Virtual Assistant, it is essential that a "Calling Card" account is present in the system (leave the default options). If this service does not exist then it will only offer 3 choices (outbound call, mailbox, Auto Attendant).

 

More, to change the Personal Virtual Assistant language in French, you have to select language French in the "Web Language" and not the "IVR Language" (I do not know why :blink::angry: ) for the extension parameters (or domain default parameters).

 

No logic in it but hey it works!

 

Tested on version 4 and 5

 

Sorry for my english (google translate) cause i'm french :P

 

Bye

 

Rudwolf

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...