Jump to content

SIP multiple trunk fails outbound


DaveD
 Share

Recommended Posts

I've configured multiple SIP trunks:

> each trunk both inbound/outbound

> different DIDs

> different [unique] login credentials

> same carrier [Vitelity]

> same [Vitelity] domain; same proxy [outbound.vitelity.net]

 

Each trunk authenticates OK and accepts inbound traffic OK

BUT:

> if all trunks are enabled, apparently no trunk accepts

outbound calls [this is not a dialplan issue]

> if only one trunk is enabled, outbound calls are OK

 

I've used these identical trunks, configured in the identical way
on a PBX appliance box for years, and they worked outbound OK.

 

I've tried the possible solution to create separate inbound and
outbound trunks for each DID (shown elsewhere); this did not work.

 

[Note: this is not a license issue; 'HC' confirms that there is no limit
on any version for for number of SIP trunks.]

 

This is critical for use! PBX is useless if this doesn't work.

I can post logs for a specific test if you specify one. Dave

 

Link to comment
Share on other sites

This was a new installation--not an upgrade.

BUT: I recall that I had this same killer issue
when I installed earlier versions: 4 and 5.0
(on different hardware). That's why I
abandoned the product back then.

 

As I already explained in my first post, this is
a single carrier, on the same (authentication)
domain but using different accounts.

 

Again: there's not one account; if I PM you the
logon info and you logon, that will lock out the
accounts here. That's not a great idea.

 

Isn't there some log info that will tell you what's
going on? This is--generally speaking--a very
ordinary 5.1.0 installation, except perhaps that
it is on Windows SBS server 2003 (32bit), using
port 81 as access. [i can't get SSL port 444 to work.]

 

And again, you're right: I've had this exact problem
before with earlier builds. It's likely a trunk compatibility
issue, because others have reported similar problems
with Vitelity trunks. But Vitelity is a major ISP... Dave

 

PS: I find that if I disable all but two trunks, only one of
the two is active; the other responds with fast busy, as
if the trunk were out of service.

Link to comment
Share on other sites

If you are using trunks only for outbound traffic, try to set them as outbound only in the trunk setting. At least this way you can make sure that they are not messing up inbound traffic. If all trunks register (for inbound traffic) at the same time, you might just confuse the service provider with overlapping registrations.

 

Also you have to keep in mind, that in the SIP world a trunk does not mean a physical connection with a cable. At the end of the dialing process, a SIP INVITE packet leaves the PBX, no matter what trunk the PBX has selected during the routing of the call. If all trunks are configured the same way, then the packets will also look the same. If you just want to change the caller-ID that you would like to present, you can also achieve that with the ANI field in the extension which is placing the call.

 

This issue has nothing to do with Windows or license or even version 4 or version 5.

Link to comment
Share on other sites

No, these trunks are not only for outbound traffic,
as I already pointed out. I tried setting up separate
accounts for each trunk--one outbound, one inbound.

That didn't resolve this issue.

 

If I'm 'confusing' the ISP with registrations, why didn't
the Epygi appliance I used for years have the same

issue? These are the same trunks--same accounts.

I've also used other software PBX without this problem.

 

This is not an issue about CID; I never even mentioned

that. I do have questions about CID--for another thread.

 

As you say, probably not a Windows or license issue.

But I'm left with a system that doesn't work, while my old
junky appliance does (although it has other issues).

 

Isn't it likely the log files will tell you what's wrong? Dave

Link to comment
Share on other sites

This article explains how to get a simple invite from the system .

 

http://wiki.snomone.com/index.php?title=How_to_Take_SIP_log_file.

 

If you need us to further investigate, you can upgrade your support to priority by purchasing a ticket and we can log into your unit and verify what the issue might be.

 

Thanks

Link to comment
Share on other sites

Thanks for that!

 

I've sent you a PM with log and dialplan attached.

 

Note that the visual log in the domain log screen shows very strangely;

some of the text is full size, but most of the SIP details are in very small
type, and unreadable. This happens both in Chrome and Firefox.

 

If I copy and paste to Notepad [plain text], all text is full-size. (The log
file I sent is in plain text and doesn't show this issue.)

 

luck, Dave

 

PS: trunk I provided is currently set to 'ATA' type routing.

Link to comment
Share on other sites

I sent you the complete log messages, and also
the dial plan, fully annotated. As tech support
requested, I also provisioned a Vitelity DID
(SIP trunk) for your exclusive testing use.

 

You did evaluate the SIP traffic log briefly, and
said there are important aspects missing. You
said a week ago that you would do further testing.

 

This PBX is still unable to use multiple trunks;
have you made any progress? thanks, Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...