Jump to content

Vitelity Trunk config


Pablo
 Share

Recommended Posts

Just upgraded a SoHo to v5.0.8 (mini) and then wanted to create a (new) Vitelity trunk. However, in the drop-down menu within the Create service provider trunk (SIP trunks) section, Vitelity is not among the 44 providers available to select from.

Would Vodia Networks entertain a request to have Vitelity added (1) to the Create service provider trunk (SIP trunks) section and (2) to the Certified ITSPs section on the snom ONE wiki?

Link to comment
Share on other sites

Just as an FYI for anyone else that may be interested...

Per Vitelity Support:

Ensure firewall is open for the following ranges as Media and SIP signalling for these calls may originate from within the following IP ranges:

64.2.142.0/24

66.241.96.0/24

66.241.99.0/24

66.241.111.0/24

Link to comment
Share on other sites

Can you please provide the following settings of the provider, so that we can add it.

 

Outbound Proxy Address:

Domain:

 

In its support page, Vitelity provides configuration info. for Asterisk, FreePBX, X-Lite, Linksys, Switchvox, Elastix, and, finally, Generic SIP. I'm trying to extrapolate the correct trunk settings for snom ONE from the other config examples, but I'm having trouble getting inbound calls to work. In the Generic SIP example, all the info. that Vitelity provides is the following:

Authentication parameters are as follows:

 

Proxy: sip29.vitelity.net (66.241.99.28)

Outbound Proxy: outbound.vitelity.net

Under FAQs, I found:

 

What codecs does Vitelity Communications support?

 

We currently supports the following codecs: Ulaw, Alaw, GSM and G729a.

In the Switchvox config example:

DTMF should be set to RFC2833
Link to comment
Share on other sites

On snom ONE, if you provide:

 

outbound proxy address: outbound.vitelity.net

domain: sip29.vitelity.net

 

and the account and password that you may have, does it work flawlessly in both directions?

 

If not, it cannot be added yet because that much information should be enough to get it working, no fuzzy inside details.

Link to comment
Share on other sites

On snom ONE, if you provide:

 

outbound proxy address: outbound.vitelity.net

domain: sip29.vitelity.net

 

and the account and password that you may have, does it work flawlessly in both directions?

 

If not, it cannot be added yet because that much information should be enough to get it working, no fuzzy inside details.

 

Flawlessly? No. I'm able to make outbound calls just fine. But, according to Vitelity, based on their trace, snom ONE does not know what to do w/the incoming calls. Here's what they sent me:

Here is the trace show your device3 does not know what to do with the call.

Apr 16 13:21:54.308 PM 66.241.99.28 > 99.111.114.6 INVITE sip:6083716430@99.111.114.6:5060 SIP/2.0

Apr 16 13:21:54.399 PM 66.241.99.28 < 99.111.114.6 SIP/2.0 100 Trying

Apr 16 13:21:54.483 PM 66.241.99.28 < 99.111.114.6 SIP/2.0 404 Not Found

Apr 16 13:21:54.483 PM 66.241.99.28 > 99.111.114.6 ACK sip:6083716430@99.111.114.6:5060 SIP/2.0

 

Are you able to help? Please!

Link to comment
Share on other sites

You need to set something in the "send call to extension" field in the trunk or assign the DID to one of the extensions. More info on http://wiki.snomone....roper_Extension

 

 

I reviewed the instructions you suggested and I've tried these combinations (among many other!):

Scenario 1:

In the extension settings, set "Account number(s)" to: 45 608-371-6430

and in the trunk settings, set "Send call to extension" to: !([0-9]{10}$)!\1!t!45

Scenario 2:

Account number(s): 45 608-371-6430

Send call to extension: 45

Neither worked. Any thoughts?

Link to comment
Share on other sites

Looks like the PBX has problems identifying the trunk. Do you have multiple trunks to Vitelity? What does the log say when the call comes in? It should say something like "identified trunk so-and-so" . Did you specify the inbound addresses? When you set the trunk up there might be still a 1.2.3.4 as a placeholder for the real IP address where the call will come from (or just leave that empty, but not with 1.2.3.4).

Link to comment
Share on other sites

Looks like the PBX has problems identifying the trunk. Do you have multiple trunks to Vitelity? What does the log say when the call comes in? It should say something like "identified trunk so-and-so" . Did you specify the inbound addresses? When you set the trunk up there might be still a 1.2.3.4 as a placeholder for the real IP address where the call will come from (or just leave that empty, but not with 1.2.3.4).

 

I only have 1 trunk (w/Direction set to: Inbound and Outbound);

That's the annoying part: The log doesn't even mention that the PBX IDs the trunk;

Additional settings are:

Domain: sip29.vitelity.net

Proxy Address: sip:outbound.vitelity.net:5060

Explicitly list addresses for inbound traffic: I've tried alternating b/w: 64.2.142.0/24 66.241.96.0/24 66.241.99.0/24 66.241.111.0/24 and (only) sip29.vitelity.net

Link to comment
Share on other sites

Pablo can you send A PM with an account so that we can test it here, this should not be so difficult.

Also please include a screenshot of your config so we can reproduce today including the DIDs.

 

Thanks

 

Thanks for the offer, Mr. X! But, I think I've stumbled upon the solution. snom ONE piqued my curiosity last night when he asked how many trunks to Vitelity I was using; so, instead of continuing to bang my head against the (figurative) wall, I created one inbound trunk and one outbound trunk and... (drum-role, please)... voila!

Inbound trunk is using sip29.vitelity.net for the (i) Domain; (ii) Proxy Address; and (iii) Explicitly list addresses for inbound traffic; and the outbound trunk is using outbound.vitelity.net for those three settings.

Link to comment
Share on other sites

On snom ONE, if you provide:

 

outbound proxy address: outbound.vitelity.net

domain: sip29.vitelity.net

 

and the account and password that you may have, does it work flawlessly in both directions?

 

If not, it cannot be added yet because that much information should be enough to get it working, no fuzzy inside details.

 

Now that I created two trunks (see post #12, above), instead of trying to use a combined (inbound/outbound trunk), everything is working flawlessly!

Link to comment
Share on other sites

It has been added.

 

Although I don't understand yet why it didn't work with a single trunk like the others.

 

I don't know if this sheds light on your question, but here's an excerpt from my support ticket at Vitelity, when I was trying to work through this:

 

 

Hello,

 

For a stand alone device please remove the outbound proxy and leave it blank, this should correct the issue since the device won't allow 2 trunks. Our inbound servers are not load balanced for outbound calls, but when it comes to a standalone device or ATA you should be able to get away with it as long as there aren't several simultaneous outbound calls going through it.

 

Thanks,

...

Vitelity, LLC

 

 

Given that this person thought that a snom ONE IP PBX is a "stand alone device" didn't help, either! wink.gif

Link to comment
Share on other sites

  • 3 months later...

I have a Vitelity Trunk that I use successfully for inbound and outbound traffic. I set both the proxy and the domain to sip29.vitelity.net in the trunk configuration. My problem is that I actually have two separate inbound trunks form Vitelity that I want to route differently in the PBX...that is not working and I've created a separate topic for that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...