Jump to content
Vodia PBX forum
Sign in to follow this  
James Mahood

4.1.0.4013 (Linux) intercom not working

Recommended Posts

Dialing the star code and extension for intercom justs rings the extension. The extension doesn't auto answer. It acts like the auto answer bit isn't being set. We just migrated from version 3 where this feature was working. Paging has the same problem, all the extensions ring but don't answer. In addition when the caller hangs up after doing a page the extensions continue to ring.

Share this post


Link to post
Share on other sites
Dialing the star code and extension for intercom justs rings the extension. The extension doesn't auto answer. It acts like the auto answer bit isn't being set. We just migrated from version 3 where this feature was working. Paging has the same problem, all the extensions ring but don't answer. In addition when the caller hangs up after doing a page the extensions continue to ring.

 

In v4, intercom needs the permission. This can be set on the extension->permission tab.

Share this post


Link to post
Share on other sites

I have the exact same problem in v4 in windows.

 

extension 101 DOES have rights to intercom to 111. (*)

Yet 111 just rings instead. (no, there is NOT 2 extensions registered on either extension)

 

Some extension work, some don't.

I'm a bit frustrated by this problem because there is never a resolution.

Could we nail it down? i would really like to resolve.

 

thanks

matt

Share this post


Link to post
Share on other sites
My extensions have permisison too. I haven't got any of my extension to work. If you don't set the permission you get a recording when you try to do an intercom call.

 

1. If you have multiple registrations, then the intercom will not work. I will just ring all the phones.

2. If you do not have the permission, then you will hear "... feature not avail...." message

 

Beyond these 2 cases, I would look at the INVITE message sent to the phone. That should have either "auto-answer" or "answer-after" tag in the call-info header.

Share this post


Link to post
Share on other sites

A ticket has been opened with an attached trace of the Invite message. The auto answer bit was set so there is something else different in the invite that is confusing the phone. This is occuring with Linksys SPA942 and SPA962 phones. This problem occurs with version 4.1 and 4.0.

Share this post


Link to post
Share on other sites
A ticket has been opened with an attached trace of the Invite message. The auto answer bit was set so there is something else different in the invite that is confusing the phone. This is occuring with Linksys SPA942 and SPA962 phones. This problem occurs with version 4.1 and 4.0.

 

Ok. The ringtones.xml was missing 'intercom' section for Linksys (and Aastra - someone else had similar issue). Even though the issue is resolved outside the forum, I am posting the new ringtones.xml file here for others to use, if they have similar problems. Whoever wants to use this file, you need to copy it to "<pbx install dir>/html" folder and restart the PBX.

ringtones.xml

Share this post


Link to post
Share on other sites

hi pbxsupport,

 

i am looking for a newer build than 4.0.1.3499.

4.0.1.3499 is still funky on my mac os x.

 

reco

Share this post


Link to post
Share on other sites
Ok. The ringtones.xml was missing 'intercom' section for Linksys (and Aastra - someone else had similar issue). Even though the issue is resolved outside the forum, I am posting the new ringtones.xml file here for others to use, if they have similar problems. Whoever wants to use this file, you need to copy it to "<pbx install dir>/html" folder and restart the PBX.

 

Hello,

I am actually experiencing the same problem initiating intercom and paging services on Grandstream GXP 2020 phones. The intercom feature code does work, but extension/phone doesn't auto answer, it only rings. Same is happening with the paging group extension.

 

I need to know what changes I should make in the ringtones.xml file for these phones to be able to auto answer if someone uses intercom feature code or paging group extension.

 

Also I can't seem to find the ringtones.xml file on my server. Where it should be located? I'm using pbxnsip Centos version.

 

I would appreciate if someone can help me with this issue.

Share this post


Link to post
Share on other sites
The reply on July 1 has the ringtone file attached. The problem is the file was missing.

 

I know the file is there, but the thing is where I should upload it. I don't have an html folder in my pbxnsip install directory. Should I create this directory/folder and upload the file there? Was this directory missing on your server too? Please confirm.

Share this post


Link to post
Share on other sites
I know the file is there, but the thing is where I should upload it. I don't have an html folder in my pbxnsip install directory. Should I create this directory/folder and upload the file there? Was this directory missing on your server too? Please confirm.

 

Yes, create the folder if you don't have it.

Share this post


Link to post
Share on other sites
Can I get an updated file that makes Aastra auto-answer/intercom function work?

 

The ringtones.xml that was attached in one of the earlier posts in this thread, should take care of the Aastra intercom too. You need to copy this file in the 'html' folder of the PBX and restart the PBX (there is another option - "Admin->Settings->Configuration:Reload Configuration Files" section. This option does not need the PBX reboot)

Share this post


Link to post
Share on other sites
yea we loaded it. Aastra intercom/paging still does not work.

 

linksys is ok.

 

Can you attach the SIP INVITE that is sent from PBX to Aastra? Also, please mention PBX and Aastra model/version.

Share this post


Link to post
Share on other sites

INVITE sip:603@192.168.10.55:5060;transport=udp SIP/2.0

Via: SIP/2.0/UDP 6.5.4.3:5060;branch=z9hG4bK-f6dad48abfa80aab2b7ebc47d6a55afa;rport

From: "Chris" <sip:601@6.5.4.3>;tag=830686032

To: "Yesica" <sip:603@6.5.4.3>

Call-ID: b67a76fa@pbx

CSeq: 26368 INVITE

Max-Forwards: 70

Contact: <sip:603@6.5.4.3:5060;transport=udp>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: nexSIP99/4.0.1.3499

Answer-Mode: Auto

Content-Type: application/sdp

Content-Length: 298

 

v=0

o=- 1197571218 1197571218 IN IP4 6.5.4.3

s=-

c=IN IP4 6.5.4.3

t=0 0

a=oa:offer

m=audio 16686 RTP/AVP 0 18 101

a=rtpmap:0 pcmu/8000

a=rtpmap:18 g729/8000

a=fmtp:18 annexb=no

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=rtcp-xr:rcvr-rtt=all voip-metrics

a=sendrecv

Share this post


Link to post
Share on other sites
Answer-Mode: Auto

 

This is defined in RFC 5373. Seems like the UA does not support this.

 

What you can do is to add a line to the ringtones.xml file and define how the device would like to have it.

ringtones.xml

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×