Jump to content

Windows app causing calls in a ring group to drop

Tech man

Recommended Posts

We have been having some issues with the windows app when it is being used in a ring group.  The app will work fine for a while and then all of a sudden, when a call comes into the ring group it rings for like 2 ring and drops the call.  If we have the user log out it works fine. Then when they log in again it works fine.

Link to comment
Share on other sites

  • 4 months later...


We are also having this issue.  I am on version Version 69.0.6.  We have seen that this isnt just ring group calls.  It is also outside calls directed thru an auto attendant, as well as station to station calls.  This seems lioke a pretty major bug.


Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

Hi team

I've had similar issue, where it will randomly stop ringing some extensions using softclient after couple of seconds.

some members would ring for longer period, some will drop after couple of seconds.
Running latest version 69.1.2

Have managed to resolve it with workaround by using extension through Chrome/edge webapp, but this way I've lost ability to associate app with tel protocol.

Ticket is still open with support

Link to comment
Share on other sites

  • 2 weeks later...

Hi all,

Since we're getting crickets from support on this still aside from chasing the "update to the latest version", we updated to 69.1.4 and verified the latest app from the Microsoft Store and retested.  I decided to do some further debugging on my own, and here's what I've got.


The scenario is someone dials into a DID, which is mapped to an AA. The caller dials my extension, 1119, and is then transferred. I get two rings, and everything is expected up to this point in the logs:

POST /rest/user/1119@somehost.somedomain.com/calls HTTP/1.1
Host: somehost.somedomain.com
Connection: keep-alive
Content-Length: 49
Accept: */*
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US
Content-Type: application/json; charset=utf-8
Cookie: session=xmkewf0yyhq8h9fx4nm7
Origin: localhost
Sec-Fetch-Dest: empty
Sec-Fetch-Mode: cors
Sec-Fetch-Site: cross-site
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) VodiaPhone/5.1.1 Chrome/91.0.4472.164 Electron/13.5.0 Safari/537.36

[8] 23:59:24.637	REST: POST /rest/user/1119@somehost.somedomain.com/calls

Huh? What the heck? The desktop app is sending a call reject. The critical line here is:

[8] 23:59:24.637    REST: POST /rest/user/1119@somehost.somedomain.com/calls

So, what happens next in the logs? The call rings out until voicemail picks up.

To double-triple verify what was happening, I ran the Vodia Desktop app with electron debugging and extracted the post requests into HARs, which are attached. Sure enough, the app on my Windows machine sends rejects without interaction from me.



Link to comment
Share on other sites

Well the reject is triggered when the Notification gets closed, see https://developer.mozilla.org/en-US/docs/Web/API/Notification/close_event. It seems it's not clear if this is because of a user interaction or because of the browser after a timeout closes the window. Looks like Electron has a different way of handling this than most of the browsers.

Anyway, IMHO it is not worth the trouble. As a short-term measure let's just ignore that event (69.1.4).

Then as the next step to clean this up, IMHO clicking on the notification should just bring the tab to the front and then the user can decide in the tab what to do — accept the call, reject the call, divert, and so on. Yes this will mean two clicks for the user, but because the browser notification essentially has only one action item available today, well that is what we have to work with. 

We are working on the next Windows store version that will handle notifications through the Windows API where multiple choices are possible and fit into the Windows user experience better than the browser does today. That will be. the ultimate answer to this annoying issue.

Link to comment
Share on other sites

@Vodia PBX Thanks for the reply, that makes a lot of sense. I dug through some of the Electron docs and I think you're right about it being related to notifications. Do you know what build of 69.1.4 a fix will be available in? I'm on the build from Nov 30 2023 14:04:04.

I re-tested this and the app is definitely interpreting Windows dismissing the notification as a user rejection.

On Windows, if you go to the settings app and then ease of access, you can change the duration of time that Windows shows the notification for. If I change the value to 30 seconds as in the screenshot below the App on Desktop works as expected for me. I think this might be a good workaround until a more permanent fix is deployed for the app.



Link to comment
Share on other sites

as this issue seems to be resolved now, there are more issues with headsets dropping the calls, notifications for calls not coming through, failed calls... This app just doesn't get anywhere. Going back to v68, and seriously considering another vendor... It is too bad as I really like the PBX logic and setup, just softphone app never worked OK




Link to comment
Share on other sites

1 minute ago, Vodia PBX said:

Well maybe we should just split the V68 Windows app from the V69 Windows app. Then we can just freeze the 68 app pretty much and don't have to deal with this when we add stuff to the V69 app.

FYI I think that post was before the 6.0.4 version it was the new version before the new new version ... ha ha. 

6.0.4 is ok at the moment. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...