Jump to content

Linksys SPA3102


stillabdul
 Share

Recommended Posts

Hello,

 

I have a Linksys spa3102. I have had difficulty trying to make this work with pbxnsip. Is there anyone out there who has these two working together? I have heard that I should set it up in pbxnsip as an extension. I have tried this, but no joy. There is no PSTN setup. It has been a couple of days. Any help would be appreciated.

 

Thanks.

Link to comment
Share on other sites

Hello,

 

I have a Linksys spa3102. I have had difficulty trying to make this work with pbxnsip. Is there anyone out there who has these two working together? I have heard that I should set it up in pbxnsip as an extension. I have tried this, but no joy. There is no PSTN setup. It has been a couple of days. Any help would be appreciated.

 

Thanks.

 

Very true, it took me a while to get it working fine ... since version 2.0

 

I have one running for several mounts on a test system, here's my settings:

 

PBX - Trunk should be configured with

username and password that match spa3102,

Outbound Proxy: xxx.xxx.xxx.xxx:port (for me it is 192.168.1.50:5061)

Send call to extension: AA (for me 10)

 

 

SPA3102:

firmware 3.2.6(GWa) newer will never register

 

under PSTN Line

Proxy: your PBX IP (for me 192.168.0.1)

Outbound Proxy: your SPA3102 IP (192.168.0.50)

Use Outbound Proxy: Yes

Use OB Proxy In Dialog: Yes

 

SIP Settings

SIP Port: 5061

 

Subscriber Information - this must match your Trunk set-up

Display Name:

User ID:

Password:

Use Auth ID:

Auth ID:

 

Dial Plans

Dial Plan 1: (S0< :10@192.168.0.1:5060>)

Dial Plan 2: nothing

Dial Plan 3: (xx.) - and all others

 

 

VoIP-To-PSTN Gateway Setup

VoIP-To-PSTN Gateway Enable: Yes

VoIP Caller Auth Method: none

VoIP PIN Max Retry: 3

One Stage Dialing: yes

Line 1 VoIP Caller DP: 1

VoIP Caller Default DP: 2

Line 1 Fallback DP: none

 

 

PSTN-To-VoIP Gateway Setup

PSTN-To-VoIP Gateway Enable: Yes

PSTN Caller Auth Method: None

PSTN Ring Thru Line 1: Yes

PSTN PIN Max Retry: 3

PSTN CID For VoIP CID: Yes

PSTN CID Number Prefix:

PSTN Caller Default DP: 1

Off Hook While Calling VoIP: no

Line 1 Signal Hook Flash To PSTN: Disabled

PSTN CID Name Prefix:

 

 

Line 1

DialPlan: (*xx.|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)

xx must match the max number of digets for your system ex if your system is 2 digets you must put xx, if 4 mut put xxxx

 

 

Hope this helps

Link to comment
Share on other sites

Yes, my problem, was that I needed to set it up as an extension and let it (SPA 3102) register as that extension. For dialing out, I would have to dial that extension number first, and then dial my intended external PSTN number. For incoming from PSTN->VOIP, my dial plan was simply (S0<:10>) where 10 is the extension I wanted the PSTN call sent to.

 

Thanks.

Link to comment
Share on other sites

Yes, my problem, was that I needed to set it up as an extension and let it (SPA 3102) register as that extension. For dialing out, I would have to dial that extension number first, and then dial my intended external PSTN number. For incoming from PSTN->VOIP, my dial plan was simply (S0<:10>) where 10 is the extension I wanted the PSTN call sent to.

 

Thanks.

 

1-You CANNOT register PSTN line as an extension, it MUST be as a trunk

2-You CANNOT dial an extension to get an external line! Unless I am mistaking or not getting your question.

 

You can use SPA3102 to dial true PSTN line without going to PBX at all, but why would you like to do that!

 

If you need to dial to extension to place an external call, you can use CallingCard feature. Mechanism will do what I understand from your question.

 

their is 2 thinkgs on SPA3102

one is FXO port (Your extension) and second FXO (your PSTN line) they need to work together!

 

 

Maube some will have an answer for you, I never used SPA3102 in a process like you are asking to do!

Link to comment
Share on other sites

1-You CANNOT register PSTN line as an extension, it MUST be as a trunk

2-You CANNOT dial an extension to get an external line! Unless I am mistaking or not getting your question.

 

Actually, I didn't want to set it up this way, but I saw in some wiki documentation that I needed to set it up as an extension. I reluctantly listened and was then able to make it work. Ans yes I can dial an extension to get an outside line. I don't like it, but it works. I would prefer to use a dial plan.

 

Thanks.

Link to comment
Share on other sites

Ok. Forgive me. I think I have it now.

I was able to set up the trunk this time. Initially it wouldn't work. I guess I also needed an extension for the spa3102 to register (otherwise it wouldn't). So I now have it where the trunk (sip gateway) and the dial plan works.

 

Thanks.

Link to comment
Share on other sites

Ok. Forgive me. I think I have it now.

I was able to set up the trunk this time. Initially it wouldn't work. I guess I also needed an extension for the spa3102 to register (otherwise it wouldn't). So I now have it where the trunk (sip gateway) and the dial plan works.

 

Thanks.

 

Just like YMSL, it is not completely clear to me what you want to achieve.

 

I would just like to inform you that it is possible to use the SPA3102 firmware 5.1.5(GWa) as a fully functional Gateway and SIP-FXS-client at the same time

If anybody is interested i could provide you with the configuration...

Link to comment
Share on other sites

Just like YMSL, it is not completely clear to me what you want to achieve.

 

I would just like to inform you that it is possible to use the SPA3102 firmware 5.1.5(GWa) as a fully functional Gateway and SIP-FXS-client at the same time

If anybody is interested i could provide you with the configuration...

 

Does anyone have access to this particular version SPA3102 firmware 5.1.5(GWa).

With 5.1.7 or 5.1.10 FXO never register (FAILD)

The only version I can have fully working is 3.2.6(GWa)

Link to comment
Share on other sites

  • 2 months later...
Guest gloryforixseal

Hi,

Im evaluating this product. Any ideas how to make it work with SPA9000? I can see the "Music On Hold Server" field on my PBX, but no idea how to make it registers with IMS. Your help is highly appreciated.

 

Thanks.

Link to comment
Share on other sites

  • 11 months later...

Hi I'm a university student in networking and telecommunications. Actually am working on a project. Our task is to use an SPA9000 and a SPA3102 to be able to make call using ip phones. We have been able to establish calls between the ip phones which we connected on the university network.

 

Now we have been asked to make the correct settings on the SPA9000 and the SPA3102 so that we can use the ip phones or analogue phone so that we can make the calls to any phone using a normal telephone line.

 

We don't know much about this as we are on our own to make the project functional.

 

PS: I apologize myself for my bad English. I'd be very thankful if you guys could help or at least give me some info which i could use to be able to progress on my project.

Link to comment
Share on other sites

  • 5 months later...

I am having difficulty with this and could do with some help.

 

I have a Linksys SPA3102 that is set up to handle calls between the PSTN and an account at my VOIP provider (to which I have SIP clients registered) and it all works. But I'm not getting very far transferring this to pbxnsip.

 

To start with, I'm only working on incoming PSTN calls getting to the specified PBX extension.

 

Currently, the SPA is configured to place a direct IP call to my provider (i.e. it's not registered). The dial plan contains the number to be dialled and the Subscriber info contains the authorisation info, i.e. username and password, the former is actually the same number as is being called but that's OK. This is all as the SPA should be configured and as I said, it works perfectly.

 

But when I simply change the address to that of the PBX rather than my provider's account (username and password are set the same to make this easier) it fails with the following error in the PBX's logfile:-

 

"Received incoming call without trunk information and user has not been found"

 

The trunk is set up in the PBX as a 'SIP Gateway' with the Account=UserName which is the same as on the SPA and the correct password. The Proxy is set to the address and port of the SPA (but that should only be relevant to outgoing calls that I am not troubleshooting here) and the domain is set to the address of the PBX host. In fact all the addresses are the DNS names rather than numeric, but they are all correctly resolvable so that shouldn't be an issue. Oh, it is set to send calls to the extension I want.

 

Part of my problem is understanding how the trunk is supposed to work. I presume this type does NOT try to register, so the correct methodology would appear to be direct IP calling and I would think that I am therefore correct to be calling:

 

<trunk username>@<pbx address>

 

which should get picked up by the PBX and handed to the extension as specified in the Gateway Trunk setup, but it doesn't. I just get that error.

 

What do I need to set in the Trunk to tell it to accept these calls?

Link to comment
Share on other sites

The trunk is set up in the PBX as a 'SIP Gateway' with the Account=UserName which is the same as on the SPA and the correct password. The Proxy is set to the address and port of the SPA (but that should only be relevant to outgoing calls that I am not troubleshooting here) and the domain is set to the address of the PBX host. In fact all the addresses are the DNS names rather than numeric, but they are all correctly resolvable so that shouldn't be an issue. Oh, it is set to send calls to the extension I want.

........

What do I need to set in the Trunk to tell it to accept these calls?

 

- Currently i am using the 'Outbound Proxy' Trunk-Type for communication with the SPA3102.

- I recommend using IP-Adresses instead of DNS-names in this trouble-shooting stage.

- Be sure to use the WAN connector of the SPA to connect to your PBX.

- Be sure you see all settings (advanced mode & admin mode ?)

- Configure the SPA with the IP of the PBX and account properties, this is how the SPA connects to the PBX.

 

Good luck,

Rudi

Link to comment
Share on other sites

- Currently i am using the 'Outbound Proxy' Trunk-Type for communication with the SPA3102.

- I recommend using IP-Adresses instead of DNS-names in this trouble-shooting stage.

- Be sure to use the WAN connector of the SPA to connect to your PBX.

- Be sure you see all settings (advanced mode & admin mode ?)

- Configure the SPA with the IP of the PBX and account properties, this is how the SPA connects to the PBX.

 

Good luck,

Rudi

Problem is, I don't know what the various fields are in snomONE. I know what all the information in the SPA is for, I have set it up to successfully work with my VOIP provider. What I don't know is which bits of info in the PBX relate to which function. In the Trunk setup:-

 

Type: Not sure what the difference is between SIP Gateway and SIP Proxy. Neither work.

 

Proxy Address: I assumed this was where to send outbound calls and would therefore be the SPA3102, but the PBX is then trying to register to the SPA which is always going to fail as it is NOT a SIP server. Does this have ANYTHING to do with incoming calls to the Gateway?

 

Username and Password: I assume these would be used by the SPA to authenticate.

 

Account: No idea what this is. What does this relate to in the SPA's configuration?

 

I'm sure if I can get these correct it will work, but right now I'm having difficulty cross referencing the various fields between the 2 devices.

Link to comment
Share on other sites

We only use patton so i'm not familiar with spa 3102.

but maybe this helps?

 

http://kiwi.pbxnsip.com/index.php/Linksys

 

Matt

I had seen that, but it is fundamentally wrong and shows a lack of understanding of the SPA by the author. Once you understand how the SPA is logically structured, you don't need to bounce the calls around as suggested in that article.

 

It took me some time, but I now understand the relevant bits of the SPA and as I said, it has been working as a PSTN <-> VOIP gateway for the last few months, but that was with my VOIP provider. In this case, the info used was a username and password (with which the SPA was able to authenticate to my provider's server) and then the number that was the target of the connection. So a PSTN call would arrive at the SPA and it would immediately place a call with my provider to the specified number. The PSTN line continues to ring until the VOIP call is picked up. This is straightforward PSTN -> VOIP gateway, no messing around with dialling in to get another dial tone in order to then make cheap International calls. The SPA can do that, but that's not really a function for a straight PSTN gateway to an IP PBX and certainly not what I want.

 

Anyway, it works with my provider. But I cannot yet get it to work with snomONE. I believe the problem is that snomONE is not correctly configured to accept the call. It sees the incoming call and negotiation commences, but the PBX eventually reports that it cannot find any trunk information and the call fails. So I need to somehow configure it to understand that this is a call coming in on that trunk (i.e. the PSTN gateway) and then it can be directed to the extension specified for the trunk.

 

But the trunk configuration is for incoming AND outgoing calls and it is not clear which of the displayed fields relate to which direction of call. As I said in my last post, I am trying to gain a better understanding of what the various fields mean so that I can then (hopefully) fill them with the correct info and it will all work perfectly:-)

 

The snomONE manual is not entirely clear on what the fields all mean and just provides examples which are simply numbers, but with no indication of to what they refer. Are they telephone numbers, IP addresses or what? It shows the username as what looks like an IP address followed by a port number, but how can that be a username? In any case is that for incoming or outgoing calls? Or is the manual simply wrong as it looks suspiciously like they got the fields mixed up when they printed it.

 

Sorry, rambling again. But I have the M9 now to set up and so need to crack this PSTN Gateway problem.

Link to comment
Share on other sites

OK, got it working, but had to enter the SPA's IP address (or FQDN) in the "Explicitly list addresses for inbound traffic:" field. Once this was done the PBX was able to recognise the call as coming on on that trunk and deal with it appropriately.

 

Whilst this is not a problem, I am not entirely sure why it was necessary since it seems to me it ought to have been able to do this without that last step. So if anyone can shed any light on this I'd be grateful.

 

But in the meantime it is working for inbound and outbound calls with the former providing the CID of the real calling party, i.e. the SPA is receiving it from the PSTN and passing it on to the PBX. Perfect:-)

Link to comment
Share on other sites

  • 2 months later...

Just like YMSL, it is not completely clear to me what you want to achieve.

 

I would just like to inform you that it is possible to use the SPA3102 firmware 5.1.5(GWa) as a fully functional Gateway and SIP-FXS-client at the same time

If anybody is interested i could provide you with the configuration...

 

Hello,

 

Could you provide this configuration? I'm having trouble setting up SPA3102 with pbxnsip

 

Thanks

Link to comment
Share on other sites

  • 3 weeks later...

Remember snom ONE has some restriction on the non-snom devices. If you want to use SPA as a gateway, then all you have to do is to create a 'gateway' trunk on the PBX and point that to SPA IP address. Then use this trunk in the PBX dialplan for any specific patterns.

I don't know what i'm doing wrong:

 

In the snom One i have configured spa trunk

 

Name: spa

Type: gateway

To: sip

RegPass: ********

Direction:

Disabled: false

Global: false

Display: SPA-3102

RegAccount: 620

RegRegistrar: 192.168.2.202

RegKeep:

RegUser: 620

Icid:

Require:

OutboundProxy: 192.168.2.202

Ani:

DialExtension: 72

Prefix:

Trusted: false

AcceptRedirect: false

RfcRtp: false

Analog: false

SendEmail:

UseUuid: false

Ring180: false

Failover: never

Privacy: rpi

Glob:

RequestTimeout:

Codecs:

CodecLock: true

Expires: 3600

FromUser:

Tel: true

TranscodeDtmf: false

AssociatedAddresses:

InterOffice: false

DialPlan:

Colines:

DialogPermission:

 

------------------

Line 1 on SP3102:

 

Line enable: no

 

------------------

 

PSTN Line on SPA3102:

 

Line enable: yes

SIP Transport: UDP

SIP port: 5060

Proxy: 192.168.2.201 (PBX's IP)

Outbound proxy: 192.168.2.201

Diplay name: SPA-3102

User ID: 620

PAssword: ****

Use Auth ID: yes

Auth ID: 620

 

 

In the log i see:

 

[5] 2011/02/08 17:16:44: SIP Rx udp:192.168.2.202:5060:

REGISTER sip:192.168.2.201 SIP/2.0

Via: SIP/2.0/UDP 192.168.2.202:5060;branch=z9hG4bK-41b79b68

From: SPA-3102 <sip:620@192.168.2.201>;tag=21eee40ca9cebfaco1

To: SPA-3102 <sip:620@192.168.2.201>

Call-ID: 5518cddc-91715e7c@192.168.2.202

CSeq: 2882 REGISTER

Max-Forwards: 70

Contact: SPA-3102 <sip:620@192.168.2.202:5060>;expires=3600

User-Agent: Linksys/SPA3102-5.1.10(GW)

Content-Length: 0

Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER

Supported: x-sipura, replaces

 

 

[5] 2011/02/08 17:16:52: SIP Tx udp:192.168.2.202:5060:

SIP/2.0 404 Not Found

Via: SIP/2.0/UDP 192.168.2.202:5060;branch=z9hG4bK-41b79b68

From: SPA-3102 <sip:620@192.168.2.201>;tag=21eee40ca9cebfaco1

To: SPA-3102 <sip:620@192.168.2.201>;tag=eb60de0482

Call-ID: 5518cddc-91715e7c@192.168.2.202

CSeq: 2882 REGISTER

Content-Length: 0

 

 

Where am I wrong?

Link to comment
Share on other sites

Maybe there is a misunderstanding. Trunks can register, but not receive registrations. Extensions receive registrations, but not trunks. You dont have to register the device, just send the traffic there any you are all set.

 

If you want to send calls to the PSTN through a gateway that is e.g. behind NAT, then you can register the device to an extension and in the dial plan you can use the option to send a call to an extension.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...